Linux Today: Linux News On Internet Time.





More on LinuxToday


How To Lock Installed RPM Package Update

Feb 27, 2012, 21:00 (1 Talkback[s])

"Lets assume you have a RPM Package installed called firefox-3.6.17-1.el5.centos and you don't want to update it even if a newer version is available. This can by done by using YUM plugin called yum-versionlock. This plugin allows you to lock package update. Just you need to add the list of packages that you want to lock their updates with their version and architecture in the lock file /etc/yum/pluginconf.d/versionlock.list.

So, whenever you update your system these packages where excluded by the YUM, because yum reads the file before updating the packages.

Complete Story

Related Stories: