Linux Today: Linux News On Internet Time.
Search Linux Today
Linux News Sections:  Developer -  High Performance -  Infrastructure -  IT Management -  Security -  Storage -
Linux Today Navigation
LT Home
Contribute
Contribute
Link to Us
Linux Jobs


Top White Papers

More on LinuxToday


Gentoo Linux Advisories: lcdproc, xine, ssmtp

Apr 28, 2004, 02:29 (0 Talkback[s])

Gentoo Linux Security Advisory GLSA 200404-19

http://security.gentoo.org/


Severity: Normal
Title: Buffer overflows and format string vulnerabilities in LCDproc
Date: April 27, 2004
Bugs: #47340
ID: 200404-19


Synopsis

Multiple remote vulnerabilities have been found in the LCDd server, allowing execution of arbitrary code with the rights of the LCDd user.

Background

LCDproc is a program that displays various bits of real-time system information on an LCD. It makes use of a local server (LCDd) to collect information to display on the LCD.

Affected packages

Package Vulnerable Unaffected
1 app-misc/lcdproc <= 0.4.4-r1 >= 0.4.5

Description

Due to insufficient checking of client-supplied data, the LCDd server is susceptible to two buffer overflows and one string buffer vulnerability. If the server is configured to listen on all network interfaces (see the Bind parameter in LCDproc configuration), these vulnerabilities can be triggered remotely.

Impact

These vulnerabilities allow an attacker to execute code with the rights of the user running the LCDproc server. By default, this is the "nobody" user.

Workaround

A workaround is not currently known for this issue. All users are advised to upgrade to the latest version of the affected package.

Resolution

LCDproc users should upgrade to version 0.4.5 or later:

    # emerge sync
    # emerge -pv ">=app-misc/lcdproc-0.4.5"
    # emerge ">=app-misc/lcdproc-0.4.5"

References

[ 1 ] LCDproc advisory

http://lists.omnipotent.net/pipermail/lcdproc/2004-April/008884.html

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200404-19.xml

Concerns?

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at http://bugs.gentoo.org.

License

Copyright 2004 Gentoo Technologies, Inc; referenced text belongs to its owner(s).

The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0


Gentoo Linux Security Advisory GLSA 200404-20

http://security.gentoo.org/


Severity: Normal
Title: Multiple vulnerabilities in xine
Date: April 27, 2004
Bugs: #45448, #48107, #48108
ID: 200404-20


Synopsis

Several vulnerabilities have been found in xine-ui and xine-lib, potentially allowing an attacker to overwrite files with the rights of the user.

Background

xine is a multimedia player allowing to play back CDs, DVDs, and VCDs and decoding multimedia files like AVI, MOV, WMV, and MP3 from local disk drives, and displays multimedia streamed over the Internet. It is available in Gentoo as a reusable library (xine-lib) with a standard user interface (xine-ui).

Affected packages

Package Vulnerable Unaffected
1 media-video/xine-ui <= 0.9.23-r1 >= 0.9.23-r2
2 media-libs/xine-lib <= 1_rc3-r2 >= 1_rc3-r3

2 affected packages on all of their supported architectures.

Description

Several vulnerabilities were found in xine-ui and xine-lib. By opening a malicious MRL in any xine-lib based media player, an attacker can write arbitrary content to an arbitrary file, only restricted by the permissions of the user running the application. By opening a malicious playlist in the xine-ui media player, an attacker can write arbitrary content to an arbitrary file, only restricted by the permissions of the user running xine-ui. Finally, a temporary file is created in an insecure manner by the xine-check and xine-bugreport scripts, potentially allowing a local attacker to use a symlink attack.

Impact

These three vulnerabilities may alow an attacker to corrupt system files, thus potentially leading to a Denial of Service. It is also theoretically possible, though very unlikely, to use these vulnerabilities to elevate the privileges of the attacker.

Workaround

There is no known workaround at this time. All users are advised to upgrade to the latest available versions of xine-ui and xine-lib.

Resolution

All users of xine-ui or another xine-based player should upgrade to the latest stable versions:

    # emerge sync
    # emerge -pv ">=media-video/xine-ui-0.9.23-r2"
    # emerge ">=media-video/xine-ui-0.9.23-r2"
    # emerge -pv ">=media-libs/xine-lib-1_rc3-r3"
    # emerge ">=media-libs/xine-lib-1_rc3-r3"

References

[ 1 ] Xine Security Advisories

http://xinehq.de/index.php/security

[ 2 ] xine-bugreport and xine-check vulnerability

http://nettwerked.mg2.org/advisories/xinebug

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200404-20.xml

Concerns?

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at http://bugs.gentoo.org.

License

Copyright 2004 Gentoo Technologies, Inc; referenced text belongs to its owner(s).

The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0


Gentoo Linux Security Advisory GLSA 200404-18

http://security.gentoo.org/


Severity: High
Title: Multiple Vulnerabilities in ssmtp
Date: April 26, 2004
Bugs: #47918, #48435
ID: 200404-18


Synopsis

There are multiple format string vulnerabilities in the SSMTP package, which may allow an attacker to run arbitrary code with ssmtp's privileges (potentially root).

Background

SSMTP is a very simple mail transfer agent (MTA) that relays mail from the local machine to another SMTP host. It is not designed to function as a full mail server; its sole purpose is to relay mail.

Affected packages

Package Vulnerable Unaffected
1 net-mail/ssmtp <= 2.60.4-r2 >= 2.60.7

Description

There are two format string vulnerabilities inside the log_event() and die() functions of ssmtp. Strings from outside ssmtp are passed to various printf()-like functions from within log_event() and die() as format strings. An attacker could cause a specially-crafted string to be passed to these functions, and potentially cause ssmtp to execute arbitrary code.

Impact

If ssmtp connects to a malicious mail relay server, this vulnerability can be used to execute code with the rights of the mail sender, including root.

Workaround

There is no known workaround at this time. All users are advised to upgrade to the latest available version of ssmtp.

Resolution

All users are advised to upgrade to the latest available version of ssmtp.

    # emerge sync
    # emerge -pv ">=net-mail/ssmtp-2.60.7"
    # emerge ">=net-mail/ssmtp-2.60.7"

References

[ 1 ] Secunia Advisory

http://secunia.com/advisories/11378/

[ 2 ] CVE Reference

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0156

[ 3 ] Debian Advisory

http://lists.debian.org/debian-security-announce/debian-security-announce-2004/msg00084.html

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200404-18.xml

Concerns?

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at http://bugs.gentoo.org.

License

Copyright 2004 Gentoo Technologies, Inc; referenced text belongs to its owner(s).

The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0