Linux Today: Linux News On Internet Time.

More on LinuxToday

Gentoo Linux Advisory: Mailman

Jun 10, 2004, 03:13 (0 Talkback[s])

Gentoo Linux Security Advisory GLSA 200406-04

Severity: Normal
Title: Mailman: Member password disclosure vulnerability
Date: June 09, 2004
Bugs: #51671
ID: 200406-04


Mailman contains a bug allowing 3rd parties to retrieve member passwords.


Mailman is a python-based mailing list server with an extensive web interface.

Affected packages

Package Vulnerable Unaffected
1 net-mail/mailman < 2.1.5 >= 2.1.5


Mailman contains an unspecified vulnerability in the handling of request emails.


By sending a carefully crafted email request to the mailman server an attacker could obtain member passwords.


There is no known workaround at this time.


All users of Mailman should upgrade to the latest stable version:

    # emerge sync
    # emerge -pv ">=net-mail/mailman-2.1.5"
    # emerge ">=net-mail/mailman-2.1.5"


[ 1 ] Mailman 2.1.5 Release Announcement

[ 2 ] CAN-2004-0412


This GLSA and any updates to it are available for viewing at the Gentoo Security Website:


Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to or alternatively, you may file a bug at


Copyright 2004 Gentoo Technologies, Inc; referenced text belongs to its owner(s).

The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.