Linux Today: Linux News On Internet Time.
Search Linux Today
Linux News Sections:  Developer -  High Performance -  Infrastructure -  IT Management -  Security -  Storage -
Linux Today Navigation
LT Home
Contribute
Contribute
Link to Us
Linux Jobs


Top White Papers

More on LinuxToday


Security Digest: January 26, 2005

Jan 27, 2005, 04:45 (0 Talkback[s])

Debian GNU/Linux


Debian Security Advisory DSA 660-1 security@debian.org
http://www.debian.org/security/ Martin Schulze
January 26th, 2005 http://www.debian.org/security/faq


Package : kdebse
Vulnerability : missing return value check
Problem-Type : local
Debian-specific: no
CVE ID : CAN-2005-0078

Raphaél Enrici discovered that the KDE screensaver can crash under certain local circumstances. This can be exploited by an attacker with physical access to the workstation to take over the desktop session.

For the stable distribution (woody) this problem has been fixed in version 2.2.2-14.9.

This problem has been fixed upstream in KDE 3.0.5 and is therefore fixed in the unstable (sid) and testing (sarge) distributions already.

We recommend that you upgrade your kscreensaver package.

Upgrade Instructions


wget url

will fetch the file for you
dpkg -i file.deb

will install the referenced file.

If you are using the apt-get package manager, use the line for sources.list as given below:

apt-get update

will update the internal database apt-get upgrade

will install corrected packages

You may use an automated update by adding the resources from the footer to the proper configuration.

Debian GNU/Linux 3.0 alias woody


Source archives:

http://security.debian.org/pool/updates/main/k/kdebase/kdebase_2.2.2-14.9.dsc
Size/MD5 checksum: 1155 dfe0d609c615fe8b7935892ccd0dab4e
http://security.debian.org/pool/updates/main/k/kdebase/kdebase_2.2.2-14.9.diff.gz
Size/MD5 checksum: 73052 abcc2cbac602c1c557fad0816e970db5
http://security.debian.org/pool/updates/main/k/kdebase/kdebase_2.2.2.orig.tar.gz
Size/MD5 checksum: 13035693 3c17b6821bbd05c7e04682c70cb7de8a

Architecture independent components:

http://security.debian.org/pool/updates/main/k/kdebase/kdebase-doc_2.2.2-14.9_all.deb
Size/MD5 checksum: 3140996 17745ec3c454d65516d6e19af77ba080
http://security.debian.org/pool/updates/main/k/kdebase/kdewallpapers_2.2.2-14.9_all.deb
Size/MD5 checksum: 962194 a6e045e59fb5f5d409eef6f91cafda37

Alpha architecture:

http://security.debian.org/pool/updates/main/k/kdebase/kate_2.2.2-14.9_alpha.deb
Size/MD5 checksum: 488956 cebb2cb36c834c6693cad6ff9214cf15
http://security.debian.org/pool/updates/main/k/kdebase/kdebase_2.2.2-14.9_alpha.deb
Size/MD5 checksum: 6991454 4c054e1747b10c4465f6430c3329eb13
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-audiolibs_2.2.2-14.9_alpha.deb
Size/MD5 checksum: 108078 1103e988ce6817b8f7085ed7bf57f7d7
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-dev_2.2.2-14.9_alpha.deb
Size/MD5 checksum: 49514 0a60e5d0b2ce1f848d82ef20c5167691
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-libs_2.2.2-14.9_alpha.deb
Size/MD5 checksum: 1988950 d75b23f2b08b1611a6947c26044ce641
http://security.debian.org/pool/updates/main/k/kdebase/kdm_2.2.2-14.9_alpha.deb
Size/MD5 checksum: 436126 b39964dfd1a9090c8fef9265829d9e57
http://security.debian.org/pool/updates/main/k/kdebase/konqueror_2.2.2-14.9_alpha.deb
Size/MD5 checksum: 2229054 6e57e8b0639bb780707c1a4e747d5cf6
http://security.debian.org/pool/updates/main/k/kdebase/konsole_2.2.2-14.9_alpha.deb
Size/MD5 checksum: 538632 39ee4795e5ab89cf52704fd4c2db06fa
http://security.debian.org/pool/updates/main/k/kdebase/kscreensaver_2.2.2-14.9_alpha.deb
Size/MD5 checksum: 482956 4482d999c2981e95db3a3d47f4444f96
http://security.debian.org/pool/updates/main/k/kdebase/libkonq-dev_2.2.2-14.9_alpha.deb
Size/MD5 checksum: 46042 8d894c8f9f1c376f5a5300a94fe9b04b
http://security.debian.org/pool/updates/main/k/kdebase/libkonq3_2.2.2-14.9_alpha.deb
Size/MD5 checksum: 270520 1a6e146175770e64d965ffd031abd519

ARM architecture:

http://security.debian.org/pool/updates/main/k/kdebase/kate_2.2.2-14.9_arm.deb
Size/MD5 checksum: 418864 e203c7a41042168e7ec089cc08fcdce9
http://security.debian.org/pool/updates/main/k/kdebase/kdebase_2.2.2-14.9_arm.deb
Size/MD5 checksum: 6520888 09ba2542f77611bbc392185a34b6a235
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-audiolibs_2.2.2-14.9_arm.deb
Size/MD5 checksum: 86506 40f71a0729f46cc49c1b014d5e5e9f35
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-dev_2.2.2-14.9_arm.deb
Size/MD5 checksum: 48612 afe2715d9a3eee6a20a8ac5bd200172e
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-libs_2.2.2-14.9_arm.deb
Size/MD5 checksum: 1680906 c0530300b569a5a37d722f681c0701d5
http://security.debian.org/pool/updates/main/k/kdebase/kdm_2.2.2-14.9_arm.deb
Size/MD5 checksum: 390882 cdef2636462f0b210de63271b4c4f771
http://security.debian.org/pool/updates/main/k/kdebase/konqueror_2.2.2-14.9_arm.deb
Size/MD5 checksum: 1926580 76e6578bc030bd975b1a6795b3957a5d
http://security.debian.org/pool/updates/main/k/kdebase/konsole_2.2.2-14.9_arm.deb
Size/MD5 checksum: 457596 ec72c3fbb862b4658365f7e1a3c879a3
http://security.debian.org/pool/updates/main/k/kdebase/kscreensaver_2.2.2-14.9_arm.deb
Size/MD5 checksum: 375628 72ef3fa402a0a7431df669a88d97def4
http://security.debian.org/pool/updates/main/k/kdebase/libkonq-dev_2.2.2-14.9_arm.deb
Size/MD5 checksum: 46046 33ce8b120a20172ebdbaf87c87592169
http://security.debian.org/pool/updates/main/k/kdebase/libkonq3_2.2.2-14.9_arm.deb
Size/MD5 checksum: 216052 e6f3a3b8241e0db05f55c8415e510ecb

Intel IA-32 architecture:

http://security.debian.org/pool/updates/main/k/kdebase/kate_2.2.2-14.9_i386.deb
Size/MD5 checksum: 407970 0b38c2916480159a70f4099b75053cf4
http://security.debian.org/pool/updates/main/k/kdebase/kdebase_2.2.2-14.9_i386.deb
Size/MD5 checksum: 6486276 ad3dadbc95b46598105de11f7e740a7a
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-audiolibs_2.2.2-14.9_i386.deb
Size/MD5 checksum: 84028 b9aa9ee1f7f57d6e9e122a2c28192d6f
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-dev_2.2.2-14.9_i386.deb
Size/MD5 checksum: 47816 036e86f41c43ec6f2ec65ebe77f8d758
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-libs_2.2.2-14.9_i386.deb
Size/MD5 checksum: 1653012 5b195fdbb260cb9dd909cd7d440e65d9
http://security.debian.org/pool/updates/main/k/kdebase/kdm_2.2.2-14.9_i386.deb
Size/MD5 checksum: 395818 0ba48e2582510942777b42b9c961d0c0
http://security.debian.org/pool/updates/main/k/kdebase/konqueror_2.2.2-14.9_i386.deb
Size/MD5 checksum: 1929328 b31b3b160c849141cc1bd1a78e3c6c55
http://security.debian.org/pool/updates/main/k/kdebase/konsole_2.2.2-14.9_i386.deb
Size/MD5 checksum: 459074 69e1a604af6da9f2a066db19024faf43
http://security.debian.org/pool/updates/main/k/kdebase/kscreensaver_2.2.2-14.9_i386.deb
Size/MD5 checksum: 396370 10708fe013b78828a1a99fb3d97838db
http://security.debian.org/pool/updates/main/k/kdebase/libkonq-dev_2.2.2-14.9_i386.deb
Size/MD5 checksum: 46048 bbad375447a928a1a139a4904a861de8
http://security.debian.org/pool/updates/main/k/kdebase/libkonq3_2.2.2-14.9_i386.deb
Size/MD5 checksum: 221032 c78e8eae29e20bad3e41658ad78787eb

Intel IA-64 architecture:

http://security.debian.org/pool/updates/main/k/kdebase/kate_2.2.2-14.9_ia64.deb
Size/MD5 checksum: 611890 5a0c52e8b157dbd2e64b9389a1b03950
http://security.debian.org/pool/updates/main/k/kdebase/kdebase_2.2.2-14.9_ia64.deb
Size/MD5 checksum: 7541710 448f5fa9121adaa13ce78c0d686fa76a
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-audiolibs_2.2.2-14.9_ia64.deb
Size/MD5 checksum: 120072 220e21286d13a231a678d52800c7362e
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-dev_2.2.2-14.9_ia64.deb
Size/MD5 checksum: 52250 842516a87bc2ab2a7e4025841c8ecb3d
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-libs_2.2.2-14.9_ia64.deb
Size/MD5 checksum: 2465710 732bd2c1c5d39d404c2a14443314e440
http://security.debian.org/pool/updates/main/k/kdebase/kdm_2.2.2-14.9_ia64.deb
Size/MD5 checksum: 538810 62b9975f93d1b1d749234999b315afbf
http://security.debian.org/pool/updates/main/k/kdebase/konqueror_2.2.2-14.9_ia64.deb
Size/MD5 checksum: 2490004 1cf73d089139a55dcb25598cc947aa17
http://security.debian.org/pool/updates/main/k/kdebase/konsole_2.2.2-14.9_ia64.deb
Size/MD5 checksum: 598614 b600efadf0f8cb66fe826640ada3fe8b
http://security.debian.org/pool/updates/main/k/kdebase/kscreensaver_2.2.2-14.9_ia64.deb
Size/MD5 checksum: 551750 8a55a06301a84473009226cb5976042e
http://security.debian.org/pool/updates/main/k/kdebase/libkonq-dev_2.2.2-14.9_ia64.deb
Size/MD5 checksum: 46036 f9681cb495e56a3224f8bca6d9d68b0a
http://security.debian.org/pool/updates/main/k/kdebase/libkonq3_2.2.2-14.9_ia64.deb
Size/MD5 checksum: 347646 ef3d8d7209c297c995a3f7b042d747be

HP Precision architecture:

http://security.debian.org/pool/updates/main/k/kdebase/kate_2.2.2-14.9_hppa.deb
Size/MD5 checksum: 514094 2eb07e6acd45bb7847807a69f1c2c6d6
http://security.debian.org/pool/updates/main/k/kdebase/kdebase_2.2.2-14.9_hppa.deb
Size/MD5 checksum: 6986014 ed12ea654a6d000bce9def3696c27fb4
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-audiolibs_2.2.2-14.9_hppa.deb
Size/MD5 checksum: 106130 f51a4108d6101e52db2455dbc646ffba
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-dev_2.2.2-14.9_hppa.deb
Size/MD5 checksum: 49686 887499fa02280212867459c77c80ed63
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-libs_2.2.2-14.9_hppa.deb
Size/MD5 checksum: 2085756 548a99abdf666883f8aa9cf49061cb17
http://security.debian.org/pool/updates/main/k/kdebase/kdm_2.2.2-14.9_hppa.deb
Size/MD5 checksum: 445852 fded136e5ddb52ab29cafd7d69e55d7e
http://security.debian.org/pool/updates/main/k/kdebase/konqueror_2.2.2-14.9_hppa.deb
Size/MD5 checksum: 2190354 35757070838eb023fc43f6baf9a201a9
http://security.debian.org/pool/updates/main/k/kdebase/konsole_2.2.2-14.9_hppa.deb
Size/MD5 checksum: 517774 eead16edc06d70e083a2e06a9a539459
http://security.debian.org/pool/updates/main/k/kdebase/kscreensaver_2.2.2-14.9_hppa.deb
Size/MD5 checksum: 456948 c408303889ceda15ff248eaeb0d1e61d
http://security.debian.org/pool/updates/main/k/kdebase/libkonq-dev_2.2.2-14.9_hppa.deb
Size/MD5 checksum: 46040 20e7c3be70470cf60093da3b73b1067d
http://security.debian.org/pool/updates/main/k/kdebase/libkonq3_2.2.2-14.9_hppa.deb
Size/MD5 checksum: 260306 437312542ffb7486c18d97bc9f1fe48b

Motorola 680x0 architecture:

http://security.debian.org/pool/updates/main/k/kdebase/kate_2.2.2-14.9_m68k.deb
Size/MD5 checksum: 403884 7844857493ec07c68f1a9f568d9cddb4
http://security.debian.org/pool/updates/main/k/kdebase/kdebase_2.2.2-14.9_m68k.deb
Size/MD5 checksum: 6472796 ac6f1697ec714ab8f11ad2cbed1352a0
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-audiolibs_2.2.2-14.9_m68k.deb
Size/MD5 checksum: 84792 c322d9cb2ff703cde4415fc97c2b6c72
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-dev_2.2.2-14.9_m68k.deb
Size/MD5 checksum: 47580 2f7b713e25132a6c8c0018572ee192c9
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-libs_2.2.2-14.9_m68k.deb
Size/MD5 checksum: 1633348 fdd16124da1626012ae6b52000acf20c
http://security.debian.org/pool/updates/main/k/kdebase/kdm_2.2.2-14.9_m68k.deb
Size/MD5 checksum: 381482 7ffef06bb41a5c38d6a1dce88f8635b5
http://security.debian.org/pool/updates/main/k/kdebase/konqueror_2.2.2-14.9_m68k.deb
Size/MD5 checksum: 1915896 60a42a0b6d2323c35a490534640acbd2
http://security.debian.org/pool/updates/main/k/kdebase/konsole_2.2.2-14.9_m68k.deb
Size/MD5 checksum: 458218 6b2ef323d7faaed0cb06cd9d13656436
http://security.debian.org/pool/updates/main/k/kdebase/kscreensaver_2.2.2-14.9_m68k.deb
Size/MD5 checksum: 394510 6e442e47b60fcce94af235e51c40bdda
http://security.debian.org/pool/updates/main/k/kdebase/libkonq-dev_2.2.2-14.9_m68k.deb
Size/MD5 checksum: 46044 52ae57a7c907641c2b59320fb63bfc20
http://security.debian.org/pool/updates/main/k/kdebase/libkonq3_2.2.2-14.9_m68k.deb
Size/MD5 checksum: 212060 0a4be5dfc31ae0e3deeb8d110b9ce859

Big endian MIPS architecture:

http://security.debian.org/pool/updates/main/k/kdebase/kate_2.2.2-14.9_mips.deb
Size/MD5 checksum: 413590 9dc1fe8f2522d18766b9d24ef6545f79
http://security.debian.org/pool/updates/main/k/kdebase/kdebase_2.2.2-14.9_mips.deb
Size/MD5 checksum: 6476868 1ccdb4b6e924c6df6c7b03d5e325ac5e
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-audiolibs_2.2.2-14.9_mips.deb
Size/MD5 checksum: 81234 e916912d6d4d9b67fbb30e31029e5f4a
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-dev_2.2.2-14.9_mips.deb
Size/MD5 checksum: 49570 87614b6d2b7ea08ae1ffbfab2a4251b6
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-libs_2.2.2-14.9_mips.deb
Size/MD5 checksum: 1531226 d399256ffcd12ab9928a83da0885fe72
http://security.debian.org/pool/updates/main/k/kdebase/kdm_2.2.2-14.9_mips.deb
Size/MD5 checksum: 381466 2aebf97b0c92505105dc2865dce3766f
http://security.debian.org/pool/updates/main/k/kdebase/konqueror_2.2.2-14.9_mips.deb
Size/MD5 checksum: 1884966 9ff5812fab1142811f4f92143f4ddcbd
http://security.debian.org/pool/updates/main/k/kdebase/konsole_2.2.2-14.9_mips.deb
Size/MD5 checksum: 477618 376a2f114ddd58f04ae646197f045c58
http://security.debian.org/pool/updates/main/k/kdebase/kscreensaver_2.2.2-14.9_mips.deb
Size/MD5 checksum: 420094 8323871f3474733b911379b5a96378bf
http://security.debian.org/pool/updates/main/k/kdebase/libkonq-dev_2.2.2-14.9_mips.deb
Size/MD5 checksum: 46046 3e0327aee72d00aa42dea64c358c397b
http://security.debian.org/pool/updates/main/k/kdebase/libkonq3_2.2.2-14.9_mips.deb
Size/MD5 checksum: 206052 42ab931bcf3ddd9dc4d85d167ea62438

Little endian MIPS architecture:

http://security.debian.org/pool/updates/main/k/kdebase/kate_2.2.2-14.9_mipsel.deb
Size/MD5 checksum: 408664 b3099a63b4094579c91b410b49d83529
http://security.debian.org/pool/updates/main/k/kdebase/kdebase_2.2.2-14.9_mipsel.deb
Size/MD5 checksum: 6448420 e14dd39e3da6f208c981e954e5751351
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-audiolibs_2.2.2-14.9_mipsel.deb
Size/MD5 checksum: 80674 33fc4fb06df59e03876c8ffad32c95ae
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-dev_2.2.2-14.9_mipsel.deb
Size/MD5 checksum: 49652 f60498f2dfc73ebb17fa09c42a1f7087
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-libs_2.2.2-14.9_mipsel.deb
Size/MD5 checksum: 1513044 64899a5cff5d59b741dc0cf4ff7eddf4
http://security.debian.org/pool/updates/main/k/kdebase/kdm_2.2.2-14.9_mipsel.deb
Size/MD5 checksum: 379328 7e9192a349f3010dd507767585c0a94b
http://security.debian.org/pool/updates/main/k/kdebase/konqueror_2.2.2-14.9_mipsel.deb
Size/MD5 checksum: 1869748 e4f2e9974392c55b860a96f0bd4a6515
http://security.debian.org/pool/updates/main/k/kdebase/konsole_2.2.2-14.9_mipsel.deb
Size/MD5 checksum: 474078 0e8f84272c164dd4dd9cfc70095affd7
http://security.debian.org/pool/updates/main/k/kdebase/kscreensaver_2.2.2-14.9_mipsel.deb
Size/MD5 checksum: 416880 5dab7aa13a7b63a8fdcecb06c8224979
http://security.debian.org/pool/updates/main/k/kdebase/libkonq-dev_2.2.2-14.9_mipsel.deb
Size/MD5 checksum: 46046 862b384dd78394336a4bd90677041c65
http://security.debian.org/pool/updates/main/k/kdebase/libkonq3_2.2.2-14.9_mipsel.deb
Size/MD5 checksum: 203500 77b9625085171d0f3ffc5450e3f3fe5a

PowerPC architecture:

http://security.debian.org/pool/updates/main/k/kdebase/kate_2.2.2-14.9_powerpc.deb
Size/MD5 checksum: 424568 0e7724795fff69713e61737304b011a6
http://security.debian.org/pool/updates/main/k/kdebase/kdebase_2.2.2-14.9_powerpc.deb
Size/MD5 checksum: 6494884 994a68ccf381bc560acb7784c7bd19d6
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-audiolibs_2.2.2-14.9_powerpc.deb
Size/MD5 checksum: 85654 842951482e03727551878eb312b0af67
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-dev_2.2.2-14.9_powerpc.deb
Size/MD5 checksum: 48680 38da3b9cadde36be3c9078118e595726
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-libs_2.2.2-14.9_powerpc.deb
Size/MD5 checksum: 1665002 79175104f5b11fc1bbf6a2e4ae22c272
http://security.debian.org/pool/updates/main/k/kdebase/kdm_2.2.2-14.9_powerpc.deb
Size/MD5 checksum: 388384 0118926ee6cc39f61fb4cfd38f036f48
http://security.debian.org/pool/updates/main/k/kdebase/konqueror_2.2.2-14.9_powerpc.deb
Size/MD5 checksum: 1931522 731ffdb85e956700a562c44f3f4d3f34
http://security.debian.org/pool/updates/main/k/kdebase/konsole_2.2.2-14.9_powerpc.deb
Size/MD5 checksum: 459866 2fdf70f483bb56ed5b40b3993b8ce6fe
http://security.debian.org/pool/updates/main/k/kdebase/kscreensaver_2.2.2-14.9_powerpc.deb
Size/MD5 checksum: 369616 e5f1c98b98b99cc2c307e3279dfd7df1
http://security.debian.org/pool/updates/main/k/kdebase/libkonq-dev_2.2.2-14.9_powerpc.deb
Size/MD5 checksum: 46042 90a9717d835ce257756bef07eb84bca0
http://security.debian.org/pool/updates/main/k/kdebase/libkonq3_2.2.2-14.9_powerpc.deb
Size/MD5 checksum: 220524 258f7ef196999c48f9586b60894fc27c

IBM S/390 architecture:

http://security.debian.org/pool/updates/main/k/kdebase/kate_2.2.2-14.9_s390.deb
Size/MD5 checksum: 434620 2644f6e7392eaeb1e909262e9b25a50b
http://security.debian.org/pool/updates/main/k/kdebase/kdebase_2.2.2-14.9_s390.deb
Size/MD5 checksum: 6577338 dfd793aff448e4c8a332330a9f0d5f14
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-audiolibs_2.2.2-14.9_s390.deb
Size/MD5 checksum: 85472 83a87d726b05c070cbdf27f439817724
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-dev_2.2.2-14.9_s390.deb
Size/MD5 checksum: 48134 440ed2d3d0abc0c15ebad8a1099095b4
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-libs_2.2.2-14.9_s390.deb
Size/MD5 checksum: 1699114 3d8dedbe000116f6089d4d37c1ce980e
http://security.debian.org/pool/updates/main/k/kdebase/kdm_2.2.2-14.9_s390.deb
Size/MD5 checksum: 392128 c4f42f7ddd5c24e48d83ff3b34a010f4
http://security.debian.org/pool/updates/main/k/kdebase/konqueror_2.2.2-14.9_s390.deb
Size/MD5 checksum: 1977992 f7cceb9e9309bc01ae761dc4bd83f63b
http://security.debian.org/pool/updates/main/k/kdebase/konsole_2.2.2-14.9_s390.deb
Size/MD5 checksum: 478626 75754353588d0f2bbf7f6f8993432ef3
http://security.debian.org/pool/updates/main/k/kdebase/kscreensaver_2.2.2-14.9_s390.deb
Size/MD5 checksum: 428768 e9cf91a0766f9c3aeefbe227f4f8c061
http://security.debian.org/pool/updates/main/k/kdebase/libkonq-dev_2.2.2-14.9_s390.deb
Size/MD5 checksum: 46040 95ab5d3a3006bd1f21c4c273f4bfddc8
http://security.debian.org/pool/updates/main/k/kdebase/libkonq3_2.2.2-14.9_s390.deb
Size/MD5 checksum: 227590 4ab5593c6f62bcaecde3b0f8275f4a72

Sun Sparc architecture:

http://security.debian.org/pool/updates/main/k/kdebase/kate_2.2.2-14.9_sparc.deb
Size/MD5 checksum: 427276 c01793500f0644abee85f7bab876b4d2
http://security.debian.org/pool/updates/main/k/kdebase/kdebase_2.2.2-14.9_sparc.deb
Size/MD5 checksum: 6528768 3c3068f375072560a5f4203980f560f5
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-audiolibs_2.2.2-14.9_sparc.deb
Size/MD5 checksum: 86702 ebcfd07aab1a5e98f2f21c294b9acec2
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-dev_2.2.2-14.9_sparc.deb
Size/MD5 checksum: 48042 19d9d7d96bf6964117af204eb52dbec8
http://security.debian.org/pool/updates/main/k/kdebase/kdebase-libs_2.2.2-14.9_sparc.deb
Size/MD5 checksum: 1671584 e3cb6241c21ad30e34a668140d582dc4
http://security.debian.org/pool/updates/main/k/kdebase/kdm_2.2.2-14.9_sparc.deb
Size/MD5 checksum: 390762 f6b891cea82726586a0551bfb08688de
http://security.debian.org/pool/updates/main/k/kdebase/konqueror_2.2.2-14.9_sparc.deb
Size/MD5 checksum: 1939998 4b66439b38ab03d4882b9651523f46ab
http://security.debian.org/pool/updates/main/k/kdebase/konsole_2.2.2-14.9_sparc.deb
Size/MD5 checksum: 468830 f4d49ea7fa19782987bf7ad3048e1556
http://security.debian.org/pool/updates/main/k/kdebase/kscreensaver_2.2.2-14.9_sparc.deb
Size/MD5 checksum: 391342 2fbd92a134367967f5af6d74b54d67d1
http://security.debian.org/pool/updates/main/k/kdebase/libkonq-dev_2.2.2-14.9_sparc.deb
Size/MD5 checksum: 46038 a31928bb3ae42311d8c12a7a4d857cbc
http://security.debian.org/pool/updates/main/k/kdebase/libkonq3_2.2.2-14.9_sparc.deb
Size/MD5 checksum: 219372 cd51b55bd951624d5336fc56d0befdf8

These files will probably be moved into the stable distribution on its next update.



Debian Security Advisory DSA 659-1 security@debian.org
http://www.debian.org/security/ Martin Schulze
January 26th, 2005 http://www.debian.org/security/faq


Package : libpam-radius-auth
Vulnerability : information leak, integer underflow
Problem-Type : remote
Debian-specific: no
CVE ID : CAN-2004-1340 CAN-2005-0108

Two problems have been discovered in the libpam-radius-auth package, the PAM RADIUS authentication module. The Common Vulnerabilities and Exposures Project identifies the following problems:

CAN-2004-1340

The Debian package accidently installed its configuration file /etc/pam_radius_auth.conf world-readable. Since it may possibly contain secrets all local users are able to read them if the administrator hasn't adjusted file permissions. This problem is Debian specific.

CAN-2005-0108

Leon Juranic discoverd an integer underflow in the mod_auth_radius module for Apache which is also present in libpam-radius-auth.

For the stable distribution (woody) these problems have been fixed in version 1.3.14-1.3.

For the unstable distribution (sid) these problems have been fixed in version 1.3.16-3.

We recommend that you upgrade your libpam-radius-auth package.

Upgrade Instructions


wget url

will fetch the file for you
dpkg -i file.deb

will install the referenced file.

If you are using the apt-get package manager, use the line for sources.list as given below:

apt-get update

will update the internal database apt-get upgrade

will install corrected packages

You may use an automated update by adding the resources from the footer to the proper configuration.

Debian GNU/Linux 3.0 alias woody


Source archives:

http://security.debian.org/pool/updates/main/libp/libpam-radius-auth/libpam-radius-auth_1.3.14-1.3.dsc
Size/MD5 checksum: 633 685f1323a3b5848ccb548fe383c2647d
http://security.debian.org/pool/updates/main/libp/libpam-radius-auth/libpam-radius-auth_1.3.14-1.3.diff.gz
Size/MD5 checksum: 4339 cdbeaff45c0477e017bb2926d72e258f
http://security.debian.org/pool/updates/main/libp/libpam-radius-auth/libpam-radius-auth_1.3.14.orig.tar.gz
Size/MD5 checksum: 24709 3952a5de3ac960d03e437951f42e67e2

Alpha architecture:

http://security.debian.org/pool/updates/main/libp/libpam-radius-auth/libpam-radius-auth_1.3.14-1.3_alpha.deb
Size/MD5 checksum: 21606 a6ba05a3d785212a9b65720f29254988

ARM architecture:

http://security.debian.org/pool/updates/main/libp/libpam-radius-auth/libpam-radius-auth_1.3.14-1.3_arm.deb
Size/MD5 checksum: 19220 393e12c5b12e19b4f85f9efd2daa10cb

Intel IA-32 architecture:

http://security.debian.org/pool/updates/main/libp/libpam-radius-auth/libpam-radius-auth_1.3.14-1.3_i386.deb
Size/MD5 checksum: 17496 183e9f999e643aeb407898c8aac3f7d4

Intel IA-64 architecture:

http://security.debian.org/pool/updates/main/libp/libpam-radius-auth/libpam-radius-auth_1.3.14-1.3_ia64.deb
Size/MD5 checksum: 24672 d595102f5f85b8b1c403bf9fa5cceab7

HP Precision architecture:

http://security.debian.org/pool/updates/main/libp/libpam-radius-auth/libpam-radius-auth_1.3.14-1.3_hppa.deb
Size/MD5 checksum: 20238 f88620aba0ce73be9978d5e069af6391

Motorola 680x0 architecture:

http://security.debian.org/pool/updates/main/libp/libpam-radius-auth/libpam-radius-auth_1.3.14-1.3_m68k.deb
Size/MD5 checksum: 17140 4409cb32e00171b001a99a9c8a690679

Big endian MIPS architecture:

http://security.debian.org/pool/updates/main/libp/libpam-radius-auth/libpam-radius-auth_1.3.14-1.3_mips.deb
Size/MD5 checksum: 18090 916e4b25e48fd01d6bdc2509d8089505

Little endian MIPS architecture:

http://security.debian.org/pool/updates/main/libp/libpam-radius-auth/libpam-radius-auth_1.3.14-1.3_mipsel.deb
Size/MD5 checksum: 18310 1b20887306ee88f954aa159afb13889e

PowerPC architecture:

http://security.debian.org/pool/updates/main/libp/libpam-radius-auth/libpam-radius-auth_1.3.14-1.3_powerpc.deb
Size/MD5 checksum: 18394 29467c53c34a3f8745e640969e337a51

IBM S/390 architecture:

http://security.debian.org/pool/updates/main/libp/libpam-radius-auth/libpam-radius-auth_1.3.14-1.3_s390.deb
Size/MD5 checksum: 18690 2c2ea4437da4b44b14c65fffedc11673

Sun Sparc architecture:

http://security.debian.org/pool/updates/main/libp/libpam-radius-auth/libpam-radius-auth_1.3.14-1.3_sparc.deb
Size/MD5 checksum: 18328 b39b7c1da80afa286c979e37b74c846e

These files will probably be moved into the stable distribution on its next update.


For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

Fedora Core


Fedora Update Notification
FEDORA-2005-016
2005-01-26

Product : Fedora Core 3
Name : enscript
Version : 1.6.1
Release : 28.0.2
Summary : A plain ASCII to PostScript converter.

Description :
GNU enscript is a free replacement for Adobe's Enscript program. Enscript converts ASCII files to PostScript(TM) and spools generated PostScript output to the specified printer or saves it to a file. Enscript can be extended to handle different output media and includes many options for customizing printouts.


Update Information:

Erik Sjalund has discovered several security relevant problems in enscript, a program to converts ASCII text to Postscript and other formats. The Common Vulnerabilities and Exposures project identifies the following vulnerabilities:

CAN-2004-1184

Unsanitised input can caues the execution of arbitrary commands via EPSF pipe support. This has been disabled, also upstream.

CAN-2004-1185

Due to missing sanitising of filenames it is possible that a specially crafted filename can cause arbitrary commands to be executed.

CAN-2004-1186

Multiple buffer overflows can cause the program to crash.


  • Mon Jan 24 2005 Tim Waugh <twaugh@redhat.com> 1.6.1-28.0.2
    • Fixed patch for CAN-2004-1186 (bug #114684).
  • Tue Jan 11 2005 Tim Waugh <twaugh@redhat.com> 1.6.1-28.0.1
    • Added patch to fix CAN-2004-1186 (bug #114684).
    • Added patch to fix CAN-2004-1185 (bug #114684).
    • Backported patch to fix CAN-2004-1184 (bug #114684).

This update can be downloaded from:
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/

64cf1cd8caf430620476ff974c243829 SRPMS/enscript-1.6.1-28.0.2.src.rpm
233b8d840cfcc8d17286421e4ce0e868 x86_64/enscript-1.6.1-28.0.2.x86_64.rpm
11834dbe6435a1944da492a91f6a0bb1 x86_64/debug/enscript-debuginfo-1.6.1-28.0.2.x86_64.rpm
97e0027f6d54ca9575e816ba47ee5e0e i386/enscript-1.6.1-28.0.2.i386.rpm
ad12163e561ab7e16637fb75690633d4 i386/debug/enscript-debuginfo-1.6.1-28.0.2.i386.rpm

This update can also be installed with the Update Agent; you can launch the Update Agent with the 'up2date' command.



Fedora Update Notification
FEDORA-2005-015
2005-01-26

Product : Fedora Core 2
Name : enscript
Version : 1.6.1
Release : 25.2
Summary : A plain ASCII to PostScript converter.

Description :
GNU enscript is a free replacement for Adobe's Enscript program. Enscript converts ASCII files to PostScript(TM) and spools generated PostScript output to the specified printer or saves it to a file. Enscript can be extended to handle different output media and includes many options for customizing printouts.


Update Information:

Erik Sjalund has discovered several security relevant problems in enscript, a program to converts ASCII text to Postscript and other formats. The Common Vulnerabilities and Exposures project identifies the following vulnerabilities:

CAN-2004-1184

Unsanitised input can caues the execution of arbitrary commands via EPSF pipe support. This has been disabled, also upstream.

CAN-2004-1185

Due to missing sanitising of filenames it is possible that a specially crafted filename can cause arbitrary commands to be executed.

CAN-2004-1186

Multiple buffer overflows can cause the program to crash.


  • Mon Jan 24 2005 Tim Waugh <twaugh@redhat.com> 1.6.1-25.2
    • Fixed patch for CAN-2004-1186 (bug #114684).
  • Tue Jan 11 2005 Tim Waugh <twaugh@redhat.com> 1.6.1-25.1
    • Added patch to fix CAN-2004-1186 (bug #114684).
    • Added patch to fix CAN-2004-1185 (bug #114684).
    • Backported patch to fix CAN-2004-1184 (bug #114684).

This update can be downloaded from:
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/2/

aa8a46ea612edcccad9c3a90812e7b87 SRPMS/enscript-1.6.1-25.2.src.rpm
333674557f54bd9e05ad7b57e91ccd97 x86_64/enscript-1.6.1-25.2.x86_64.rpm
d1042af5d9397370d41170d06ce07d23 x86_64/debug/enscript-debuginfo-1.6.1-25.2.x86_64.rpm
d42a75862ed92f3a01840c42cc476a45 i386/enscript-1.6.1-25.2.i386.rpm
15dab7f96309408804dc89b233984dbe i386/debug/enscript-debuginfo-1.6.1-25.2.i386.rpm

This update can also be installed with the Update Agent; you can launch the Update Agent with the 'up2date' command.


Gentoo Linux


Gentoo Linux Security Advisory GLSA 200501-36

http://security.gentoo.org/


Severity: High
Title: AWStats: Remote code execution
Date: January 25, 2005
Bugs: #77963
ID: 200501-36


Synopsis

AWStats fails to validate certain input, which could lead to the remote execution of arbitrary code.

Background

AWStats is an advanced log file analyzer and statistics generator.

Affected packages


     Package          /  Vulnerable  /                      Unaffected

  1  net-www/awstats        < 6.3                               >= 6.3

Description

When 'awstats.pl' is run as a CGI script, it fails to validate specific inputs which are used in a Perl open() function call.

Impact

A remote attacker could supply AWStats malicious input, potentially allowing the execution of arbitrary code with the rights of the web server.

Workaround

Making sure that AWStats does not run as a CGI script will avoid the issue, but we recommend that users upgrade to the latest version, which fixes these bugs.

Resolution

All AWStats users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=net-www/awstats-6.3"

References

[ 1 ] AWStats ChangeLog

http://awstats.sourceforge.net/docs/awstats_changelog.txt

[ 2 ] iDEFENSE Advisory

http://www.idefense.com/application/poi/display?id=185

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200501-36.xml

Concerns?

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at http://bugs.gentoo.org.

License

Copyright 2005 Gentoo Foundation, Inc; referenced text belongs to its owner(s).

The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0

Mandrakelinux


Mandrakelinux Security Update Advisory


Package name: gpdf
Advisory ID: MDKSA-2005:016
Date: January 25th, 2005
Affected versions: 10.0, 10.1, Corporate Server 3.0


Problem Description:

A buffer overflow vulnerability was discovered in the xpdf PDF code, which could allow for arbitrary code execution as the user viewing a PDF file. The vulnerability exists due to insufficient bounds checking while processing a PDF file that provides malicious values in the /Encrypt /Length tag. Gpdf uses xpdf code and is susceptible to the same vulnerability.

The updated packages have been patched to prevent these problems.


References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0064


Updated Packages:

Mandrakelinux 10.0:
fa03ef1a1d5a1784298d890e8cf09bd2 10.0/RPMS/gpdf-0.112-2.5.100mdk.i586.rpm
dc1ff1ca81d1148e7524b3a53fe68197 10.0/SRPMS/gpdf-0.112-2.5.100mdk.src.rpm

Mandrakelinux 10.0/AMD64:
76dcd6cc6c50b284371ae17eef7112e1 amd64/10.0/RPMS/gpdf-0.112-2.5.100mdk.amd64.rpm
dc1ff1ca81d1148e7524b3a53fe68197 amd64/10.0/SRPMS/gpdf-0.112-2.5.100mdk.src.rpm

Mandrakelinux 10.1:
56154e1310488f9ba89004a979ee3393 10.1/RPMS/gpdf-0.132-3.4.101mdk.i586.rpm
391b99e6a4f37385493acde18209f85c 10.1/SRPMS/gpdf-0.132-3.4.101mdk.src.rpm

Mandrakelinux 10.1/X86_64:
e1ddd99a172f76393693e25f1a302a17 x86_64/10.1/RPMS/gpdf-0.132-3.4.101mdk.x86_64.rpm
391b99e6a4f37385493acde18209f85c x86_64/10.1/SRPMS/gpdf-0.132-3.4.101mdk.src.rpm

Corporate Server 3.0:
14b33a6547cf218481ba22a1ebd21b16 corporate/3.0/RPMS/gpdf-0.112-2.5.C30mdk.i586.rpm
9fc41a46a4398ece01b369547aac6125 corporate/3.0/SRPMS/gpdf-0.112-2.5.C30mdk.src.rpm


To upgrade automatically use MandrakeUpdate or urpmi. The verification of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandrakesoft for security. You can obtain the GPG public key of the Mandrakelinux Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandrakelinux at:

http://www.mandrakesoft.com/security/advisories

If you want to report vulnerabilities, please contact

security_linux-mandrake.com

Type Bits/KeyID Date User ID
pub 1024D/22458A98 2000-07-10 Linux Mandrake Security Team <security linux-mandrake.com>


Mandrakelinux Security Update Advisory


Package name: koffice
Advisory ID: MDKSA-2005:019
Date: January 25th, 2005
Affected versions: 10.0, 10.1, Corporate Server 3.0


Problem Description:

A buffer overflow vulnerability was discovered in the xpdf PDF code, which could allow for arbitrary code execution as the user viewing a PDF file. The vulnerability exists due to insufficient bounds checking while processing a PDF file that provides malicious values in the /Encrypt /Length tag. Koffice uses xpdf code and is susceptible to the same vulnerability.

The updated packages have been patched to prevent these problems.


References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0064


Updated Packages:

Mandrakelinux 10.0:
d620ab0db67c4e25f755ee62cf1a474a 10.0/RPMS/koffice-1.3-12.2.100mdk.i586.rpm
ade52f0ac258267ae8614502fabc8ab2 10.0/RPMS/libkoffice2-1.3-12.2.100mdk.i586.rpm
280135355e26e3baab14f63628c97dc2 10.0/RPMS/libkoffice2-devel-1.3-12.2.100mdk.i586.rpm
d46d3a868900d7ab94aeaa34deea1018 10.0/SRPMS/koffice-1.3-12.2.100mdk.src.rpm

Mandrakelinux 10.0/AMD64:
04bf5f31e92516f1c0458ba12c930a48 amd64/10.0/RPMS/koffice-1.3-12.2.100mdk.amd64.rpm
eec5070100e0ddbc03d4e0c55dfe1be3 amd64/10.0/RPMS/lib64koffice2-1.3-12.2.100mdk.amd64.rpm
065702b188f8ea68df6493da6cdbd660 amd64/10.0/RPMS/lib64koffice2-devel-1.3-12.2.100mdk.amd64.rpm
d46d3a868900d7ab94aeaa34deea1018 amd64/10.0/SRPMS/koffice-1.3-12.2.100mdk.src.rpm

Mandrakelinux 10.1:
c0530b7a5fa5542752b8998c31acce9e 10.1/RPMS/koffice-1.3.3-2.2.101mdk.i586.rpm
7d18d56f064133b241d2c454e817eb38 10.1/RPMS/koffice-karbon-1.3.3-2.2.101mdk.i586.rpm
9622c8c9f7876aa3d159532486117c5d 10.1/RPMS/koffice-kformula-1.3.3-2.2.101mdk.i586.rpm
4389b3cd90e57052424417f7a8dd4ceb 10.1/RPMS/koffice-kivio-1.3.3-2.2.101mdk.i586.rpm
361459b34c382e1c1382b483a92a6756 10.1/RPMS/koffice-koshell-1.3.3-2.2.101mdk.i586.rpm
15e865d609a58ac2783e8d25fde0418e 10.1/RPMS/koffice-kpresenter-1.3.3-2.2.101mdk.i586.rpm
65a868b881015cfd2376748526902fc8 10.1/RPMS/koffice-kspread-1.3.3-2.2.101mdk.i586.rpm
6587cc22182a858158cd8aea2afcba64 10.1/RPMS/koffice-kugar-1.3.3-2.2.101mdk.i586.rpm
caf4007f0343e29a69d10a057af99c83 10.1/RPMS/koffice-kword-1.3.3-2.2.101mdk.i586.rpm
da30f2308d7158089c383ca4a99d72ea 10.1/RPMS/koffice-progs-1.3.3-2.2.101mdk.i586.rpm
5784ad20ba835bd54cd95dc24d713253 10.1/RPMS/libkoffice2-karbon-1.3.3-2.2.101mdk.i586.rpm
8eda23533d992bb34d12c7bac00030be 10.1/RPMS/libkoffice2-kformula-1.3.3-2.2.101mdk.i586.rpm
a7923dede9bb79346bab697142346ec1 10.1/RPMS/libkoffice2-kivio-1.3.3-2.2.101mdk.i586.rpm
5cc52af39aa57938d7edae0d640fc968 10.1/RPMS/libkoffice2-koshell-1.3.3-2.2.101mdk.i586.rpm
e4bec26f95e1f55ced770cafd320e335 10.1/RPMS/libkoffice2-kpresenter-1.3.3-2.2.101mdk.i586.rpm
a8e1b736a8a3924cc39495a32b6ad223 10.1/RPMS/libkoffice2-kspread-1.3.3-2.2.101mdk.i586.rpm
5d1e64e28d69771aa4709791547f3802 10.1/RPMS/libkoffice2-kspread-devel-1.3.3-2.2.101mdk.i586.rpm
81bbf226aca53b9ad14c7522f3302191 10.1/RPMS/libkoffice2-kugar-1.3.3-2.2.101mdk.i586.rpm
e0c51ed40247b0d0715c6a67e9c0dfdc 10.1/RPMS/libkoffice2-kugar-devel-1.3.3-2.2.101mdk.i586.rpm
1403e58e5586b3dc41d874fb7f76992f 10.1/RPMS/libkoffice2-kword-1.3.3-2.2.101mdk.i586.rpm
77afbcf9c3603ec9cfae784e0d2ed43b 10.1/RPMS/libkoffice2-kword-devel-1.3.3-2.2.101mdk.i586.rpm
37a4b0ca89f95d47850392303f6774a1 10.1/RPMS/libkoffice2-progs-1.3.3-2.2.101mdk.i586.rpm
2219d9fdc81fcf660d60e15319e9943d 10.1/RPMS/libkoffice2-progs-devel-1.3.3-2.2.101mdk.i586.rpm
618a562fb56d40e4ecfd730d2b1be49b 10.1/SRPMS/koffice-1.3.3-2.2.101mdk.src.rpm

Mandrakelinux 10.1/X86_64:
d9cf8ecb69c8d7ccc2f0168ee078b3d3 x86_64/10.1/RPMS/koffice-1.3.3-2.2.101mdk.x86_64.rpm
460dd9a91e6e82323e110bf052371a52 x86_64/10.1/RPMS/koffice-karbon-1.3.3-2.2.101mdk.x86_64.rpm
3ae887f0ac3679219721611c1f05697d x86_64/10.1/RPMS/koffice-kformula-1.3.3-2.2.101mdk.x86_64.rpm
49efb5347574454645adca560a81f911 x86_64/10.1/RPMS/koffice-kivio-1.3.3-2.2.101mdk.x86_64.rpm
6f4a57a3d88a88ea7a179b4a1a113de9 x86_64/10.1/RPMS/koffice-koshell-1.3.3-2.2.101mdk.x86_64.rpm
d5be06b78eb1a0d2606be0deaa45a4a8 x86_64/10.1/RPMS/koffice-kpresenter-1.3.3-2.2.101mdk.x86_64.rpm
96ed4e467d93797e925f09c3ca150a0b x86_64/10.1/RPMS/koffice-kspread-1.3.3-2.2.101mdk.x86_64.rpm
41c1e39c0766d9ed0a823d8d5fa7499b x86_64/10.1/RPMS/koffice-kugar-1.3.3-2.2.101mdk.x86_64.rpm
cc48202eb30adf7625464def2461901c x86_64/10.1/RPMS/koffice-kword-1.3.3-2.2.101mdk.x86_64.rpm
7b672b3f77fe1d16ba22fe266695ffa9 x86_64/10.1/RPMS/koffice-progs-1.3.3-2.2.101mdk.x86_64.rpm
3d73eb1169a9a1055c06e134bb366b9f x86_64/10.1/RPMS/lib64koffice2-karbon-1.3.3-2.2.101mdk.x86_64.rpm
c31083fa21030ae3270b6623ae6cb29c x86_64/10.1/RPMS/lib64koffice2-kformula-1.3.3-2.2.101mdk.x86_64.rpm
228b5a7e9a0f71b59b00d89f79dd627b x86_64/10.1/RPMS/lib64koffice2-kivio-1.3.3-2.2.101mdk.x86_64.rpm
9ecf703ab3f988fb9cd914c46387bd21 x86_64/10.1/RPMS/lib64koffice2-koshell-1.3.3-2.2.101mdk.x86_64.rpm
456dea35aba11bdfbf3fe253939289b9 x86_64/10.1/RPMS/lib64koffice2-kpresenter-1.3.3-2.2.101mdk.x86_64.rpm
75e1f65af93ef7fb4f5a754b0c7bec31 x86_64/10.1/RPMS/lib64koffice2-kspread-1.3.3-2.2.101mdk.x86_64.rpm
9c44cfeb5ddf24bf0a7cb0f7cb2aab0a x86_64/10.1/RPMS/lib64koffice2-kspread-devel-1.3.3-2.2.101mdk.x86_64.rpm
7b18675837a38c393747a6dd4b6ccf4e x86_64/10.1/RPMS/lib64koffice2-kugar-1.3.3-2.2.101mdk.x86_64.rpm
f570ef6a23fa7afc2fb4379329853999 x86_64/10.1/RPMS/lib64koffice2-kugar-devel-1.3.3-2.2.101mdk.x86_64.rpm
4a558d84ab7a2d547c35801aca5d3dbb x86_64/10.1/RPMS/lib64koffice2-kword-1.3.3-2.2.101mdk.x86_64.rpm
ea2261303599a4c9d465304e27201f64 x86_64/10.1/RPMS/lib64koffice2-kword-devel-1.3.3-2.2.101mdk.x86_64.rpm
77ade17c9ac8c20c9cf55478dd12aff7 x86_64/10.1/RPMS/lib64koffice2-progs-1.3.3-2.2.101mdk.x86_64.rpm
996b4496c415ffdc41c56e5d0dba97b5 x86_64/10.1/RPMS/lib64koffice2-progs-devel-1.3.3-2.2.101mdk.x86_64.rpm
618a562fb56d40e4ecfd730d2b1be49b x86_64/10.1/SRPMS/koffice-1.3.3-2.2.101mdk.src.rpm

Corporate Server 3.0:
b487481d69017027aa30d300768f077e corporate/3.0/RPMS/koffice-1.3-12.2.C30mdk.i586.rpm
8b4d331f0944c61fb8e5077bca050c2f corporate/3.0/RPMS/libkoffice2-1.3-12.2.C30mdk.i586.rpm
4d1dae4b305ff73a186b3eaf41ab89bb corporate/3.0/RPMS/