<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
	<head>

	<meta name="WT.qs_dlk" content="WgHl2QrIZ7wAAFu1R9oAAAAN"/>

	<meta name="WT.qs_shmv" content="hv20150423-shelton.sf.quinstreet.net"/>

	<meta name="inject_params" content="WT.qs_dlk=WgHl2QrIZ7wAAFu1R9oAAAAN&"/>

	<meta http-equiv="Set-Cookie" content="inject_params=WT.qs_dlk=WgHl2QrIZ7wAAFu1R9oAAAAN&; path=/;  domain=linuxtoday.com;"/>
	<meta http-equiv="Set-Cookie" content="WMUUID=WgHl2QrIZ7wAAFu1R9oAAAAN; path=/;  domain=linuxtoday.com;"/>

    	<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<title>Linux Today - How to Install Varnish Cache with Apache on CentOS 7</title>
<meta name="description" content="HowToForge: Varnish is a proxy server focused on HTTP caching." />
<meta name="keywords" content="" />
<meta name="channel" content="IT" />
<link rel="canonical" href="https://www.linuxtoday.com/infrastructure/how-to-install-varnish-cache-with-apache-on-centos-7-171106071025.html" />
<meta name="articleKey" content="206877010"/>
<meta name='qs.quad.keywords' content='{keywords:"96310|95900|935613|95850",nodes:"96310"}' >
<link rel="alternate"  type="application/rss+xml" title="Linux Today RSS" href="/biglt.rss">
<link rel="apple-touch-icon" href="/img/apple-touch-icon-iphone.png" />
<link rel="apple-touch-icon" sizes="72x72" href="/img/apple-touch-icon-ipad.png" />
<link rel="apple-touch-icon" sizes="114x114" href="/img/apple-touch-icon-iphone4.png" />
<link rel="apple-touch-icon" sizes="144x144" href="/img/apple-touch-icon-ipad3.png" />

<link rel="alternate" media="only screen and (max-width: 640px)" href="https://mobile.linuxtoday.com/infrastructure/how-to-install-varnish-cache-with-apache-on-centos-7-171106071025.html" />

<link type="text/css" rel="stylesheet" name="min-css" media="screen" href="/hqx/min/?b=css&f=text.css,comments.css&v=1"/>
<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.min.js"></script> 

<!-- BEGIN DFP core -->
<script type='text/javascript'>
function gDFPC(e){var n=e+"=";var ca=document.cookie.split(';');for(var i=0;i<ca.length;i++){var c=ca[i].replace(/^\s+|\s+$/g,'');if(c.indexOf(n)==0) return c.substring(n.length,c.length);}return "";}var mbw=window.innerWidth||document.documentElement.clientWidth||document.body.clientWidth;var myWTDLK=gDFPC('WMUUID');var mlWTFP="";var myWTtemp=gDFPC('WT_FPC').split(":");for(var i=0;i<myWTtemp.length;i++){if(myWTtemp[i].search("id=")==0){mlWTFP=myWTtemp[i].slice(3);}}var qsDFPSec=(location.protocol==="https:"?"true":"false");
</script>
<script type='text/javascript'>
var n_imu=0,n_ic_imu=0,n_lb=0,n_sky=0,n_hero=0,n_wa=0,n_wap=0,n_ciu=0,n_siteskin=0,n_button=0,n_qmp=0,n_m_lb=0,n_m_imu=0,n_m_ic_imu=0,n_m_hero=0,n_m_wa=0,n_ic=0,n_oop=0,n_pf=0;function refreshDFPTags(){googletag.pubads().refresh();}function hideQSDiv(e){if(document.getElementById){document.getElementById(e).style.visibility="hidden";document.getElementById(e).innerHTML="";}}
</script><script type='text/javascript'>(function(){var src=(location.protocol==="https:"?"https:":"http:")+"//www.googletagservices.com/tag/js/gpt.js";document.write("<scr"+"ipt src=\""+src+"\"></scr"+"ipt>");})();function displayDFPTag(t){var a=0;var b="";var c=0;var d="";if(t.match(/^sponsor-logo.*/)){var z=t.split(":");t=z[0];a=z[1];}switch(t){case "imu":a=++n_imu;break;case "ic_imu":a=++n_ic_imu;b=" style='width: 300px; text-align: center; padding: 0px 0px 20px 0px; margin: 0 auto;'";d=" <div style=\"text-align: right; margin: 0 auto; font-family: 'Helvetica Neue 55 Roman', Helvetica, Arial, san-serif; color: #666666; font-size: 10px; font-weight: normal;\">Advertisement</div>";break;case "lb":a=++n_lb;break;case "sky":a=++n_sky;break;case "hero":a=++n_hero;b=" style='height: 0px;'";c=1;break;case "wa":a=++n_wa;b=" style='height: 0px;'";c=1;break;case "wap":a=++n_wap;break;case "ciu":a=++n_ciu;break;case "siteskin":a=++n_siteskin;break;case "button":a=++n_button;break;case "qmp":a=++n_qmp;break;case "sponsor-logo":break;case "m_lb":a=++n_m_lb;break;case "m_imu":a=++n_m_imu;break;case "m_ic_imu":a=++n_m_ic_imu;b=" style='width: 300px; text-align: center; padding: 0px 0px 20px 0px; margin: 0 auto;'";d=" <div style=\"text-align: right; margin: 0 auto; font-family: 'Helvetica Neue 55 Roman', Helvetica, Arial, san-serif; color: #666666; font-size: 10px; font-weight: normal;\">Advertisement</div>";break;case "m_hero":a=++n_m_hero;break;case "m_wa":a=++n_m_wa;break;case "ic":a=++n_ic;b=" style='width: 300px; text-align: center; padding: 0px 0px 20px 0px; margin: 0 auto;'";d="  <div style=\"text-align: right; margin: 0 auto; font-family: 'Helvetica Neue 55 Roman', Helvetica, Arial, san-serif; color: #666666; font-size: 10px; font-weight: normal;\">Advertisement</div>";break;case "oop":a=++n_oop;break;case "pf":a=++n_pf;break;default:return "<!-- QS-DFP: Unknown tag '"+t+"' requested -->";}var e=t+"-"+a;var r="<div id='"+e+"'"+b+">\n";if(d){r+=d;}r+=" <scr"+"ipt type='text/javascript'>\n        googletag.display('"+e+"');\n   </scr"+"ipt>\n</div>\n";if(c){r+="<style type=\"text/css\">#"+e+"_ad_container { height: 0px; }</style>\n";}return r;}
</script><!-- END DFP core -->

    <meta NAME="DCSext.tax" content="product pcs and peripherals personal computer pc desktop workstation,product platform os linux,product security,product servers,product servers server operating systems linux server operatting system,product data center cloud computing,product mobile mobile operating systems android" />
    <meta NAME="DCSext.qse_b2b_tax" content="product pcs and peripherals personal computer pc desktop workstation,product platform os linux,product security,product servers,product servers server operating systems linux server operatting system,product data center cloud computing,product mobile mobile operating systems android" />

<!-- BEGIN ML Tag -->
<script type='text/javascript'>
var mlCLID="50443";if(typeof mlCLID!='undefined'){var mlEml=gDFPC('eml');(function(f,i,c){var a=decodeURIComponent,e="",l="",o="||",g=";;",h="split",b="length",j="indexOf",k=0,n="localStorage",m="_ccmdt";f[c]=f[c]||{};function d(q){var p;if(f[n]){return f[n][q]||""}else{p=i.cookie.match(q+"=([^;]*)");return(p&&p[1])||""}}f[c].us={};e=a(d(m))[h](o);k=e[b];if(k>0){while(k--){l=e[k][h]("=");if(l[b]>1){if(l[1][j](g)>-1){f[c].us[l[0]]=l[1][h](g);f[c].us[l[0]].pop()}else{f[c].us[l[0]]=l[1]}}}}})(window,document,"_ml");(function(){_ml=window._ml||{};_ml.eid='50027';_ml.clid=mlCLID;if(typeof mlEml!='undefined'){_ml.em=mlEml;}else{_ml.em='';}_ml.ht='shex';_ml.fp=mlWTFP;_ml.redirect=(location.protocol==='https:'?'https:':'http:')+'//beacon.krxd.net/usermatch.gif?partner=madisonlogic&partner_uid=[PersonID]';_ml.informer={enable:true};var s=document.getElementsByTagName('script')[0],cd=new Date(),mltag=document.createElement('script');mltag.type='text/javascript';mltag.async=true;mltag.src=(location.protocol==='https:'?'https:':'http:')+'//ml314.com/tag.aspx?'+cd.getDate()+cd.getMonth()+cd.getFullYear();s.parentNode.insertBefore(mltag,s);})();}
</script>
<!-- END ML Tag -->
<!-- BEGIN Krux Tag -->
<script type='text/javascript'>
window.Krux||((Krux=function(){Krux.q.push(arguments);}).q=[]);(function(){function retrieve(n){var m,k='kx'+n;if(window.localStorage){return window.localStorage[k]||"";}else if(navigator.cookieEnabled){m=document.cookie.match(k+'=([^;]*)');return (m&&unescape(m[1]))||"";}else{return '';}}Krux.user=retrieve('user');Krux.segments=retrieve('segs')&&retrieve('segs').split(',')||[];})();
</script>
<script class="kxct" data-id="JdOofiLA" data-timing="async" data-version="1.9" type="text/javascript">
window.Krux||((Krux=function(){Krux.q.push(arguments)}).q=[]);(function(){var k=document.createElement('script');k.type='text/javascript';k.async=true;var m,src=(m=location.href.match(/\bkxsrc=([^&]+)/))&&decodeURIComponent(m[1]);k.src = /^https?:\/\/([a-z0-9_\-\.]+\.)?krxd\.net(:\d{1,5})?\//i.test(src)?src:src==="disable"?"":(location.protocol==="https:"?"https:":"http:")+"//cdn.krxd.net/controltag?confid=JdOofiLA";var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(k,s);}());
</script>
<!-- END Krux Tag -->
    <!-- BEGIN DnB Tag -->
    <script type="text/javascript" async defer src="//vid1044.d41.co/sync/"></script>
    <script type="text/javascript" src="//cdn-0.d41.co/tags/dnb_coretag_v3.min.js"></script>
    <!-- END DnB Tag -->    
    <!-- BEGIN DnB Tag Data Layer -->
    <script type="text/javascript">
        var dfpDnB = {};
        // Data layer for Krux
        var kruxDataLayer = {};
        var visitor_companyName, visitor_employeesInAllLocationsNum, visitor_vanityTitle, visitor_jobSeniority, visitor_jobFunction, visitor_fortune1000, visitor_networth, visitor_networthNum, visitor_techOfficeDemand, visitor_duns, visitor_companyCountry, visitor_itExpense, visitor_industryNaics, visitor_dnbstatus;
        dnbvid.getData("vid1044","json","T",function(dnb_Data){
            // Data set for tracking it in webtrends
            visitor_companyName = dnb_Data.companyName;
            visitor_employeesInAllLocationsNum = dnb_Data.employeesInAllLocationsNum;
            visitor_vanityTitle = dnb_Data.vanityTitle;
            visitor_jobSeniority = dnb_Data.jobSeniority;
            visitor_jobFunction = dnb_Data.jobFunction;
            visitor_fortune1000 = dnb_Data.fortune1000;
            visitor_networth = dnb_Data.networth;
            visitor_networthNum = dnb_Data.networthNum;
            visitor_techOfficeDemand = dnb_Data.techOfficeDemand;
            visitor_duns = dnb_Data.duns;
            visitor_companyCountry = dnb_Data.companyCountry;
            visitor_itExpense = dnb_Data.itExpense;
            visitor_industryNaics = dnb_Data.industryNaics;
            visitor_dnbstatus = dnb_Data.status;

            dfpDnB = {
                "dnb_companyName": dnb_Data.companyName,
                "dnb_employeesInAllLocationsNum": dnb_Data.employeesInAllLocationsNum,
                "dnb_vanityTitle": dnb_Data.vanityTitle,
                "dnb_jobSeniority": dnb_Data.jobSeniority,
                "dnb_jobFunction": dnb_Data.jobFunction,
                "dnb_fortune1000": dnb_Data.fortune1000,
                "dnb_networth": dnb_Data.networth,
                "dnb_networthNum": dnb_Data.networthNum,
                "dnb_techOfficeDemand": dnb_Data.techOfficeDemand,
                "dnb_duns": dnb_Data.duns,
                "dnb_companyCountry": dnb_Data.companyCountry,
                "dnb_itExpense": dnb_Data.itExpense,
                "dnb_industryNaics": dnb_Data.industryNaics,
                "dnb_dnbstatus": dnb_Data.status
            };

                kruxDataLayer = {
                "page": {
                    "domain": "www.linuxtoday.com",
                    "section": "infrastructure",
                    "category": "infrastructure",
                    "keywords": "PCs and peripherals,personal computer,pc,desktop,workstation,platform,OS Linux,security,servers,server operating systems,Linux server operatting system,data center,cloud computing,mobile,mobile operating systems,Android",
                    "url_path_1": "https://www.linuxtoday.com/infrastructure/how-to-install-varnish-cache-with-apache-on-centos-7-171106071025.html"
                },
                "user": {
                    "companyName" : dnb_Data.companyName,
                    "employeesInAllLocationsNum" : dnb_Data.employeesInAllLocationsNum,
                    "vanityTitle" : dnb_Data.vanityTitle,
                    "jobSeniority" : dnb_Data.jobSeniority,
                    "jobFunction" : dnb_Data.jobFunction,
                    "fortune1000" : dnb_Data.fortune1000,
                    "networth" : dnb_Data.networth,
                    "networthNum" : dnb_Data.networthNum,
                    "techOfficeDemand" : dnb_Data.techOfficeDemand,
                    "duns" : dnb_Data.duns,
                    "companyCountry" : dnb_Data.companyCountry,
                    "itExpense" : dnb_Data.itExpense,
                    "industryNaics" : dnb_Data.industryNaics,
                    "dnbStatus" : dnb_Data.status
                }
            };
            });
    </script>
    <!-- END DnB Tag Data Layer -->

        <!-- BEGIN DFP visibility -->
    <script type="text/javascript">
        eval(function(p,a,c,k,e,d){e=function(c){return c};if(!''.replace(/^/,String)){while(c--){d[c]=k[c]||c}k=[function(e){return d[e]}];e=function(){return'\\w+'};c=1};while(c--){if(k[c]){p=p.replace(new RegExp('\\b'+e(c)+'\\b','g'),k[c])}}return p}('0 2=1(\'2\');0 3=1(\'3\');0 6=1(\'6\');0 4=1(\'4\');0 5=1(\'5\');',7,7,'var|gDFPC|dn|jf|ir|noer|dr'.split('|'),0,{}));

                    googletag.defineSlot('/5055/b2b/it/linuxtoday/ciu',[[600,200],[300,200]],'ciu-1').addService(googletag.pubads()).setTargeting('pos','top');
                    if(mbw>1049){googletag.defineOutOfPageSlot('/5055/b2b/it/linuxtoday/hero','hero-1').addService(googletag.pubads());}
                    googletag.defineSlot('/5055/b2b/it/linuxtoday/imu',[[300,250],[300,600],[300,1050]],'imu-1').addService(googletag.pubads()).setTargeting('pos','top');
                    googletag.defineSlot('/5055/b2b/it/linuxtoday/imu',[[300,250],[300,600]],'imu-2').addService(googletag.pubads()).setTargeting('pos','mid');
                    googletag.defineSlot('/5055/b2b/it/linuxtoday/lb',[728,90],'lb-1').addService(googletag.pubads()).setTargeting('pos','top');
                    googletag.defineSlot('/5055/b2b/it/linuxtoday/lb',[728,90],'lb-2').addService(googletag.pubads()).setTargeting('pos','low');
                    googletag.defineSlot('/5055/b2b/it/linuxtoday/sky',[160,600],'sky-1').addService(googletag.pubads()).setTargeting('pos','top');
                    googletag.defineOutOfPageSlot('/5055/b2b/it/linuxtoday/wa','wa-1').addService(googletag.pubads());
        
                    googletag.pubads().setTargeting('kw',['PCs and peripherals','personal computer','pc','desktop','workstation','platform','OS Linux','security','servers','server operating systems','Linux server operatting system','data center','cloud computing','mobile','mobile operating systems','Android']);
                            googletag.pubads().setTargeting('tax',['product pcs and peripherals personal computer pc desktop workstation','product platform os linux','product security','product servers','product servers server operating systems linux server operatting system','product data center cloud computing','product mobile mobile operating systems android']);
                            googletag.pubads().setTargeting('path',['infrastructure','how-to-install-varnish-cache-with-apache-on-centos-7-171106071025.html']);
                            googletag.pubads().setTargeting('pagetype','other');
            googletag.pubads().setTargeting('securesite',''+qsDFPSec+'');
                    googletag.pubads().setTargeting('url',['https://www.linuxtoday.com/infrastructure/how-to-install-varnish-cache-with-apache-on-centos-7-171106071025.html','http://www.linuxtoday.com/infrastructure/how-to-install-varnish-cache-with-apache-on-centos-7-171106071025.html']);
                    if(mbw<641){googletag.pubads().setTargeting('pfm','mob');}else{googletag.pubads().setTargeting('pfm','des');}
                    googletag.pubads().setTargeting('env','prod');
                    googletag.pubads().setTargeting('wtdlk',''+myWTDLK+'');
                    if(typeof _ml!='undefined'&&_ml.us){if(_ml.us.tp&&_ml.us.tp.length>0){googletag.pubads().setTargeting('mlt',''+_ml.us.tp+'');}}
                            googletag.pubads().setTargeting('ksg',Krux.segments);
            googletag.pubads().setTargeting('kuid',Krux.user);
                            for (key in dfpDnB) { googletag.pubads().setTargeting(key,dfpDnB[key]); }
        
            eval(function(p,a,c,k,e,d){e=function(c){return c};if(!''.replace(/^/,String)){while(c--){d[c]=k[c]||c}k=[function(e){return d[e]}];e=function(){return'\\w+'};c=1};while(c--){if(k[c]){p=p.replace(new RegExp('\\b'+e(c)+'\\b','g'),k[c])}}return p}('0(5!=\'\'&&5!=\'2\'){1.3().4(\'5\',\'\'+5+\'\')}0(6!=\'\'&&6!=\'2\'){1.3().4(\'6\',\'\'+6+\'\')}0(9!=\'\'&&9!=\'2\'){1.3().4(\'9\',\'\'+9+\'\')}0(7!=\'\'&&7!=\'2\'){1.3().4(\'7\',\'\'+7+\'\')}0(8!=\'\'&&8!=\'2\'){1.3().4(\'8\',\'\'+8+\'\')}',10,10,'if|googletag|null|pubads|setTargeting|dn|jf|ir|noer|dr'.split('|'),0,{}));

            googletag.pubads().enableSingleRequest();
            googletag.pubads().collapseEmptyDivs();
                    googletag.pubads().enableSyncRendering();
                            googletag.disablePublisherConsole();
        
            googletag.enableServices();
            </script>
    <!-- END DFP visibility -->
    
        <!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "17199065" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=17199065&cv=2.0&cj=1" alt=""/>
</noscript>
<!-- End comScore Tag -->
        <!-- Google Analytics -->
        <script>
            (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
                (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
                m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
            })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
            ga('create', 'UA-48217604-1', 'auto');
            ga('send', 'pageview');
        </script>
        <!-- End Google Analytics -->
    
	<meta name="cache-creation-time" content="2017-11-07 08:50:58.000 -0800" />

    <script>
    window.webtrendsAsyncInit=function(){
        var dcs=new Webtrends.dcs().init({
            dcsid:"dcsq968da00000oiyhzhxx6wa_7q6r",
            domain:"www.qsstats.com",
            timezone:-8,
            i18n:true,
            onsitedoms:"linuxtoday.com",
            fpcdom:".linuxtoday.com",
            plugins:{
                //hm:{src:"//s.webtrends.com/js/webtrends.hm.js"}
            }
            }).track();
    };
    (function(){
        var s=document.createElement("script"); s.async=true; s.src="/imageserver/common/v10/webtrends.min.js";    
        var s2=document.getElementsByTagName("script")[0]; s2.parentNode.insertBefore(s,s2);
    }());
    </script>
    <noscript><img alt="dcsimg" id="dcsimg" width="1" height="1" src="//www.qsstats.com/dcsq968da00000oiyhzhxx6wa_7q6r/njs.gif?dcsuri=/index.php/infrastructure/how-to-install-varnish-cache-with-apache-on-centos-7-171106071025.html&amp;WT.js=No&amp;WT.tv=10.4.1&amp;dcssip=www.linuxtoday.com&amp;WT.qs_dlk=WgHl2QrIZ7wAAFu1R9oAAAAN&"/></noscript>
</head>
    <body class="mt-main-index layout-wtt" onload="welcomeUser();">
		<!-- QS-AD: 'wa' start -->
<script language="JavaScript">
	var t=displayDFPTag("wa");
	document.write(t);

</script>
<!-- QS-AD: 'wa' end -->    	<div id="container">
    			<style type="text/css">
<!--
body { margin: 0; padding: 0;}
.brandLogo a img { border: none;}
.globalHeader { font: 100%/1.4 Arial, Helvetica, sans-serif; height: 25px; background-color: #111; background-image: url(/icom_includes/toolbars/globaltoolbar/img/header-bg.jpg); background-repeat: repeat-x;	background-position: center top;}
.globalHeader .brandLogo { padding: 4px 0 0 .5em; float: left; }
.globalHeader .brandLogo p { color: #666; font-family: Arial, sans-serif; font-size: 11px; padding: 0; margin: 0;}
.globalHeader .login-register { text-align: right; padding: 4px .5em 0 .5em; /*float: right;*/}
.globalHeader .login-register img{ cursor:pointer;}
.globalHeader .logout { text-align: right;  }
.globalHeader .logout .greeting span{ color: #797979; font-family: Arial, sans-serif; font-size: 13px; padding: 0; margin: 0;}
.globalHeader .logout .greeting a{ color: #797979 !important; font-family: Arial, sans-serif; padding: 0; font-size: 13px; margin: 0;}
.logout-link img{ cursor:pointer;margin-top:3px; margin-right:5px;}
.clearfloat { clear:both; height:0;	font-size: 1px;	line-height: 0px;} 
-->
</style>
<div class="globalHeader" id="ITBE-ACLHeader" style="display:none;"></div>
<div class="globalHeader" id="ITBE-NonACLHeader" style="display:none;"></div>
<div class="globalHeader" id="Developer.com-ACLHeader" style="display:none;"></div>
<div class="globalHeader" id="Developer.com-NonACLHeader" style="display:none;"></div>
<div class="globalHeader" id="Developer.com-CustomToolbar" style="display:none;"></div>
<div class="globalHeader" id="developerBrandForum" style="display:none;"></div>
<div class="globalHeader" id="itbeBrandForum-CustomToolbar" style="display:none;"></div>
<div class="globalHeader" id="itbeBrandForum" style="display:none;"></div>
<div class="globalHeader" id="ZDE-ACLHeader" style="display:none;"></div>
<div class="globalHeader" id="ZDE-NonACLHeader" style="display:none;"></div>
<div class="globalHeader" id="BASELINE-ACLHeader" style="display:none;"></div>
<div class="globalHeader" id="BASELINE-NonACLHeader" style="display:none;"></div>
<div class="globalHeader" id="CINSIDER-ACLHeader" style="display:none;"></div>
<div class="globalHeader" id="CINSIDER-NonACLHeader" style="display:none;"></div>
<div class="globalHeader" id="CIOINSIGHT-ACLHeader" style="display:none;"></div>
<div class="globalHeader" id="CIOINSIGHT-NonACLHeader" style="display:none;"></div>
<div class="globalHeader" id="EWEEK-ACLHeader" style="display:none;"></div>
<div class="globalHeader" id="EWEEK-NonACLHeader" style="display:none;"></div>
<div class="globalHeader" id="WBG-ACLHeader" style="display:none;"></div>
<script async language="Javascript" src="/icom_includes/toolbars/globaltoolbar/scripts/brandingcode_new.js">
</script>    			<div style="text-align: center; margin-top: 2px;">
    				<!-- QS-AD: 'lb' start -->
<script language="JavaScript">
	var t=displayDFPTag("lb");
	document.write(t);

</script>
<!-- QS-AD: 'lb' end -->    			</div>

    			<table border="0" width="100%" cellpadding="0" cellspacing="0" style="padding-top: 3px;">
	<tr>
		<td border="0" class="deferload" data-original="/img/srch_bkgd.png" background="" width="100%">
			<table width="100%" border="0" cellspacing="0" cellpadding="0">
	  			<tr>
	    			<td width="429" nowrap>
	    				<a href="/"><img class="deferload" data-original="/img/linuxtd_logo.png" src="" width="378" height="63"  alt="Linux Today: Linux News On Internet Time." border="0"/><span class="sprite sprite-top_shad" style="display:inline-block;"></span></a>
	    			</td>
	    			<td align="left" border="0"> 
						<!--start_search-->
		      			<table width="100%" border="0" cellspacing="0" cellpadding="5">
							<tr valign="top">
								<form action="/search.html" id="cse-search-box">
									<td valign="top">
										<span class="sprite sprite-search_txt" style="display:inline-block;"></span>
										<input type="text" name="q" size="18">
										<input type="hidden" name="cx" value="partner-pub-8768004398756183:6999378834">
	                                    <input type="hidden" name="cof" value="FORID:10">
	                                    <input type="hidden" name="ie" value="UTF-8">
	                                    <input type="submit" value="" alt="Go" class="button">
                                    </td>                                    
								</form>
								<script type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en">
</script>
								
								
								
								</tr>
		      			</table>
						<!--end_search-->
	    			</td>
	    			<td id="loginfo" align="right"></td>					
	  			</tr>
			</table>
		</td>
	</tr>
</table>
<table width="100%" cellspacing="0" cellpadding="0" border="0">
	<tbody>
		<tr>
			<td class="deferload" data-original="/img/tab_bkgd.png" background="">
				<a href="/"><span class="sprite sprite-linuxnews_tab" style="display:inline-block;"></span></a>				
				<a href="/developer/"><span class="sprite sprite-developer_tab" style="display:inline-block;"></span></a>
				<a href="/high_performance/"><span class="sprite sprite-highperform_tab" style="display:inline-block;"></span></a>
				<a href="/infrastructure/"><span class="sprite sprite-infrastructure_tab" style="display:inline-block;"></span></a>
				<a href="/it_management/"><span class="sprite sprite-itmanagment_tab" style="display:inline-block;"></span></a>
				<a href="/security/"><span class="sprite sprite-security_tab" style="display:inline-block;"></span></a>
				<a href="/storage/"><span class="sprite sprite-storage_tab" style="display:inline-block;"></span></a>				
			</td>
		</tr>
	</tbody>
</table>
				<table border="0">
					<tbody>
						<tr><td width="161" valign="top" class="deferload" data-original="/img/nav_bkgd.png" background="" align="center">
	<table width="161" border="0" align="left" valign="top" cellspacing="0" cellpadding="0">
		<tbody>
			<tr>
				<td>
		        	<span class="sprite sprite-linuxtodaytop_nav" style="display:inline-block;"></span><br>
					<a href="/"><span class="sprite sprite-home_nav" style="display:inline-block;"></span></a><br>
					<a href="/accountManagement?formType=loginForm"><span class="sprite sprite-preferences_nav" style="display:inline-block;"></span></a><br>					
					<a href="/contribute.html"><span class="sprite sprite-contribute_nav" style="display:inline-block;"></span></a><br>
					<a href="/linkus.html"><span class="sprite sprite-linkto_nav" style="display:inline-block;"></span></a>
					<!--<br>					
					<a href="http://www.justtechjobs.com/" target="_blank"><img width="161" height="24" border="0" alt="Linux Jobs" src="/img/jobs_nav2.gif"></a>-->
	        		<p></p>
	        		<div style="width:99%">												
						<br />	
						<div align="CENTER">							
							<!-- QS-AD: 'sky' start -->
<script language="JavaScript">
	var t=displayDFPTag("sky");
	document.write(t);

</script>
<!-- QS-AD: 'sky' end -->						</div>					
					</div>
				</td>
			</tr>
		</tbody>
	</table>
</td>							<td width="97%" class="contenttd" valign="TOP"><div class="rightnav">
			<!-- QS-AD: 'imu' start -->
<script language="JavaScript">
	var t=displayDFPTag("imu");
	document.write(t);

</script>
<!-- QS-AD: 'imu' end --><p></p>	
			<div class="articlecategorysummary">
    <iframe id='whitePaperIFrame' scrolling="no" frameborder="0" align="middle" src="https://www.linuxtoday.com/sl/assetlisting/?wsn=www.linuxtoday.com&amp;wpu=/&amp;lurl=https://o1.qnsr.com/cgi/r?WT.qs_dlk=WgHl2QrIZ7wAAFu1R9oAAAAN;;n=203;c=1395316;s=9543;x=7936;f=201308291504360;u=j;z=TIMESTAMP;k=https://assetform.linuxtoday.com/controller&amp;wpos=AssetListing&amp;lyt=l9&css=https://www.linuxtoday.com/hqb2b/css/qmp/qmp_default.css&wi=4230610&title=Top%20White%20Papers%20and%20Webcasts" height="780"></iframe>
</div>
<script type="text/javascript"> 
var updateIframe = false;
var t = 0;

function updateQMPIframe(){
    if(!updateIframe) { 
        if($('#whitePaperIFrame').contents().find('.asset').length > 0) {
            var height = $('#whitePaperIFrame').contents().find('#assetsListings').height();
            height = height + 50;
            var iframe = document.getElementById('whitePaperIFrame');  
            iframe.setAttribute( 'height', height);
            updateIframe = true;
            clearTimeout(t);
        }else {
            t = setTimeout('updateQMPIframe()', 1000);
        }
    }
}

t = setTimeout('updateQMPIframe()', 5000);


</script>
 <p></p>			
			<!-- QS-AD: 'imu' start -->
<script language="JavaScript">
	var t=displayDFPTag("imu");
	document.write(t);

</script>
<!-- QS-AD: 'imu' end --><p></p>
			<!--<div id="newsletter" class="rightnav_box">
	<h3>Subscribe to Our Daily Newsletter</h3>
	<span class="error"></span>
	<span class="success"></span>
    <form method="POST" id="newsletter_form" name="newsletter_form">
      	<input type="text" name="email" id="email" value="Enter your email address"> 
      	<input type="submit" value="Submit">
    </form>
</div>-->

<!--
<div id="newsletterBox" class="rightnav_box">
<h3>Subscribe to Our Daily Newsletter</h3>					
						<form method="POST" id="newsletter_form" name="newsletter_form" class="nlForm">
							<div class="nlbody" id="nl_form">												
								<input type="text" name="email" id="email" value="Enter your email address" class="inputbox"> 						
								<input type="submit" value="Submit" class="myButton">
								<span class="error" style="display:block;"></span>
								<span class="success" style="display:block;"></span>
							</div>
						</form>					
				</div>
				<p></p>
	-->			
<form style="margin: 0pt; padding: 0pt;" method="post" id="newsletter_form">	
	<div class="newsletter_holder rightnav_box"><h3>Subscribe to Our Daily Newsletter</h3>		
		<div id="newsdiv">
		<input type="text" maxlength="255" name="email" id="email" value="Enter your email address">	
		<input id="NewsletterSignup" type="hidden" value="Linux Today News" name="NewsletterSignup">
		<input id="navNewsletterSignup" type="hidden" value="1110" name="NewsletterKey">
		<input id="businessUnit" type="hidden" value="Internet.com" name="businessUnit">
		<input id="RegistrationWebsite" type="hidden" value="www.linuxtoday.com" name="RegistrationWebsite">		
		<input type="submit" value="Submit" class="myButton">
		<span id="nl_response_message"></span>		
		</div>
	</div>
	<div class="successbox rightnav_box" id="successbox" style="padding-top: 10px;"></div>
	
</form>

<p></p><p></p>
			 <!--start current newswire-->
							<div class="rightnav_box">
												<h3>Current Newswire:</h3>
												<ul>
																								<li><a href="https://www.linuxtoday.com/developer/linux-weather-forecast-linux-4.14-kernel.html">Linux Weather Forecast Linux 4.14 kernel</a></li>												
												
																								<li><a href="https://www.linuxtoday.com/infrastructure/5-apps-to-install-on-your-fedora-workstation.html">5 apps to install on your Fedora Workstation</a></li>												
												
																								<li><a href="https://www.linuxtoday.com/security/multi-server-samba-installation-to-protect-your-network-against-outages-and-network-attacks.html">Multi-Server Samba Installation to Protect Your Network Against Outages and Network Attacks</a></li>												
												
																								<li><a href="https://www.linuxtoday.com/infrastructure/managing-docker-instances-with-puppet.html">Managing Docker Instances with Puppet</a></li>												
												
																								<li><a href="https://www.linuxtoday.com/infrastructure/chef-expands-its-cloud-and-container-menu.html">Chef expands its cloud and container menu</a></li>												
												
																								<li><a href="https://www.linuxtoday.com/infrastructure/networkmanager-changes-and-improvements.html">NetworkManager changes and improvements</a></li>												
												
																								<li><a href="https://www.linuxtoday.com/infrastructure/kubernetes-the-smart-persons-guide.html">Kubernetes: The smart person's guide</a></li>												
												
																								<li><a href="https://www.linuxtoday.com/high_performance/serverless-computing-picks-up-new-docker-option.html">Serverless computing picks up new Docker option</a></li>												
												
																								<li><a href="https://www.linuxtoday.com/it_management/the-linux-foundation-not-a-friend-of-desktop-linux-the-gpl-or-openness.html">The Linux Foundation: Not a Friend of Desktop Linux, the GPL, or Openness</a></li>												
												
																								<li><a href="https://www.linuxtoday.com/high_performance/radeon-linux-4.11-mesa-17.1-dev-vs.-nvidia-378.13-graphics-performance.html">Radeon Linux 4.11 + Mesa 17.1-dev vs. NVIDIA 378.13 Graphics Performance</a></li>												
												
												</ul>
												</div>		
			
			 <!--end current newswire-->
<p></p>
	<div class="rightnav_box">
		<h3>More on LinuxToday</h3>				
		<ul>
			<li><a href="https://www.linuxtoday.com/sitemap.html">Sitemap</a></li>			
			<li><a href="https://www.linuxtoday.com/feedback.html">Feedback</a></li>
		</ul>
	</div>
</div>
<table cellspacing="0" cellpadding="0" border="0">
	<tbody>
		<tr>
			<td>
				<!-- QS-AD: 'ciu' start -->
<script language="JavaScript">
	var t=displayDFPTag("ciu");
	document.write(t);

</script>
<!-- QS-AD: 'ciu' end -->			</td>
		</tr>
	</tbody>
</table>
<br>
<div class="ciu_div"></div>
<div class="ciu">
	</div>

<!--[if IE 7]>
<br>
<![endif]-->
<div class="article" style="width:698px;">
		<h1>How to Install Varnish Cache with Apache on CentOS 7</h1>
		<span class="article_sub"> Nov 07, 2017, 07:00			(<a href="#comments"><span>0 Talkback[s]</span></a>)  
		</span>		
		 
			<br>
			<span class="article_sub">
						(Other stories by <a href="https://www.linuxtoday.com/author/Muhammad+Arul/">Muhammad Arul</a>)</span> 
				
		<div id="social_media">
    <div id="twitter">
        <a href="https://twitter.com/share" class="twitter-share-button" data-count="none">Tweet</a><script type="text/javascript" src="//platform.twitter.com/widgets.js">
</script>
    </div>
    <div id="google_plus"><!-- Place this tag where you want the +1 button to render -->
        <!-- Place this tag where you want the +1 button to render -->
        <g:plusone size="medium" annotation="none"></g:plusone>

        <!-- Place this render call where appropriate -->
        <script type="text/javascript">
            (function() {
                var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
                po.src = 'https://apis.google.com/js/plusone.js';
                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
            })();
        
</script>
    </div>    
    <div id="facebook_like">
        <iframe src="https://www.facebook.com/plugins/like.php?href=https://www.linuxtoday.com/infrastructure/how-to-install-varnish-cache-with-apache-on-centos-7-171106071025.html&amp;send=false&amp;layout=button_count&amp;width=90&amp;show_faces=true&amp;action=like&amp;colorscheme=light&amp;font&amp;height=21" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:90px; height:21px;" allowTransparency="true"></iframe>
    </div>
</div>
<div style="clear:left;padding-top: 5px;"></div><style>
    #manual-webinar-asset{
        background-color: #EBEBEB;
        border: 3px solid #55c7c7;
        text-align: left;
        padding-top: 5px;
        padding-left: 10px;
        padding-right: 10px;
        padding-bottom: 5px;
        margin-bottom: 10px;
    }
    #manual-webinar-asset h3{
        margin-top: 0px;
        margin-left: 0px;
        margin-right: 0px;
        margin-bottom: 0px;
        display: inline;
        font-size: 20px;
        font-family: 'Oswald',sans-serif;
        font-weight: 600;
    }
    #manual-webinar-asset h3 span{
        color: #55c7c7;
    }
    #manual-webinar-asset #webinar-asset-button{
        background-color: #55c7c7;
        color: white !important;
        border: 0;
        border-radius: 0;
        margin: 5px 5px 0px 15px;
        font-weight: 600;
        padding-left: 25px;
        padding-right: 25px;
    }
    #manual-webinar-asset #redspan{
        color: #D33333 !important;
    }
    #manual-webinar-asset #webinar-title{
        display: inline;
        font-size: 19px;
        font-family: 'Oswald',sans-serif;
        color: #12376f;
    }
    .btn {
        display: inline-block;
        margin-bottom: 0;
        font-weight: normal;
        text-align: center;
        vertical-align: middle;
        touch-action: manipulation;
        cursor: pointer;
        background-image: none;
        border: 1px solid transparent;
        white-space: nowrap;
        padding: 6px 12px;
        font-size: 14px;
        line-height: 1.42857143;
        border-radius: 4px;
        -webkit-user-select: none;
        -moz-user-select: none;
        -ms-user-select: none;
        user-select: none;
    }
</style>
<div id="manual-webinar-asset">
    <div>
        <h3><span>WEBINAR:</span> <span id="redspan"><strong>Live Date: </strong>November 15th, 2017 @ 1:00 p.m. ET / 10:00 a.m. PT</span> </h3>
        <p id="webinar-title">No-Size-Fits-All! An Application-Down Approach for Your Cloud Transformation            <a href="https://o1.qnsr.com/cgi/r?WT.qs_dlk=WgHl2QrIZ7wAAFu1R9oAAAAN;;n=203;c=1643132;s=9543;x=7936;f=201707241338090;u=j;z=TIMESTAMP;k=https%3A%2F%2Fassetform.linuxtoday.com%2Fcontroller%3Fasset%3D234783810%26srvid%3D95980%26vkey%3D26318410%26io%3D230784%26qset%3DCONTACTFORM_HQB%26formHQB%3Dy%26domain%3Dwww.linuxtoday.com" class="btn btn-primary" id="webinar-asset-button" rel="noindex, nofollow" target="_blank">REGISTER > </a>
        </p>
    </div>
</div>		
		<p style="padding-left: 30px;">Varnish is a proxy server focused on HTTP caching. It's designed as an HTTP accelerator and can act as reverse proxy for your web server Apache or Nginx. In this tutorial, we will show you how to install and configure varnish HTTP accelerator as a reverse proxy for Apache web server.</p>					<p><a style="font-size:12px;" href="https://www.howtoforge.com/tutorial/how-to-install-varnish-with-nginx-on-centos-7/">Complete Story</a></p>
		 
		
		</div>
<p><a href="https://www.linuxtoday.com/email/infrastructure/how-to-install-varnish-cache-with-apache-on-centos-7-171106071025.html" rel="nofollow"><img src="https://www.linuxtoday.com/img/emailicon.gif" border="0" width="188" height="29" alt=""/></a><br>
	<a href="https://www.linuxtoday.com/print/infrastructure/how-to-install-varnish-cache-with-apache-on-centos-7-171106071025.html" rel="nofollow"><img src="https://www.linuxtoday.com/img/printicon.gif" border="0" width="205" height="29" alt=""/></a></p>
<input type="hidden" id="blurb_key" value="234814910" name="key">
<div align="center" id="commentsImg" style="display:none;"><img class="deferload" data-original="/img/comments-loader.gif" src="" height="32" weight="32"></div>
<div id="talkback_area">
<p><noscript>Please enable Javascript in your browser, before you post the comment! Now Javascript is disabled.</noscript></p>
<div style="font-weight: bold;"><span id="commentCount">0</span> Talkback[s]&nbsp;
<a href="#comment_form" style="text-decoration: underline;">(click to add your comment)</a>
</div>
<div id="comment_container"></div>   	   
</div>
<div id="comment_acl"></div>

</td>						</tr>
					</tbody>
				</table>
				<div style="background:#F2AA00;height:5px;"></div>
<div style="margin-top: 2px;">	
	<div style="text-align:center;margin-top: 5px;">
		<!-- QS-AD: 'lb' start -->
<script language="JavaScript">
	var t=displayDFPTag("lb");
	document.write(t);

</script>
<!-- QS-AD: 'lb' end -->	</div>
	<div style="text-align:center;margin-top: 5px; margin-bottom: 5px;">
	<style type="text/css">
#developerBrand-footer{text-align:center;margin:0 auto}
#footerlinks{font-size:12px;word-spacing:1px}
#footerlinks a{color:#000;margin:5px 0 0}
#itbeBrand-footer{text-align:center;margin:0 auto}
#itbusinessedge-footer{text-align:center;margin:0 auto}
#footercopyright{font-size:12px;margin:5px 0 0}
#developerBrandForum-footer{text-align:center;margin:0 auto}
#itbeBrandForum-footer{text-align:center;margin:0 auto}
#eweek-truste-footer{text-align:center;margin:0 auto}
#developerBrand-truste-footer{text-align:center;margin:0 auto}
#itbeBrand-truste-footer{text-align:center;margin:0 auto}
#weboitbeBrand-truste-footer{text-align:center;margin:0 auto}
#itbusinessedge-truste-footer{text-align:center;margin:0 auto}
.footerLogoClass{text-align:center;margin:0 auto}
</style>
<div id="developerBrand-footer" style="display:none"></div>
<div id="itbeBrand-footer" style="display:none"></div>
<div id="itbusinessedge-footer" style="display:none"></div>
<div id="zde-footer" style="display:none" class="footerLogoClass"></div>
<div id="baseline-footer" style="display:none" class="footerLogoClass"></div>
<div id="cinsider-footer" style="display:none" class="footerLogoClass"></div>
<div id="cioinsight-footer" style="display:none" class="footerLogoClass"></div>
<div id="eweek-footer" style="display:none" class="footerLogoClass"></div>
<div id="enterpriseappstoday-footer" style="display:none" class="footerLogoClass"></div>
<div id="eseminar-footer" style="display:none" class="footerLogoClass"></div>
<div id="wbg-footer" style="display:none" class="footerLogoClass"></div>
<div id="developerBrandForum-footer" style="display:none"></div>
<div id="itbeBrandForum-footer" style="display:none"></div>
<div id="eweek-truste-footer" style="display:none" class="footerLogoClass"></div>
<div id="developerBrand-truste-footer" style="display:none"></div>
<div id="itbeBrand-truste-footer" style="display:none"></div>
<div id="weboitbeBrand-truste-footer" style="display:none"></div>
<div id="itbusinessedge-truste-footer" style="display:none"></div>
<script async language="Javascript" src="/icom_includes/footers/scripts/footerbrandingcode.js">
</script>
</div>
</div>    	</div>
                <script type="text/javascript" src="/hqx/min/?b=js&f=validate.js,charactercount.js,article.js,jquery.cookie.min.js,lazyload-min.js,common.js&v=1" defer async">
</script>
		<script type="text/javascript">
		// Add a script element as a child of the body
		function downloadJSAtOnload() {
		var element = document.createElement("script");
		element.src = "/hqx/sl/?g=js";
		document.body.appendChild(element);
		}

		// Check for browser support of event handling capability
		if (window.addEventListener)
		window.addEventListener("load", downloadJSAtOnload, false);
		else if (window.attachEvent)
		window.attachEvent("onload", downloadJSAtOnload);
		else window.onload = downloadJSAtOnload;
		
</script>		
   </body>
</html>
