dcsimg
Linux Today: Linux News On Internet Time.





More on LinuxToday


Gentoo Linux Advisories: cadaver, XChat, monit

Apr 20, 2004, 12:55 (0 Talkback[s])
Gentoo Linux Security Advisory GLSA 200404-14

http://security.gentoo.org/


Severity: Normal
Title: Multiple format string vulnerabilities in cadaver
Date: April 19, 2004
Bugs: #47799
ID: 200404-14


Synopsis

There are multiple format string vulnerabilities in the neon library used in cadaver, possibly leading to execution of arbitrary code when connected to a malicious server.

Background

According to http://www.webdav.org/cadaver, cadaver is a command-line WebDAV client for Unix. It supports file upload, download, on-screen display, namespace operations (move/copy), collection creation and deletion, and locking operations.

Affected packages

Package Vulnerable Unaffected
net-misc/cadaver < 0.22.1 >= 0.22.1

Description

Cadaver code includes the neon library, which in versions 0.24.4 and previous is vulnerable to multiple format string attacks. The latest version of cadaver uses version 0.24.5 of the neon library, which makes it immune to this vulnerability.

Impact

When using cadaver to connect to an untrusted WebDAV server, this vulnerability can allow a malicious remote server to execute arbitrary code on the client with the rights of the user using cadaver.

Workaround

A workaround is not currently known for this issue. All users are advised to upgrade to the latest version of the affected package.

Resolution

cadaver users should upgrade to version 0.22.1 or later:

    # emerge sync
    # emerge -pv ">=net-misc/cadaver-0.22.1"
    # emerge ">=net-misc/cadaver-0.22.1"

References

[ 1 ] http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0179

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200404-14.xml

Concerns?

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at http://bugs.gentoo.org.

License

Copyright 2004 Gentoo Technologies, Inc; referenced text belongs to its owner(s).


Gentoo Linux Security Advisory GLSA 200404-15

http://security.gentoo.org/


Severity: Low
Title: XChat 2.0.x SOCKS5 Vulnerability
Date: April 19, 2004 Bugs: #46856
ID: 200404-15


Synopsis

XChat is vulnerable to a stack overflow that may allow a remote attacker to run arbitrary code.

Background

XChat is a multiplatform IRC client.

Affected packages

Package Vulnerable Unaffected
net-irc/xchat < 2.0.8-r1 >= 2.0.8-r1

Description

The SOCKS 5 proxy code in XChat is vulnerable to a remote exploit. Users would have to be using XChat through a SOCKS 5 server, enable SOCKS 5 traversal which is disabled by default and also connect to an attacker's custom proxy server.

Impact

This vulnerability may allow an attacker to run arbitrary code within the context of the user ID of the XChat client.

Workaround

A workaround is not currently known for this issue. All users are advised to upgrade to the latest version of the affected package.

Resolution

All XChat users should upgrade to the latest stable version:

# emerge sync

# emerge -pv ">=net-irc/xchat-2.0.8-r1" # emerge ">=net-irc/xchat-2.0.8-r1"

Note that users of the gtk1 version of xchat (1.8.*) should upgrade to xchat-1.8.11-r1:

    # emerge sync
    # emerge -pv "=net-irc/xchat-1.8.11-r1"
    # emerge "=net-irc/xchat-1.8.11-r1"

References

[ 1 ] http://mail.nl.linux.org/xchat-announce/2004-04/msg00000.html

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200404-15.xml

Concerns?

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at http://bugs.gentoo.org.

License

Copyright 2004 Gentoo Technologies, Inc; referenced text belongs to its owner(s).


Gentoo Linux Security Advisory GLSA 200404-16

http://security.gentoo.org/


Severity: High
Title: Multiple new security vulnerabilities in monit
Date: April 19, 2004
Bugs: #47631 ID: 200404-16


Synopsis

Two new vulnerabilities have been found in the HTTP interface of monit, possibly leading to denial of service or execution of arbitrary code.

Background

Monit is a system administration utility that allows management and monitoring of processes, files, directories and devices on a Unix system.

Affected packages

Package Vulnerable Unaffected
app-admin/monit <= 4.2 >= 4.2.1

Description

Monit has several vulnerabilities in its HTTP interface : a buffer overflow vulnerability in the authentication handling code and a off-by-one error in the POST method handling code.

Impact

An attacker may exploit the off-by-one error to crash the Monit daemon and create a denial of service condition, or cause a buffer overflow that would allow arbitrary code to be executed with root privileges.

Workaround

A workaround is not currently known for this issue. All users are advised to upgrade to the latest version of the affected package.

Resolution

Monit users should upgrade to version 4.2.1 or later:

    # emerge sync
    # emerge -pv ">=app-admin/monit-4.2.1"
    # emerge ">=app-admin/monit-4.2.1"

References

[ 1 ] http://www.tildeslash.com/monit/secadv_20040305.txt

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200404-16.xml

Concerns?

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at http://bugs.gentoo.org.

License

Copyright 2004 Gentoo Technologies, Inc; referenced text belongs to its owner(s).

The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0