dcsimg
Linux Today: Linux News On Internet Time.




More on LinuxToday


Gentoo Linux Advisories: Mozilla, CUPS, Foomatic

Sep 21, 2004, 14:28 (0 Talkback[s])

Gentoo Linux Security Advisory GLSA 200409-26

http://security.gentoo.org/


Severity: Normal
Title: Mozilla, Firefox, Thunderbird, Epiphany: New releases fix vulnerabilities
Date: September 20, 2004
Bugs: #63996
ID: 200409-26


Synopsis

New releases of Mozilla, Epiphany, Mozilla Thunderbird, and Mozilla Firefox fix several vulnerabilities, including the remote execution of arbitrary code.

Background

Mozilla is a popular web browser that includes a mail and newsreader. Epiphany is a web browser that uses Gecko, the Mozilla rendering engine. Mozilla Firefox and Mozilla Thunderbird are respectively the next-generation browser and mail client from the Mozilla project.

Affected packages


Package Vulnerable Unaffected
1 mozilla < 1.7.3 >= 1.7.3
2 mozilla-firefox < 1.0_pre >= 1.0_pre
3 mozilla-thunderbird < 0.8 >= 0.8
4 mozilla-bin < 1.7.3 >= 1.7.3
5 mozilla-firefox-bin < 1.0_pre >= 1.0_pre
6 mozilla-thunderbird-bin < 0.8 >= 0.8
7 epiphany < 1.2.9-r1 >= 1.2.9-r1

7 affected packages on all of their supported architectures.


Description

Mozilla-based products are vulnerable to multiple security issues. Firstly routines handling the display of BMP images and VCards contain an integer overflow and a stack buffer overrun. Specific pages with long links, when sent using the "Send Page" function, and links with non-ASCII hostnames could both cause heap buffer overruns.

Several issues were found and fixed in JavaScript rights handling: untrusted script code could read and write to the clipboard, signed scripts could build confusing grant privileges dialog boxes, and when dragged onto trusted frames or windows, JavaScript links could access information and rights of the target frame or window. Finally, Mozilla-based mail clients (Mozilla and Mozilla Thunderbird) are vulnerable to a heap overflow caused by invalid POP3 mail server responses.

Impact

An attacker might be able to run arbitrary code with the rights of the user running the software by enticing the user to perform one of the following actions: view a specially-crafted BMP image or VCard, use the "Send Page" function on a malicious page, follow links with malicious hostnames, drag multiple JavaScript links in a row to another window, or connect to an untrusted POP3 mail server. An attacker could also use a malicious page with JavaScript to disclose clipboard contents or abuse previously-given privileges to request XPI installation privileges through a confusing dialog.

Workaround

There is no known workaround covering all vulnerabilities.

Resolution

All users should upgrade to the latest stable version:

    # emerge sync
    # emerge -pv your-version
    # emerge your-version

References

[ 1 ] Mozilla Security Advisory

http://www.mozilla.org/projects/security/known-vulnerabilities.html#mozilla1.7.3

[ 2 ] US-CERT Security Alert TA04-261A

http://www.us-cert.gov/cas/techalerts/TA04-261A.html

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200409-26.xml

Concerns?

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at http://bugs.gentoo.org.

License

Copyright 2004 Gentoo Foundation, Inc; referenced text belongs to its owner(s).

The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0


Gentoo Linux Security Advisory GLSA 200409-25

http://security.gentoo.org/


Severity: Normal
Title: CUPS: Denial of service vulnerability
Date: September 20, 2004
Bugs: #64168
ID: 200409-25


Synopsis

A vulnerability in CUPS allows remote attackers to cause a denial of service when sending a carefully-crafted UDP packet to the IPP port.

Background

The Common UNIX Printing System (CUPS) is a cross-platform print spooler.

Affected packages


Package Vulnerable Unaffected
1 net-print/cups < 1.1.20-r2 >= 1.1.20-r2

Description

Alvaro Martinez Echevarria discovered a hole in the CUPS Internet Printing Protocol (IPP) implementation that allows remote attackers to cause CUPS to stop listening on the IPP port. This can be caused by sending an empty UDP datagram packet to the IPP port.

Impact

A remote user with malicious intent can easily cause a denial of service to the CUPS daemon.

Workaround

There is no known workaround at this time.

Resolution

All CUPS users should upgrade to the latest version:

    # emerge sync
    # emerge -pv ">=net-print/cups-1.1.20-r2"
    # emerge ">=net-print/cups-1.1.20-r2"

References

[ 1 ] CUPS Software Trouble Report

http://www.cups.org/str.php?L863

[ 2 ] CAN-2004-0558

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0558

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200409-25.xml

Concerns?

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at http://bugs.gentoo.org.

License

Copyright 2004 Gentoo Foundation, Inc; referenced text belongs to its owner(s).

The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0


Gentoo Linux Security Advisory GLSA 200409-24

http://security.gentoo.org/


Severity: High
Title: Foomatic: Arbitrary command execution in foomatic-rip filter
Date: September 20, 2004
Bugs: #64166
ID: 200409-24


Synopsis

The foomatic-rip filter in foomatic-filters contains a vulnerability which may allow arbitrary command execution on the print server.

Background

Foomatic is a system for connecting printer drivers with spooler systems such as CUPS and LPD. The foomatic-filters package contains wrapper scripts which are designed to be used with Foomatic.

Affected packages


Package Vulnerable Unaffected
1 net-print/foomatic <= 3.0.1 >= 3.0.2
2 net-print/foomatic-filters <= 3.0.1 >= 3.0.2

2 affected packages on all of their supported architectures.


Description

There is a vulnerability in the foomatic-filters package. This vulnerability is due to insufficient checking of command-line parameters and environment variables in the foomatic-rip filter.

Impact

This vulnerability may allow both local and remote attackers to execute arbitrary commands on the print server with the permissions of the spooler (oftentimes the "lp" user).

Workaround

There is no known workaround at this time.

Resolution

All foomatic users should upgrade to the latest version:

    # emerge sync
    # emerge -pv ">=net-print/foomatic-3.0.2"
    # emerge ">=net-print/foomatic-3.0.2"

PLEASE NOTE: You should update foomatic, instead of foomatic-filters. This will help to ensure that all other foomatic components remain functional.

References

[ 1 ] Foomatic Announcement

http://www.linuxprinting.org/pipermail/foomatic-devel/2004q3/001996.html

[ 2 ] Mandrakesoft Security Advisory

http://www.mandrakesoft.com/security/advisories?name=MDKSA-2004:094

[ 3 ] CAN 2004-0801

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0801

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200409-24.xml

Concerns?

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at http://bugs.gentoo.org.

License

Copyright 2004 Gentoo Foundation, Inc; referenced text belongs to its owner(s).

The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0