dcsimg
Linux Today: Linux News On Internet Time.





More on LinuxToday


Advisories, May 16, 2006

May 17, 2006, 04:45 (0 Talkback[s])
Gentoo Linux Security Advisory [ERRATA UPDATE] GLSA 200605-07:02

http://security.gentoo.org/


Severity: High
Title: Nagios: Buffer overflow
Date: May 07, 2006
Updated: May 16, 2006
Bugs: #132159, #133487
ID: 200605-07:02


Errata

The previous upstream release failed to take into account an integer overflow condition when performing bounds checking. Users are urged to upgrade to 1.4.1 which resolves the issue.

The corrected sections appear below.

Affected packages


     Package                   /  Vulnerable  /             Unaffected

  1  net-analyzer/nagios-core       < 1.4.1                   >= 1.4.1

Resolution

All Nagios users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=net-analyzer/nagios-core-1.4.1"

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200605-07.xml

Concerns?

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at http://bugs.gentoo.org.

License

Copyright 2006 Gentoo Foundation, Inc; referenced text belongs to its owner(s).

The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5


Gentoo Linux Security Advisory [UPDATE] GLSA 200605-13:04

http://security.gentoo.org/


Severity: Low
Title: MySQL: Information leakage
Date: May 11, 2006
Updated: May 15, 2006
Bugs: #132146
ID: 200605-13:04


Update

For a short time version 4.0.27 was incorrectly listed as vulnerable and the resolution incorrectly forced an upgrade to 4.1.x for 4.0.x users.

The updated sections appear below.

Affected packages


     Package       /  Vulnerable  /                         Unaffected


1 dev-db/mysql < 4.1.19 >= 4.1.19 *>= 4.0.27

Resolution

All MySQL users should upgrade to the latest version.

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-db/mysql-4.0.27"

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200605-13.xml

Concerns?

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at http://bugs.gentoo.org.

License

Copyright 2006 Gentoo Foundation, Inc; referenced text belongs to its owner(s).

The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5