<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
	<head>

	<meta name="WT.qs_dlk" content="XtvrfF5eo3e0p2tLSZ0WsAAAAAw"/>

	<meta name="WT.qs_shmv" content="hv20200211-chiron.sf.quinstreet.net"/>

	<meta name="inject_params" content="WT.qs_dlk=XtvrfF5eo3e0p2tLSZ0WsAAAAAw&"/>

<script>!function(){if(!window.BOOMR||!window.BOOMR.version){var e,t,n,o=document.createElement("iframe");o.src="javascript:false",o.title="",o.role="presentation",(o.frameElement||o).style.cssText="width:0;height:0;border:0;display:none;",(n=document.getElementsByTagName("script")[0]).parentNode.insertBefore(o,n);try{t=o.contentWindow.document}catch(n){e=document.domain,o.src="javascript:var d=document.open();d.domain='"+e+"';void(0);",t=o.contentWindow.document}t.open()._l=function(){var t=this.createElement("script");e&&(this.domain=e),t.id="boomr-if-as",t.src="/imageserver/common/sg/1.0/sg.min.js",BOOMR_lstart=(new Date).getTime(),this.body.appendChild(t)},t.write('<body onload="document._l();">'),t.close()}}();</script>
<script>
                document.cookie = 'inject_params=WT.qs_dlk=XtvrfF5eo3e0p2tLSZ0WsAAAAAw&; path=/;  domain=linuxtoday.com;; SameSite=None; Secure;';
                document.cookie = 'WMUUID=XtvrfF5eo3e0p2tLSZ0WsAAAAAw; path=/;  domain=linuxtoday.com;; SameSite=None; Secure;';
            </script>
    	<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<title>Linux Today - GNU Linux-Libre 5.7 Kernel Is Out for Those Seeking 100% Freedom for Their PCs</title>
<meta name="description" content="Based on the recently released Linux 5.7 kernel series, the GNU Linux-Libre 5.7 kernel is here." />
<meta name="keywords" content="" />
<meta name="channel" content="IT" />
<link rel="canonical" href="https://www.linuxtoday.com/upload/gnu-linux-libre-5.7-kernel-is-out-for-those-seeking-freedom-for-their-pcs.html" />
<meta name="articleKey" content="236852210"/>
<meta name='qs.quad.keywords' content='{keywords:"97160|95970|95960|935613|95850",nodes:"97160"}' >
<link rel="alternate"  type="application/rss+xml" title="Linux Today RSS" href="/biglt.rss">
<link rel="apple-touch-icon" href="/img/apple-touch-icon-iphone.png" />
<link rel="apple-touch-icon" sizes="72x72" href="/img/apple-touch-icon-ipad.png" />
<link rel="apple-touch-icon" sizes="114x114" href="/img/apple-touch-icon-iphone4.png" />
<link rel="apple-touch-icon" sizes="144x144" href="/img/apple-touch-icon-ipad3.png" />

<link rel="alternate" media="only screen and (max-width: 640px)" href="https://mobile.linuxtoday.com/upload/gnu-linux-libre-5.7-kernel-is-out-for-those-seeking-freedom-for-their-pcs.html" />

<link type="text/css" rel="stylesheet" name="min-css" media="screen" href="/hqx/min/?b=css&f=text.css,comments.css&v=4"/>
<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.min.js"></script> 
<script type="text/javascript" src="/hqb2b/js/globalNewsletter.js"></script>
<script type="text/javascript" src="/hqb2b/js/underscore.js"></script>
<script type="text/javascript" src="/hqb2b/js/tracker.js"></script>
<script type="text/javascript" src="/hqb2b/js/sl_widget_tracker.js"></script>
<script type="text/javascript" src="/hqb2b/js/monetization_widget.js"></script>

<!-- BEGIN DFP core -->
<script type='text/javascript'>
window.qs={consent:{ready:false,service:{dfp:{dc:false},krux:{dc:false,al:false,tg:false,cd:false,sh:false,re:false},ml:{dc:false}}},dfp:{ready:false,tags:{}},krux:{dn:'',jf:'',dr:'',ir:'',noer:''}};
function gDFPC(e){var n=e+"=";var ca=document.cookie.split(';');for(var i=0;i<ca.length;i++){var c=ca[i].replace(/^\s+|\s+$/g,'');if(c.indexOf(n)==0) return c.substring(n.length,c.length);}return "";}function sDFPC(c,v,e,t){var d=new Date();if(t=="mo"){d.setMonth(d.getMonth()+e);}else if(t=="hr"){d.setTime(d.getTime()+(e*60*60*1000));}else if(t=="min"){d.setTime(d.getTime()+(e*60*1000));}else if(t=="sec"){d.setTime(d.getTime()+(e*1000));}else{d.setTime(d.getTime()+(e*24*60*60*1000));}var exp="expires="+d.toUTCString();document.cookie=c+"="+v+";"+exp+";path=/";}function cDFPC(c){if(gDFPC(c)!="")return 1;return 0;}function cKVs(v){if(Array.isArray(v)){for(i=0;i<v.length;i++){v[i]=v[i].replace(/["'=!+#*~;^()<>\[\],&]/g,'').replace(/\s+/g,' ').replace(/^\s+|\s+$/g,'');}}else{v=v.replace(/["'=!+#*~;^()<>\[\],&]/g,'').replace(/\s+/g,' ').replace(/^\s+|\s+$/g,'');}return v;}var mbw=window.innerWidth||document.documentElement.clientWidth||document.body.clientWidth;var myWTDLK=gDFPC('WMUUID');var mlWTFP="";var myWTtemp=gDFPC('WT_FPC').split(":");for(var i=0;i<myWTtemp.length;i++){if(myWTtemp[i].search("id=")==0){mlWTFP=myWTtemp[i].slice(3);}}var qsDFPSec=(location.protocol==="https:"?"true":"false");
</script>

<!-- Consent info -->
<script type="text/javascript">
    if (cDFPC('_qscon')) {
        if (typeof window.qs != 'undefined' && window.qs.consent) {
            window.qs.consent.service = JSON.parse(gDFPC('_qscon'));
        }
    }
</script>

<script type='text/javascript'>
var n_imu=0,n_ic_imu=0,n_lb=0,n_sky=0,n_wap=0,n_qmp=0,n_m_lb=0,n_m_imu=0,n_m_ic_imu=0,n_ic=0;function refreshDFPTags(){if(typeof googletag.pubads!='undefined'){for(var slot_id_simple in window.qs.dfp.tags){if(window.qs.dfp.tags.hasOwnProperty(slot_id_simple)&&window.qs.dfp.tags[slot_id_simple]!=null){if(typeof window.qs.dfp.tags[slot_id_simple].slot!='undefined'&&window.qs.dfp.tags[slot_id_simple].refreshable){window.qs.dfp.tags[slot_id_simple].refreshed=true;window.qs.dfp.tags[slot_id_simple].refresh_counter++;googletag.pubads().refresh([window.qs.dfp.tags[slot_id_simple].slot],{changeCorrelator: false});}}}}}function hideQSDiv(e){if(typeof googletag.pubads!='undefined'){var slot_id=e.replace(/-outer/,'');var slot_id_simple=slot_id.replace(/-/g,'');if(typeof window.qs.dfp.tags[slot_id_simple].slot!='undefined'){googletag.destroySlots([window.qs.dfp.tags[slot_id_simple].slot]);window.qs.dfp.tags[slot_id_simple]=null;}}if(document.getElementById){document.getElementById(e).style.visibility="hidden";document.getElementById(e).innerHTML="";}}
</script>
<script type='text/javascript'>
console.log('QS: DFP GPT Code');var googletag=googletag||{};googletag.cmd=googletag.cmd||[];(function(){var gads=document.createElement("script");gads.async=true;gads.type="text/javascript";gads.src=(location.protocol==="https:"?"https:":"http:")+"//securepubads.g.doubleclick.net/tag/js/gpt.js";var node=document.getElementsByTagName("script")[0];node.parentNode.insertBefore(gads,node);})();
</script>
<script type='text/javascript'>
console.log('QS: DFP Tag Code');function displayDFPTag(tag){var tag_code="";var this_tag_pos=0;var this_tag_div_style="";var this_tag_inner_div_style="";var this_tag_notice="";var this_tag_close="";if(tag.match(/^sponsor-logo.*/)){var temp=tag.split(":");tag=temp[0];this_tag_pos=temp[1];}switch(tag){case "imu":this_tag_pos=++n_imu;break;case "ic_imu":this_tag_pos=++n_ic_imu;this_tag_div_style=" style='width:300px;text-align:center;padding:0px 0px 20px 0px;margin:0 auto;'";this_tag_notice=" <div style=\"text-align:right;margin:0 auto;font-family:'Helvetica Neue 55 Roman',Helvetica,Arial,san-serif;color:#666666;font-size:10px;font-weight:normal;\">Advertisement</div>";break;case "lb":this_tag_pos=++n_lb;if(this_tag_pos===1){this_tag_notice="    <div id='"+tag+"-"+this_tag_pos+"-notice' style=\"text-align:center;margin:0 auto;height:0;visibility:hidden;font-family:'Helvetica Neue 55 Roman',Helvetica,Arial,san-serif;color:#666666;font-size:10px;font-weight:normal;\">Advertisement</div>";this_tag_close="    <div id='"+tag+"-"+this_tag_pos+"-close' style=\"text-align:center;margin:0 auto;height:0;visibility:hidden;\"><a href=\"javascript:hideQSDiv('"+tag+"-"+this_tag_pos+"-outer')\" style=\"font-family:'Helvetica Neue 55 Roman',Helvetica,Arial,san-serif;color:#666666;font-size:12px;font-weight:normal;text-decoration:none;\">Close X</a></div>";}break;case "sky":this_tag_pos=++n_sky;break;case "wap":this_tag_pos=++n_wap;break;case "qmp":this_tag_pos=++n_qmp;break;case "sponsor-logo":break;case "m_lb":this_tag_pos=++n_m_lb;if(this_tag_pos===1){this_tag_notice="    <div id='"+tag+"-"+this_tag_pos+"-notice' style=\"text-align:center;margin:0 auto;height:0;visibility:hidden;font-family:'Helvetica Neue 55 Roman',Helvetica,Arial,san-serif;color:#666666;font-size:10px;font-weight:normal;\">Advertisement</div>";}break;case "m_imu":this_tag_pos=++n_m_imu;break;case "m_ic_imu":this_tag_pos=++n_m_ic_imu;this_tag_div_style=" style='width:300px;text-align:center;padding:0px 0px 20px 0px;margin:0 auto;'";this_tag_notice=" <div style=\"text-align:center;margin:0 auto;font-family:'Helvetica Neue 55 Roman',Helvetica,Arial,san-serif;color:#666666;font-size:10px;font-weight:normal;\">Advertisement</div>";break;case "ic":this_tag_pos=++n_ic;this_tag_div_style=" style='width:300px;text-align:center;padding:0px 0px 20px 0px;margin:0 auto;'";this_tag_notice=" <div style=\"text-align:center;margin:0 auto;font-family:'Helvetica Neue 55 Roman',Helvetica,Arial,san-serif;color:#666666;font-size:10px;font-weight:normal;\">Advertisement</div>";break;default:return "<!-- QS-DFP: Unknown tag '"+tag+"' requested -->";}var this_tag_div_id=tag+"-"+this_tag_pos;if(this_tag_notice){tag_code+="<div id='"+this_tag_div_id+"-outer' style='text-align:center;margin: 0 auto;'>\n"+this_tag_notice+"\n";}tag_code+="<div id='"+this_tag_div_id+"'"+this_tag_div_style+">\n"+"    <scr"+"ipt type=\"text/javascript\">\n"+"        googletag.cmd.push(function() {\n"+"            googletag.display('"+this_tag_div_id+"');\n"+"        });\n"+"    </scr"+"ipt>\n"+"</div>\n";if(this_tag_close){tag_code+=this_tag_close+"\n";}if(this_tag_notice){tag_code+="</div>\n";}if(this_tag_inner_div_style){tag_code+="<style type=\"text/css\">#"+this_tag_div_id+"_ad_container{height:0px;}</style>\n";}return tag_code;}
</script>
<!-- END DFP core -->

    <!-- BEGIN Evidon -->
    <script type='text/javascript'>
        console.log('QS: Evidon Code');
        (function (id) {
    function append(scriptid, url, async) {
        var d = document, sn = 'script', f = d.getElementsByTagName(sn)[0];
        if (!f) f = d.head;
        var s = d.createElement(sn);
        s.async = true;
        s.id = scriptid;
        s.src = url;
        f.parentNode.insertBefore(s, f);
    }

    function getRootDomain() {
        var parts = window.location.hostname.split('.');
        if (parts.length === 2) rootDomain = parts[0];
        else if (parts.length > 2) {
          // see if the next to last value is a common tld
          var part = parts[parts.length - 2];
          if (part === 'com' || part === 'co') {
            rootDomain = parts[parts.length - 3]; // go back one more
          }
          else {
            rootDomain = part;
          }
        }

      return rootDomain;
    }

    window.evidon = {};
    window.evidon.id = id;
    var cdn = '//c.evidon.com/', rootDomain = getRootDomain(), noticecdn = cdn + 'sitenotice/';
    append('evidon-notice', noticecdn + 'evidon-sitenotice-tag.js', false);
    append('evidon-location', cdn + 'geo/country.js', true);
    append('evidon-themes', noticecdn + id + '/snthemes.js', true);
    if (rootDomain) append('evidon-settings', noticecdn + id + '/' + rootDomain + '/settings.js', true);

    window.evidon.priorConsentCallback = function () {
        // add the tags which need to wait for prior consent
        // here.  This should be all your advertising tags and
        // probably most of your social and tracking tags.

        // QS globals
        window.qs.consent.ready = true;
    }

    window.evidon.closeCallback = function () {
        // this is executed when a user closes a UI element (banner/barrier) without
        // providing consent.

        // QS globals
        window.qs.consent.ready = true;
    }

    window.evidon.consentWithdrawnCallback = function () {
        // this is exeucted if the user withdraws consent and elects to
        // no longer allow technologies to run on the site.

        // QS globals
        window.qs.consent.ready = true;
    }

    window.evidon.consentDeclinedCallback = function () {
        // this is executed if the user explicitly declines giving consent by
        // using a Decline button

        // QS globals
        window.qs.consent.ready = true; 
    }
})(704);
    </script>
    <!-- END Evidon -->

    <meta NAME="DCSext.tax" content="product platform os linux,audience purchase stage not applicable" />
    <meta NAME="DCSext.qse_b2b_tax" content="product platform os linux,audience purchase stage not applicable" />

    <!-- BEGIN Krux -->
    <script type="text/javascript">
        window.qs.krux.dn=gDFPC('dn'),window.qs.krux.jf=gDFPC('jf'),window.qs.krux.dr=gDFPC('dr'),window.qs.krux.ir=gDFPC('ir'),window.qs.krux.noer=gDFPC('noer');
    </script>
    <script class="kxint" type="text/javascript">
        console.log('QS: Krux Interchange Tag');
        window.Krux||((Krux=function(){Krux.q.push(arguments);}).q=[]);(function(){function retrieve(n){var k='kx'+''+n,ls=(function(){try{return window.localStorage;}catch(e){return null;}})();if(ls){return ls[k]||'';}else if(navigator.cookieEnabled){var m=document.cookie.match(k+'=([^;]*)');return (m&&unescape(m[1]))||'';}else{return '';}}Krux.user=retrieve('user');Krux.segments=retrieve('segs')?retrieve('segs').split(','):[];})();
    </script>
    <script class="kxct" data-id="JdOofiLA" data-timing="async" data-version="3.0" type="text/javascript">
        console.log('QS: Krux Control Tag');
        window.Krux||((Krux=function(){Krux.q.push(arguments)}).q=[]);(function(){var k=document.createElement('script');k.type='text/javascript';k.async=true;k.src=(location.protocol==='https:'?'https:':'http:')+'//cdn.krxd.net/controltag/JdOofiLA.js';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(k,s);}());
    </script>
    <script type="text/javascript">
        console.log('QS: Krux Data Layer');
        var kruxDataLayer={"page":{"domain":"www.linuxtoday.com","section":"upload","category":"upload","keywords":"PCs and peripherals,personal computer,pc,desktop,workstation,platform,OS Linux,security,servers,server operating systems,Linux server operatting system,data center,cloud computing,mobile,mobile operating systems,Android","url_path_1":"https://www.linuxtoday.com/upload/gnu-linux-libre-5.7-kernel-is-out-for-those-seeking-freedom-for-their-pcs.html","env":"prod"},"user":{"dn":'',"jf":'',"dr":'',"ir":'',"noer":''}};if(typeof window.qs!='undefined'&&window.qs.consent.service.krux.dc&&window.qs.consent.service.krux.al&&window.qs.consent.service.krux.tg&&window.qs.consent.service.krux.cd){if(typeof window.qs.krux.dn!='undefined'&&window.qs.krux.dn!='null'){kruxDataLayer.user.dn=window.qs.krux.dn;}if(typeof window.qs.krux.jf!='undefined'&&window.qs.krux.jf!='null'){kruxDataLayer.user.jf=window.qs.krux.jf;}if(typeof window.qs.krux.dr!='undefined'&&window.qs.krux.dr!='null'){kruxDataLayer.user.dr=window.qs.krux.dr;}if(typeof window.qs.krux.ir!='undefined'&&window.qs.krux.ir!='null'){kruxDataLayer.user.ir=window.qs.krux.ir;}if(typeof window.qs.krux.noer!='undefined'&&window.qs.krux.noer!='null'){kruxDataLayer.user.noer=window.qs.krux.noer;}}    </script>
    <script type="text/javascript">
        console.log('QS: Krux Consent Tag');
        Krux('consent:set',{dc:window.qs.consent.service.krux.dc,al:window.qs.consent.service.krux.al,tg:window.qs.consent.service.krux.tg,cd:window.qs.consent.service.krux.cd,sh:window.qs.consent.service.krux.sh,re:window.qs.consent.service.krux.re},function(errors,body){if(errors){console.error('QS: SF/DMP Errors :: '+errors);}else{console.log('QS: Successfully set SF/DMP consent flags');}});
    </script>
    <!-- END Krux -->

    <!-- BEGIN ML -->
    <script type='text/javascript'>
        console.log('QS: ML Tag');
        if (typeof window.qs != 'undefined' && window.qs.consent.service.ml.dc) {
            var mlCLID="50443";if(typeof mlCLID!='undefined'){var mlEml=gDFPC('eml');(function(f,i,c){var a=decodeURIComponent,e="",l="",o="||",g=";;",h="split",b="length",j="indexOf",k=0,n="localStorage",m="_ccmdt";f[c]=f[c]||{};function d(q){var p;if(f[n]){return f[n][q]||""}else{p=i.cookie.match(q+"=([^;]*)");return(p&&p[1])||""}}f[c].us={};e=a(d(m))[h](o);k=e[b];if(k>0){while(k--){l=e[k][h]("=");if(l[b]>1){if(l[1][j](g)>-1){f[c].us[l[0]]=l[1][h](g);f[c].us[l[0]].pop()}else{f[c].us[l[0]]=l[1]}}}}})(window,document,"_ml");(function(){_ml=window._ml||{};_ml.eid='50027';_ml.clid=mlCLID;if(typeof mlEml!='undefined'){_ml.em=mlEml;}else{_ml.em='';}_ml.ht='shex';_ml.fp=mlWTFP;_ml.redirect=(location.protocol==='https:'?'https:':'http:')+'//beacon.krxd.net/usermatch.gif?partner=madisonlogic&partner_uid=[PersonID]';_ml.informer={enable:true};var s=document.getElementsByTagName('script')[0],cd=new Date(),mltag=document.createElement('script');mltag.type='text/javascript';mltag.async=true;mltag.src=(location.protocol==='https:'?'https:':'http:')+'//ml314.com/tag.aspx?'+cd.getDate()+cd.getMonth()+cd.getFullYear();s.parentNode.insertBefore(mltag,s);})();}
        }
    </script>
    <!-- END ML -->


    <!-- BEGIN GA -->
    <script type='text/javascript'>
        console.log('QS: GA Tag');
        var gaSID="UA-48217604-1";(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[  0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','//www.google-analytics.com/analytics.js','ga');ga('create', gaSID, 'auto');ga('set', 'anonymizeIp', true);ga('send', 'pageview');
    </script>
    <!-- END GA -->

            <!-- BEGIN DFP Visibility -->
        <script type="text/javascript">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</script>
        <!-- END DFP Visibility -->
    
<script type="text/javascript">
    var waitForConsent = timeoutms => new Promise((resolve, reject)=>{
        var checkConsent = () => {
            if (timeoutms && (timeoutms % 1000) == 0)
                console.log('QS: Checking for consent data');
            if (typeof window.qs != 'undefined' && window.qs.consent.ready && typeof window.evidon != 'undefined' && window.evidon.notice) {
                // DFP
                window.qs.consent.service.dfp.dc = window.evidon.notice.consentIsGiven;
                // Salseforce/Krux
                window.qs.consent.service.krux.dc = window.evidon.notice.consentIsGiven;
                window.qs.consent.service.krux.al = window.evidon.notice.consentIsGiven;
                window.qs.consent.service.krux.tg = window.evidon.notice.consentIsGiven;
                window.qs.consent.service.krux.cd = window.evidon.notice.consentIsGiven;
                window.qs.consent.service.krux.sh = window.evidon.notice.consentIsGiven;
                window.qs.consent.service.krux.re = window.evidon.notice.consentIsGiven;
                // ML
                window.qs.consent.service.ml.dc = window.evidon.notice.consentIsGiven;

                // Set QS consent cookie
                sDFPC('_qscon', JSON.stringify(window.qs.consent.service), 13, 'mo');

                resolve("QS: Consent data is ready");
            } else if ((timeoutms -= 100) < 0) {
                // DFP
                window.qs.consent.service.dfp.dc = false;
                // Salseforce/Krux
                window.qs.consent.service.krux.dc = false;
                window.qs.consent.service.krux.al = false;
                window.qs.consent.service.krux.tg = false;
                window.qs.consent.service.krux.cd = false;
                window.qs.consent.service.krux.sh = false;
                window.qs.consent.service.krux.re = false;
                // ML
                window.qs.consent.service.ml.dc = false;

                // Set QS consent cookie
                sDFPC('_qscon', JSON.stringify(window.qs.consent.service), 13, 'mo');

                reject("QS: Consent data is not ready - moving on");
            } else
                setTimeout(checkConsent, 100);
        }
        setTimeout(checkConsent, 100);
    });

    (async ()=>{
        waitForConsent(5000)
            .then(function (msg) {
                console.log(msg);
            })
            .catch(function (err) {
                console.log(err);
            })
    })();
</script>


                    <script type="text/javascript">

            /* Replace #your_subdomain# by the subdomain of a Site in your OneAll account */
            var oneall_subdomain = 'linuxtodaycom';

            /* The library is loaded asynchronously */
            var oa = document.createElement('script');
            oa.type = 'text/javascript'; oa.async = true;
            oa.src = '//' + oneall_subdomain + '.api.oneall.com/socialize/library.js';
            var s = document.getElementsByTagName('script')[0];
            s.parentNode.insertBefore(oa, s);
        </script>
    
	<meta name="cache-creation-time" content="2020-06-06 19:07:36.000 +0000" />

    <script>
    window.webtrendsAsyncInit=function(){
        var dcs=new Webtrends.dcs().init({
            dcsid:"dcsq968da00000oiyhzhxx6wa_7q6r",
            domain:"www.qsstats.com",
            timezone:-8,
            i18n:true,
            onsitedoms:"linuxtoday.com",
            fpcdom:".linuxtoday.com",
            plugins:{
                //hm:{src:"//s.webtrends.com/js/webtrends.hm.js"}
            }
            }).track();
    };
    (function(){
        var s=document.createElement("script"); s.async=true; s.src="/imageserver/common/v10/webtrends.min.js";    
        var s2=document.getElementsByTagName("script")[0]; s2.parentNode.insertBefore(s,s2);
    }());
    </script>
    <noscript><img alt="dcsimg" id="dcsimg" width="1" height="1" src="//www.qsstats.com/dcsq968da00000oiyhzhxx6wa_7q6r/njs.gif?dcsuri=/index.php/upload/gnu-linux-libre-5.7-kernel-is-out-for-those-seeking-freedom-for-their-pcs.html&amp;WT.js=No&amp;WT.tv=10.4.1&amp;dcssip=www.linuxtoday.com&amp;WT.qs_dlk=XtvrfF5eo3e0p2tLSZ0WsAAAAAw&"/></noscript>
</head>
    <body class="mt-main-index layout-wtt">
    	<div id="container">
    			    			<div style="text-align: center; margin-top: 2px;">
    				<!-- QS-AD: 'lb' start -->
<script language="JavaScript">
	var t=displayDFPTag("lb");
	document.write(t);

</script>
<!-- QS-AD: 'lb' end -->    			</div>

    			<table border="0" width="100%" cellpadding="0" cellspacing="0" style="padding-top: 3px;">
	<tr>
		<td border="0" class="deferload" data-original="/img/srch_bkgd.png" background="" width="100%">
			<table width="100%" border="0" cellspacing="0" cellpadding="0">
	  			<tr>
	    			<td width="429" nowrap>
	    				<a href="/"><img class="deferload" data-original="/img/linuxtd_logo.png" src="" width="378" height="63"  alt="Linux Today: Linux News On Internet Time." border="0"/><span class="sprite sprite-top_shad" style="display:inline-block;"></span></a>
	    			</td>
	    			<td align="left" border="0"> 
						<!--start_search-->
		      			<table width="100%" border="0" cellspacing="0" cellpadding="5">
							<tr valign="top">
								<form action="/search.html" id="cse-search-box">
									<td valign="top">
										<span class="sprite sprite-search_txt" style="display:inline-block;"></span>
										<input type="text" name="q" size="18">
										<input type="hidden" name="cx" value="partner-pub-8768004398756183:6999378834">
	                                    <input type="hidden" name="cof" value="FORID:10">
	                                    <input type="hidden" name="ie" value="UTF-8">
	                                    <input type="submit" value="" alt="Go" class="button">
                                                                        </td>
                                                                        <td valign="top"><div id="showAdvertiserDisclosure"><a href="#footerDisclaimerText">Advertiser Disclosure</a></div></td>                                    
								</form>
								<script type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en">
</script>
								
								
								
								</tr>
		      			</table>
						<!--end_search-->
	    			</td>
	    			<td id="loginfo" align="right"></td>					
	  			</tr>
			</table>
		</td>
	</tr>
</table>
<table width="100%" cellspacing="0" cellpadding="0" border="0">
	<tbody>
		<tr>
			<td class="deferload" data-original="/img/tab_bkgd.png" background="">
				<a href="/"><span class="sprite sprite-linuxnews_tab" style="display:inline-block;"></span></a>				
				<a href="/developer/"><span class="sprite sprite-developer_tab" style="display:inline-block;"></span></a>
				<a href="/high_performance/"><span class="sprite sprite-highperform_tab" style="display:inline-block;"></span></a>
				<a href="/infrastructure/"><span class="sprite sprite-infrastructure_tab" style="display:inline-block;"></span></a>
				<a href="/it_management/"><span class="sprite sprite-itmanagment_tab" style="display:inline-block;"></span></a>
				<a href="/security/"><span class="sprite sprite-security_tab" style="display:inline-block;"></span></a>
				<a href="/storage/"><span class="sprite sprite-storage_tab" style="display:inline-block;"></span></a>				
			</td>
		</tr>
	</tbody>
</table>
				<table border="0">
					<tbody>
						<tr><td width="161" valign="top" class="deferload" data-original="/img/nav_bkgd.png" background="" align="center">
	<table width="161" border="0" align="left" valign="top" cellspacing="0" cellpadding="0">
		<tbody>
			<tr>
				<td>
		        	<span class="sprite sprite-linuxtodaytop_nav" style="display:inline-block;"></span><br>
					<a href="/"><span class="sprite sprite-home_nav" style="display:inline-block;"></span></a><br>					
					<a href="/contribute.html"><span class="sprite sprite-contribute_nav" style="display:inline-block;"></span></a><br>
					<a href="/linkus.html"><span class="sprite sprite-linkto_nav" style="display:inline-block;"></span></a>
					<!--<br>					
					<a href="http://www.justtechjobs.com/" target="_blank"><img width="161" height="24" border="0" alt="Linux Jobs" src="/img/jobs_nav2.gif"></a>-->
	        		<p></p>
	        		<div style="width:99%">												
						<br />	
						<div align="CENTER">							
							<!-- QS-AD: 'sky' start -->
<script language="JavaScript">
	var t=displayDFPTag("sky");
	document.write(t);

</script>
<!-- QS-AD: 'sky' end -->						</div>					
					</div>
				</td>
			</tr>
		</tbody>
	</table>
</td>							<td width="97%" class="contenttd" valign="TOP"><div class="rightnav">
			<!-- QS-AD: 'imu' start -->
<script language="JavaScript">
	var t=displayDFPTag("imu");
	document.write(t);

</script>
<!-- QS-AD: 'imu' end --><p></p>	
			<div class="articlecategorysummary">
    <iframe id='whitePaperIFrame' scrolling="no" frameborder="0" align="middle" src="https://www.linuxtoday.com/sl/assetlisting/?wsn=www.linuxtoday.com&amp;wpu=/&amp;lurl=https://o1.qnsr.com/cgi/r?WT.qs_dlk=XtvrfF5eo3e0p2tLSZ0WsAAAAAw;;n=203;c=1395316;s=9543;x=7936;f=201308291504360;u=j;z=TIMESTAMP;k=https://assetform.linuxtoday.com/controller&amp;wpos=AssetListing&amp;lyt=l9&css=https://www.linuxtoday.com/hqb2b/css/qmp/qmp_default.css&wi=4230610&title=Top%20White%20Papers%20and%20Webcasts" height="780"></iframe>
</div>
<script type="text/javascript"> 
var updateIframe = false;
var t = 0;

function updateQMPIframe(){
    if(!updateIframe) { 
        if($('#whitePaperIFrame').contents().find('.asset').length > 0) {
            var height = $('#whitePaperIFrame').contents().find('#assetsListings').height();
            height = height + 50;
            var iframe = document.getElementById('whitePaperIFrame');  
            iframe.setAttribute( 'height', height);
            updateIframe = true;
            clearTimeout(t);
        }else {
            t = setTimeout('updateQMPIframe()', 1000);
        }
    }
}

t = setTimeout('updateQMPIframe()', 5000);


</script>
 <p></p>			
			<!-- QS-AD: 'imu' start -->
<script language="JavaScript">
	var t=displayDFPTag("imu");
	document.write(t);

</script>
<!-- QS-AD: 'imu' end --><p></p>
			<form style="margin: 0pt; padding: 0pt;" method="post" id="newsletter_form">	
	<div class="newsletter_holder rightnav_box"><h3>Subscribe to Our Daily Newsletter</h3>		
		<div id="newsdiv" style="padding: 10px;">
                    <input type="text" maxlength="255" name="nlemail" id="email" class="nlemail"  placeholder="Enter your email address">	
		<input id="navNewsletterSignup" type="hidden" value="1110" name="nlNewsletterKey">
		<input id="businessUnit" type="hidden" value="Internet.com" name="nlBusinessUnit">
                <input type="hidden" name="nlQuadTrackUrl" value="https://o1.qnsr.com/cgi/r?;n=203;c=1387912;s=15939;x=7936;f=201306031137030;u=j;z=TIMESTAMP;">
                <input type="button" value="Submit" class="myButton" onclick="newsletterGlobalSubmit('newsletter_form', 'nl_response_message', 'nl_response_message'); return false;">
		<span id="nl_response_message"></span>		
		</div>
	</div>
</form>
<p></p><p></p>
			 <!--start current newswire-->
							<div class="rightnav_box">
												<h3>Current Newswire:</h3>
												<ul>
																								<li><a href="https://www.linuxtoday.com/developer/the-top-linux-5.7-features-from-apple-fast-charge-to-official-tiger-lake-graphics.html">The Top Linux 5.7 Features From Apple Fast Charge To Official Tiger Lake Graphics</a></li>												
												
																								<li><a href="https://www.linuxtoday.com/infrastructure/why-popos-20.04-could-change-how-you-think-about-linux.html">Why Pop!_OS 20.04 could change how you think about Linux</a></li>												
												
																								<li><a href="https://www.linuxtoday.com/security/linux-firewall-basics-with-ufw.html">Linux firewall basics with ufw</a></li>												
												
																								<li><a href="https://www.linuxtoday.com/developer/5-ways-to-do-serverless-on-kubernetes.html">5 ways to do serverless on Kubernetes</a></li>												
												
																								<li><a href="https://www.linuxtoday.com/it_management/setting-the-record-straight-on-aws-and-open-source.html">Setting the record straight on AWS and open source</a></li>												
												
																								<li><a href="https://www.linuxtoday.com/developer/django-3-taps-python-async-to-speed-web-apps.html">Django 3 taps Python async to speed web apps</a></li>												
												
																								<li><a href="https://www.linuxtoday.com/developer/tuning-your-bash-or-zsh-shell-on-fedora-workstation-and-silverblue.html">Tuning your bash or zsh shell on Fedora Workstation and Silverblue</a></li>												
												
																								<li><a href="https://www.linuxtoday.com/infrastructure/red-hat-announces-rhel-8.1-with-predictable-release-cadence.html">Red Hat announces RHEL 8.1 with predictable release cadence</a></li>												
												
																								<li><a href="https://www.linuxtoday.com/infrastructure/opensuse-project-vote-on-name-change.html">openSUSE project: vote on name change</a></li>												
												
																								<li><a href="https://www.linuxtoday.com/it_management/fedora-at-15-why-matthew-miller-sees-a-bright-future-for-the-linux-distribution.html">Fedora at 15: Why Matthew Miller sees a bright future for the Linux distribution</a></li>												
												
												</ul>
												</div>		
			
			 <!--end current newswire-->
<p></p>
	<div class="rightnav_box">
		<h3>More on LinuxToday</h3>				
		<ul>
			<li><a href="https://www.linuxtoday.com/sitemap.html">Sitemap</a></li>			
			<li><a href="https://www.linuxtoday.com/feedback.html">Feedback</a></li>
		</ul>
	</div>
</div>
<table cellspacing="0" cellpadding="0" border="0">
	<tbody>
		<tr>
			<td>
				<!-- QS-AD: 'ciu' start -->
<script language="JavaScript">
	var t=displayDFPTag("ciu");
	document.write(t);

</script>
<!-- QS-AD: 'ciu' end -->			</td>
		</tr>
	</tbody>
</table>
<br>
<div class="ciu_div"></div>
<div class="ciu">
	</div>

<!--[if IE 7]>
<br>
<![endif]-->
<div class="article" style="width:698px;">
		<h1>GNU Linux-Libre 5.7 Kernel Is Out for Those Seeking 100% Freedom for Their PCs</h1>
		<span class="article_sub"> Jun 04, 2020, 15:00                    (<a href="#comments"><span>0 Talkback[s]</span></a>)  
		</span>		
		 
			<br>
			<span class="article_sub">
						(Other stories by <a href="https://www.linuxtoday.com/author/Marius+Nestor/">Marius Nestor</a>)</span> 
				
		<div id="social_media">
    
<div data-force-refresh="true" class="oas_box oas_box_btns_lfr">
 <span class="oas_btn oas_btn_facebook" title="Share On Facebook"></span>
 <span class="oas_btn oas_btn_twitter" title="Share On Twitter"></span>
 <span class="oas_btn oas_btn_linkedin" title="Share On LinkedIn"></span>
 <span class="oas_btn oas_btn_email" title="Share On Email"></span>
</div>

</div>
<div style="clear:left;padding-top: 5px;"></div>		
		<p>Based on the recently released Linux 5.7 kernel series, the GNU Linux-Libre 5.7 kernel is here to disable blob loading in the Azoteq IQS62x MFD driver, IDT 82P33xxx PTP clock driver, Marvell OcteonTX CPT driver, Mediatek MT7622 WMAC driver, MHI bus driver, and Qualcomm IPA driver. It also introduces new blob names in the AMDGPU, Arm64 DTS files, Broadcom FMAC, m88ds3103 DVB frontend, Mediatek mt8173 VPU, Mediatek 7622 and 7663 WiFi, Meson VDec, Qualcomm Venus, Realtek Bluetooth, and Silead x86 touchscreen drivers.</p>					<p><a style="font-size:12px;" href="https://9to5linux.com/gnu-linux-libre-5-7-kernel-is-out-for-those-seeking-100-freedom-for-their-pcs">Complete Story</a></p>
		 
		
		                                <div id="bottom-container"></div>
                               
                                             
<p><a href="https://www.linuxtoday.com/email/upload/gnu-linux-libre-5.7-kernel-is-out-for-those-seeking-freedom-for-their-pcs.html" rel="nofollow"><img src="https://www.linuxtoday.com/img/emailicon.gif" border="0" width="188" height="29" alt=""/></a><br>
	<a href="https://www.linuxtoday.com/print/upload/gnu-linux-libre-5.7-kernel-is-out-for-those-seeking-freedom-for-their-pcs.html" rel="nofollow"><img src="https://www.linuxtoday.com/img/printicon.gif" border="0" width="205" height="29" alt=""/></a></p>
<input type="hidden" id="blurb_key" value="296946010" name="key">
<div align="center" id="commentsImg" style="display:none;"><img class="deferload" data-original="/img/comments-loader.gif" src="" height="32" weight="32"></div>
 <div id="article-comments"></div>
  </div>
</td>						</tr>
					</tbody>
				</table>
				<div style="background:#F2AA00;height:5px;"></div>
<div style="margin-top: 2px;">	
	<div style="text-align:center;margin-top: 5px;">
		<!-- QS-AD: 'lb' start -->
<script language="JavaScript">
	var t=displayDFPTag("lb");
	document.write(t);

</script>
<!-- QS-AD: 'lb' end -->	</div>
	<div style="text-align:center;margin-top: 5px; margin-bottom: 5px;">
                        <script type="text/javascript">var blurbKey = 236852210;
</script>
                    <script type="text/javascript" src="/hqb2b/js/oneAllComments.js" defer>
</script>
	<style type="text/css">
    #brand-footer{text-align:center;margin:0 auto;}
    #commonfooterpropertytext{padding-bottom: 12px;}
    #commonfootercopyright{padding: 3px;}
    #eweekBrand-footer{text-align:center;margin:0 auto}
    #footerDisclaimerText{margin: 15px 10px 0px 10px; text-align: justify;}
</style>
<div id="brand-footer">
    <div id="acceptableusepolicy" style="display:none;">
        <a rel='nofollow' href='/aup.html' target='_blank' style='color: #000000;'>Acceptable Use Policy</a>
    </div>
    <div>
        <img id="commonfooterlogo" src="" alt="Site Logo" border="0" class="lazy" />
    </div>
    <div id="commonfooterpropertytext"></div>
    <div id="footerlinks">
        <a rel="nofollow" id="commonfootetearmslink" href="https://technologyadvice.com/terms-conditions/">Terms of Service</a> | 
        <a rel="nofollow" id="commonfooteraboutuslink" href="https://technologyadvice.com/about-us/" target="_blank">About Us</a> | 
        <a rel="nofollow" id="commonprivacylink" href="/privacy">Privacy Notice</a> | 
        <a rel="nofollow" id="commonfootercontactuslink" href="https://technologyadvice.com/contact-us/">Contact Us</a> | 
        <a rel="nofollow" id="commonadvertiselink" href="https://technologyadvice.com/partners/" target="_blank">Advertise</a> |
        <a rel="nofollow" id="commonsitemaplink" href="/sitemap.html" target="_blank">Sitemap</a> |
        <a rel="nofollow" id="commonfootercalifornialink" href="https://technologyadvice.com/privacy-policy/ccpa-opt-out-form" target="_blank">California - Do Not Sell My Info</a> 
    </div>
    <div id="commonfootercopyright"></div>
    <div id="footerDisclaimerText">
        <p>
            <strong>Advertiser Disclosure:</strong>&nbsp;<span id="advDisclaimer"></span>
        </p>
    </div>
</div>
<script async language="Javascript" src="/icom_includes/footers/scripts/footerbrandingcode.js">
</script></div>
</div>    	</div>
                <script type="text/javascript" src="/hqx/min/?b=js&f=validate.js,charactercount.js,article.js,jquery.cookie.min.js,lazyload-min.js,common.js&v=4" defer async">
</script>
		<script type="text/javascript">
		// Add a script element as a child of the body
		function downloadJSAtOnload() {
		var element = document.createElement("script");
		element.src = "/hqx/sl/?g=js";
		document.body.appendChild(element);
		}

		// Check for browser support of event handling capability
		if (window.addEventListener)
		window.addEventListener("load", downloadJSAtOnload, false);
		else if (window.attachEvent)
		window.attachEvent("onload", downloadJSAtOnload);
		else window.onload = downloadJSAtOnload;
		
</script>		
   </body>
</html>
