<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>Awesome Linux Game Tools: Heroic Games Launcher</title><style id="rocket-critical-css">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</style><link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Fira%20Sans%3A400%7CRaleway%3A400%7COpen%20Sans%3A400%2C600%2C700%7CRoboto%3A400%2C500%2C700&#038;display=swap" /><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Fira%20Sans%3A400%7CRaleway%3A400%7COpen%20Sans%3A400%2C600%2C700%7CRoboto%3A400%2C500%2C700&#038;display=swap" media="print" onload="this.media='all'" /><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Fira%20Sans%3A400%7CRaleway%3A400%7COpen%20Sans%3A400%2C600%2C700%7CRoboto%3A400%2C500%2C700&#038;display=swap" /></noscript><link rel="preload" href="https://www.linuxtoday.com/wp-content/cache/min/1/054cd28ea276727f224bab9f42f87051.css" data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" onerror="this.removeAttribute('data-rocket-async')"  media="all" data-minify="1" />
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://www.linuxtoday.com/xmlrpc.php" />
    <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<link rel="icon" type="image/png" href="https://www.linuxtoday.com/wp-content/uploads/2021/06/Linux_logos_Favicon.png">
	<!-- This site is optimized with the Yoast SEO plugin v18.8 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="Heroic Games Launcher (&quot;Heroic&quot;) is a free and open source games launcher for Epic Games and GOG. Learn more about it here." />
	<link rel="canonical" href="https://www.linuxtoday.com/developer/awesome-linux-game-tools-heroic-games-launcher/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Awesome Linux Game Tools: Heroic Games Launcher" />
	<meta property="og:description" content="Heroic Games Launcher (&quot;Heroic&quot;) is a free and open source games launcher for Epic Games and GOG. Learn more about it here." />
	<meta property="og:url" content="https://www.linuxtoday.com/developer/awesome-linux-game-tools-heroic-games-launcher/" />
	<meta property="og:site_name" content="Linux Today" />
	<meta property="article:publisher" content="https://www.facebook.com/LinuxToday-635265507098561/" />
	<meta property="article:modified_time" content="2022-11-17T23:11:04+00:00" />
	<meta property="og:image" content="https://www.linuxtoday.com/wp-content/uploads/2021/07/Linux_opengraph_square2-01.png" />
	<meta property="og:image:width" content="1201" />
	<meta property="og:image:height" content="1200" />
	<meta property="og:image:type" content="image/png" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:site" content="@linuxtoday" />
	<meta name="twitter:label1" content="Est. reading time" />
	<meta name="twitter:data1" content="1 minute" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.linuxtoday.com/#organization","name":"LinuxToday","url":"https://www.linuxtoday.com/","sameAs":["https://www.facebook.com/LinuxToday-635265507098561/","https://www.linkedin.com/company/linuxtoday/","https://twitter.com/linuxtoday"],"logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.linuxtoday.com/#/schema/logo/image/","url":"https://www.linuxtoday.com/wp-content/uploads/2021/07/Linux_opengraph_square2-01.png","contentUrl":"https://www.linuxtoday.com/wp-content/uploads/2021/07/Linux_opengraph_square2-01.png","width":1201,"height":1200,"caption":"LinuxToday"},"image":{"@id":"https://www.linuxtoday.com/#/schema/logo/image/"}},{"@type":"WebSite","@id":"https://www.linuxtoday.com/#website","url":"https://www.linuxtoday.com/","name":"Linux Today","description":"","publisher":{"@id":"https://www.linuxtoday.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.linuxtoday.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"WebPage","@id":"https://www.linuxtoday.com/developer/awesome-linux-game-tools-heroic-games-launcher/#webpage","url":"https://www.linuxtoday.com/developer/awesome-linux-game-tools-heroic-games-launcher/","name":"Awesome Linux Game Tools: Heroic Games Launcher","isPartOf":{"@id":"https://www.linuxtoday.com/#website"},"datePublished":"2022-11-18T21:00:05+00:00","dateModified":"2022-11-17T23:11:04+00:00","description":"Heroic Games Launcher (\"Heroic\") is a free and open source games launcher for Epic Games and GOG. Learn more about it here.","breadcrumb":{"@id":"https://www.linuxtoday.com/developer/awesome-linux-game-tools-heroic-games-launcher/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.linuxtoday.com/developer/awesome-linux-game-tools-heroic-games-launcher/"]}]},{"@type":"BreadcrumbList","@id":"https://www.linuxtoday.com/developer/awesome-linux-game-tools-heroic-games-launcher/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.linuxtoday.com/"},{"@type":"ListItem","position":2,"name":"User Posts","item":"https://www.linuxtoday.com/%category%/"},{"@type":"ListItem","position":3,"name":"Awesome Linux Game Tools: Heroic Games Launcher"}]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//adservice.google.com' />
<link rel='dns-prefetch' href='//cs.emxdgt.com' />
<link rel='dns-prefetch' href='//dpm.demdex.net' />
<link rel='dns-prefetch' href='//e.servebid.com' />
<link rel='dns-prefetch' href='//eb2.3lift.com' />
<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//www.google-analytics.com' />
<link rel='dns-prefetch' href='//tpc.googlesyndication.com' />
<link rel='dns-prefetch' href='//googletagservices.com' />
<link rel='dns-prefetch' href='//p.typekit.net' />
<link rel='dns-prefetch' href='//x.bidswitch.net' />
<link rel='dns-prefetch' href='//match.adsrvr.org' />
<link rel='dns-prefetch' href='//e.serverbid.com' />
<link rel='dns-prefetch' href='//jadserve.postrelease.com' />
<link rel='dns-prefetch' href='//match.sharethrough.com' />
<link rel='dns-prefetch' href='//securepubads.g.doubleclick.net' />
<link rel='dns-prefetch' href='//sync.1rx.io' />
<link rel='dns-prefetch' href='//usermatch.targeting.unrulymedia.com' />
<link rel='dns-prefetch' href='//prebid-match.dotomi.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Linux Today &raquo; Feed" href="https://www.linuxtoday.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Linux Today &raquo; Comments Feed" href="https://www.linuxtoday.com/comments/feed/" />
<!-- linuxtoday.com is managing ads with Advanced Ads 1.33.2 --><!--noptimize--><script id="wp-ads-ready">
			window.advanced_ads_ready=function(e,a){a=a||"complete";var d=function(e){return"interactive"===a?"loading"!==e:"complete"===e};d(document.readyState)?e():document.addEventListener("readystatechange",(function(a){d(a.target.readyState)&&e()}),{once:"interactive"===a})},window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[];		</script>
		<!--/noptimize--><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	
<style id='global-styles-inline-css' type='text/css'>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</style>






<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>


<style id='rocket-lazyload-inline-css' type='text/css'>
.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%;}.rll-youtube-player:focus-within{outline: 2px solid currentColor;outline-offset: 5px;}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:100%;width:100%;left:0;top:0;position:absolute;background:url(https://www.linuxtoday.com/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat center;background-color: transparent !important;cursor:pointer;border:none;}
</style>
<script type='text/javascript' src='https://www.linuxtoday.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.linuxtoday.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script data-minify="1" type='text/javascript' src='https://www.linuxtoday.com/wp-content/cache/min/1/wp-content/uploads/226/891/public/assets/js/348.js?ver=1656610517' id='unslider-js-js'></script>
<script data-minify="1" type='text/javascript' src='https://www.linuxtoday.com/wp-content/cache/min/1/wp-content/uploads/226/891/public/assets/js/892.js?ver=1656610517' id='unslider-move-js-js'></script>
<script data-minify="1" type='text/javascript' src='https://www.linuxtoday.com/wp-content/cache/min/1/wp-content/uploads/226/891/public/assets/js/425.js?ver=1656610517' id='unslider-swipe-js-js'></script>
<script type='text/javascript' id='advanced-ads-advanced-js-js-extra'>
/* <![CDATA[ */
var advads_options = {"blog_id":"1","privacy":{"enabled":false,"state":"not_needed"}};
/* ]]> */
</script>
<script data-minify="1" type='text/javascript' src='https://www.linuxtoday.com/wp-content/cache/min/1/wp-content/uploads/226/257/public/assets/js/406.js?ver=1656610517' id='advanced-ads-advanced-js-js'></script>
<script type='text/javascript' id='advanced_ads_pro/visitor_conditions-js-extra'>
/* <![CDATA[ */
var advanced_ads_pro_visitor_conditions = {"referrer_cookie_name":"advanced_ads_pro_visitor_referrer","referrer_exdays":"365","page_impr_cookie_name":"advanced_ads_page_impressions","page_impr_exdays":"3650"};
/* ]]> */
</script>
<script data-minify="1" type='text/javascript' src='https://www.linuxtoday.com/wp-content/cache/min/1/wp-content/uploads/226/735/732/295/491/614.js?ver=1656610517' id='advanced_ads_pro/visitor_conditions-js'></script>
<link rel="https://api.w.org/" href="https://www.linuxtoday.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.linuxtoday.com/wp-json/wp/v2/user_post/180160" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.linuxtoday.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.linuxtoday.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.linuxtoday.com/?p=180160' />
<link rel="alternate" type="application/json+oembed" href="https://www.linuxtoday.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.linuxtoday.com%2Fdeveloper%2Fawesome-linux-game-tools-heroic-games-launcher%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.linuxtoday.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.linuxtoday.com%2Fdeveloper%2Fawesome-linux-game-tools-heroic-games-launcher%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.74.0" /><script>advads_items = { conditions: {}, display_callbacks: {}, display_effect_callbacks: {}, hide_callbacks: {}, backgrounds: {}, effect_durations: {}, close_functions: {}, showed: [] };</script><style type="text/css" id="wp-ads-layer-custom-css"></style>
<link rel="preload" as="font" href="https://www.linuxtoday.com/wp-content/plugins/td-composer/assets/fonts/font-awesome/fontawesome-webfont.woff2" crossorigin>
<link rel="preload" as="font" href="https://www.linuxtoday.com/wp-content/themes/Newspaper/images/icons/newspaper.woff" crossorigin><script type="text/javascript">
		var advadsCfpQueue = [];
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};
		</script>
		<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
        <script>
        window.tdb_globals = {"wpRestNonce":"0a587479e9","wpRestUrl":"https:\/\/www.linuxtoday.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/","globalSettings":{"tdcSavingHistory":false},"isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50};
    </script>
    
    <style id="tdb-global-colors">
        :root {--accent-color: #fff;}
    </style>
	
			<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/www.linuxtoday.com\/wp-admin\/","wpRestNonce":"0a587479e9","wpRestUrl":"https:\/\/www.linuxtoday.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/"};
			</script>
			    <script>
        window.tdaGlobal = {"adminUrl":"https:\/\/www.linuxtoday.com\/wp-admin\/","wpRestNonce":"0a587479e9","wpRestUrl":"https:\/\/www.linuxtoday.com\/wp-json\/","permalinkStructure":"\/%category%\/%postname%\/","postId":138};
    </script>
    
<!-- Google Tag Manager snippet added by Site Kit -->
<script type="text/javascript">
			( function( w, d, s, l, i ) {
				w[l] = w[l] || [];
				w[l].push( {'gtm.start': new Date().getTime(), event: 'gtm.js'} );
				var f = d.getElementsByTagName( s )[0],
					j = d.createElement( s ), dl = l != 'dataLayer' ? '&l=' + l : '';
				j.async = true;
				j.src = 'https://www.googletagmanager.com/gtm.js?id=' + i + dl;
				f.parentNode.insertBefore( j, f );
			} )( window, document, 'script', 'dataLayer', 'GTM-T4P43PZ' );
			
</script>

<!-- End Google Tag Manager snippet added by Site Kit -->

<!-- JS generated by theme -->

<script>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</script>


<!-- Header style compiled by theme -->

<style>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</style>

<!-- Start: GAM Head Tag -->

<!-- Start: Data Layer -->
<script>
    // Setup our base data layer

    window.dataLayer = window.dataLayer || [];
    dataLayer.push(
        {"event":"CMS_Data","taxonomy":["audience purchase stage awareness","product development open source software development","industry technology"],"category":["developer"],"keywords":["epic-games","gog","heroic-games-launcher","linux-gaming"]}    );
</script>
<!-- End: Data Layer-->
<!-- End: GAM Head Tag -->

<!-- Start: Advertising Core -->
<script data-minify="1" src="https://www.linuxtoday.com/wp-content/cache/min/1/tag/js/gpt.js?ver=1656610517" async></script>

<script>window.googletag=window.googletag||{cmd:[]},window.ta=window.ta||{gam:{ready:!1,tags:{}}};var mbw=window.innerWidth||document.documentElement.clientWidth||document.body.clientWidth;getDataLayerValue=function(e,t,a){for(var o=0,n=window.dataLayer.length;o<n;o++){var g;if(void 0!==dataLayer[o][e]&&(g=t?cleanKeyValue_GAM(dataLayer[o][e]):dataLayer[o][e],a))return g}return g},getURLSegments=function(e){return e.split("/").filter(function(e){return null!=e&&""!=e&&null!=e})},getCMSEnvironment=function(){var e=new RegExp(/(local|dev)\.wordpress\.relay\.cool/).test(window.location.hostname),t=new RegExp(/.*(local|dev).*\.wpengine\.com/).test(window.location.hostname),a=new RegExp(/stage\.wordpress\.relay\.cool/).test(window.location.hostname),o=new RegExp(/.*(stage|stg|esplanetst).*\.wpengine\.com/).test(window.location.hostname);return e||t?"dev":a||o?"stage":"prod"},getGAMCookie=function(e){for(var t=e+"=",a=document.cookie.split(";"),o=0;o<a.length;o++){var n=a[o].replace(/^\s+|\s+$/g,"");if(0==n.indexOf(t))return n.substring(t.length,n.length)}return""},setGAMCookie=function(e,t,a,o){if(!(e&&t&&a&&o))return!1;var n=new Date;switch(o){case"mo":n.setMonth(n.getMonth()+a);break;case"hr":n.setTime(n.getTime()+60*a*60*1e3);break;case"min":n.setTime(n.getTime()+60*a*1e3);break;case"sec":n.setTime(n.getTime()+1e3*a);break;default:n.setTime(n.getTime()+24*a*60*60*1e3)}var g="expires="+n.toUTCString();document.cookie=e+"="+t+";"+g+";path=/"},checkGAMCookie=function(e){return e&&""!=getGAMCookie(e)?1:0},cleanKeyValue_GAM=function(e){if(e)if(Array.isArray(e))for(i=0;i<e.length;i++)e[i]=e[i].replace(/["'=!+#*~;^()<>\[\],&]/g,"").replace(/\s+/g," ").replace(/^\s+|\s+$/g,"");else"object"==typeof e&&null!==e?Object.keys(e).forEach(function(t){e[t]=e[t].replace(/["'=!+#*~;^()<>\[\],&]/g,"").replace(/\s+/g," ").replace(/^\s+|\s+$/g,"")}):e=e.replace(/["'=!+#*~;^()<>\[\],&]/g,"").replace(/\s+/g," ").replace(/^\s+|\s+$/g,"");return e},dumpGAMTargeting=function(){if(window.googletag&&googletag.pubadsReady){var e=window.googletag.pubads().getTargetingKeys();for(k=0;k<e.length;k++)console.log(e[k],googletag.pubads().getTargeting(e[k]))}},refreshDFPTags=function(){if(window.googletag&&googletag.pubadsReady)for(var e in window.ta.gam.tags)window.ta.gam.tags.hasOwnProperty(e)&&null!=window.ta.gam.tags[e]&&void 0!==window.ta.gam.tags[e].slot&&window.ta.gam.tags[e].refreshable&&(window.ta.gam.tags[e].refreshed=!0,window.ta.gam.tags[e].refresh_counter++,googletag.pubads().refresh([window.ta.gam.tags[e].slot],{changeCorrelator:!1}))},hide__div=function(e){if(e){if(window.googletag&&googletag.pubadsReady){var t=e.replace(/-outer/,"").replace(/-/g,"");void 0!==window.ta.gam.tags[t].slot&&(googletag.destroySlots([window.ta.gam.tags[t].slot]),window.ta.gam.tags[t]=null)}document.getElementById&&(document.getElementById(e).style.visibility="hidden",document.getElementById(e).innerHTML="")}};</script>
<script>googletag.cmd.push(function(){var _env=getCMSEnvironment(),_clean_path=cleanKeyValue_GAM(getURLSegments(window.location.pathname)),_clean_kw=cleanKeyValue_GAM(["epic-games","gog","heroic-games-launcher","linux-gaming"]),_clean_tax=cleanKeyValue_GAM(["audience purchase stage awareness","product development open source software development","industry technology"]),_clean_category=cleanKeyValue_GAM(["developer"]),_clean_mlt=cleanKeyValue_GAM(getGAMCookie("mlt")),_clean_mlcr=cleanKeyValue_GAM(getGAMCookie("mlcr")),_clean_mlcs=cleanKeyValue_GAM(getGAMCookie("mlcs")),_clean_mldm=cleanKeyValue_GAM(getGAMCookie("mldm")),_clean_mlsr=cleanKeyValue_GAM(getGAMCookie("mlsr")),_clean_mlpc=cleanKeyValue_GAM(getGAMCookie("mlpc")),_clean_mldcm=cleanKeyValue_GAM(getGAMCookie("mldcm")),_clean_mlfa=cleanKeyValue_GAM(getGAMCookie("mlfa")),_clean_mlins=cleanKeyValue_GAM(getGAMCookie("mlins")),_clean_mlpg=cleanKeyValue_GAM(getGAMCookie("mlpg")),_clean_mledu=cleanKeyValue_GAM(getGAMCookie("mledu")),_clean_mlind=cleanKeyValue_GAM(getGAMCookie("mlind"));_clean_mlt&&googletag.pubads().setTargeting("mlt",_clean_mlt),_clean_mlcr&&googletag.pubads().setTargeting("mlcr",_clean_mlcr),_clean_mlcs&&googletag.pubads().setTargeting("mlcs",_clean_mlcs),_clean_mldm&&googletag.pubads().setTargeting("mldm",_clean_mldm),_clean_mlsr&&googletag.pubads().setTargeting("mlsr",_clean_mlsr),_clean_mlpc&&googletag.pubads().setTargeting("mlpc",_clean_mlpc),_clean_mldm&&googletag.pubads().setTargeting("mldcm",_clean_mldcm),_clean_mlfa&&googletag.pubads().setTargeting("mlfa",_clean_mlfa),_clean_mlins&&googletag.pubads().setTargeting("mlins",_clean_mlins),_clean_mlpg&&googletag.pubads().setTargeting("mlpg",_clean_mlpg),_clean_mledu&&googletag.pubads().setTargeting("mledu",_clean_mledu),_clean_mlind&&googletag.pubads().setTargeting("mlind",_clean_mlind),googletag.pubads().setTargeting("env",_env),googletag.pubads().setTargeting("url",window.location.hostname.concat(window.location.pathname)),googletag.pubads().setTargeting("hostname",window.location.hostname),googletag.pubads().setTargeting("kw",_clean_kw),googletag.pubads().setTargeting("tax",_clean_tax),googletag.pubads().setTargeting("category",_clean_category),googletag.pubads().setTargeting("path",_clean_path),googletag.pubads().enableSingleRequest(),googletag.enableServices();});</script>
<!-- End: Advertising Core -->

<script>var ntv_kvpMap={},_ntv_env=getCMSEnvironment(),_ntv_clean_path=[cleanKeyValue_GAM(getURLSegments(window.location.pathname))].join(),_ntv_clean_kw=[cleanKeyValue_GAM(["epic-games","gog","heroic-games-launcher","linux-gaming"])].join(),_ntv_clean_tax=[cleanKeyValue_GAM(["audience purchase stage awareness","product development open source software development","industry technology"])].join(),_ntv_clean_category=[cleanKeyValue_GAM(["developer"])].join(),_ntv_clean_mlt=cleanKeyValue_GAM(getGAMCookie("mlt")),_ntv_clean_mlcr=cleanKeyValue_GAM(getGAMCookie("mlcr")),_ntv_clean_mlcs=cleanKeyValue_GAM(getGAMCookie("mlcs")),_ntv_clean_mldm=cleanKeyValue_GAM(getGAMCookie("mldm")),_ntv_clean_mlsr=cleanKeyValue_GAM(getGAMCookie("mlsr")),_ntv_clean_mlpc=cleanKeyValue_GAM(getGAMCookie("mlpc")),_ntv_clean_mldcm=cleanKeyValue_GAM(getGAMCookie("mldcm")),_ntv_clean_mlfa=cleanKeyValue_GAM(getGAMCookie("mlfa")),_ntv_clean_mlins=cleanKeyValue_GAM(getGAMCookie("mlins")),_ntv_clean_mlpg=cleanKeyValue_GAM(getGAMCookie("mlpg")),_ntv_clean_mledu=cleanKeyValue_GAM(getGAMCookie("mledu")),_ntv_clean_mlind=cleanKeyValue_GAM(getGAMCookie("mlind"));_ntv_clean_mlt&&(ntv_kvpMap.mlt=_ntv_clean_mlt),_ntv_clean_mlcr&&(ntv_kvpMap.mlcr=_ntv_clean_mlcr),_ntv_clean_mlcs&&(ntv_kvpMap.mlcs=_ntv_clean_mlcs),_ntv_clean_mldm&&(ntv_kvpMap.mldm=_ntv_clean_mldm),_ntv_clean_mlsr&&(ntv_kvpMap.mlsr=_ntv_clean_mlsr),_ntv_clean_mlpc&&(ntv_kvpMap.mlpc=_ntv_clean_mlpc),_ntv_clean_mldcm&&(ntv_kvpMap.mldcm=_ntv_clean_mldcm),_ntv_clean_mlfa&&(ntv_kvpMap.mlfa=_ntv_clean_mlfa),_ntv_clean_mlins&&(ntv_kvpMap.mlins=_ntv_clean_mlins),_ntv_clean_mlpg&&(ntv_kvpMap.mlpg=_ntv_clean_mlpg),_ntv_clean_mledu&&(ntv_kvpMap.mledu=_ntv_clean_mledu),_ntv_clean_mlind&&(ntv_kvpMap.mlind=_ntv_clean_mlind),ntv_kvpMap.env=_ntv_env,ntv_kvpMap.url=window.location.hostname.concat(window.location.pathname),ntv_kvpMap.hostname=window.location.hostname,ntv_kvpMap.keyword=_ntv_clean_kw,ntv_kvpMap.tax=_ntv_clean_tax,ntv_kvpMap.category=_ntv_clean_category,ntv_kvpMap.path=_ntv_clean_path,console.log(ntv_kvpMap),window.ntvConfig=window.ntvConfig||{},window.ntvConfig.keyValues=ntv_kvpMap;</script>

<!-- Start: Nativo Javascript Injection -->
<script data-minify="1" type="text/javascript" src="https://www.linuxtoday.com/wp-content/cache/min/1/serve/load.js?ver=1656610518" async></script>
<!-- End: Nativo Javascript Injection --><!-- Start: GAM Ad Slot Definitions | LinuxToday developer Page -->

<script>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</script>
<!-- End: GAM Ad Slot Definitions | Datamation developer Page --><meta name='webgains-site-verification' content='ofy1yvom' />
<meta name="google-site-verification" content="keb2K_3oXZ51u2Tq_gIe2dKhGoywvWVWejOIk6Q-yH4" />


<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://www.linuxtoday.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.linuxtoday.com/developer/awesome-linux-game-tools-heroic-games-launcher/",
                    "name": "Awesome Linux Game Tools: Heroic Games Launcher"
                }
            }    
        ]
    }
</script>
<link rel="icon" href="https://www.linuxtoday.com/wp-content/uploads/2021/06/cropped-Linux_logos_Favicon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.linuxtoday.com/wp-content/uploads/2021/06/cropped-Linux_logos_Favicon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.linuxtoday.com/wp-content/uploads/2021/06/cropped-Linux_logos_Favicon-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.linuxtoday.com/wp-content/uploads/2021/06/cropped-Linux_logos_Favicon-270x270.png" />

<!-- Button style compiled by theme -->

<style>
    .tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                body .tdm-social-item i {
                    color: #378de2;
                }
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                    background-color: #378de2;
                }
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #378de2;
                }
                .tdm-btn-style1 {
					background-color: #378de2;
				}
				.tdm-btn-style2:before {
				    border-color: #378de2;
				}
				.tdm-btn-style2 {
				    color: #378de2;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #378de2;
                    -moz-box-shadow: 0 2px 16px #378de2;
                    box-shadow: 0 2px 16px #378de2;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #378de2;
                    -moz-box-shadow: 0 4px 26px #378de2;
                    box-shadow: 0 4px 26px #378de2;
				}
</style>

	<style id="tdw-css-placeholder"></style><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript><script>
/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))
</script></head>

<body class="user_post-template-default single single-user_post postid-180160 td-standard-pack awesome-linux-game-tools-heroic-games-launcher global-block-template-2 tdb_template_138 aa-prefix-wp-ads- tdb-template  tdc-header-template  tdc-footer-template td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

            <div class="td-scroll-up  td-hide-scroll-up-on-mob" style="display:none;"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background" style="visibility:hidden"></div>
<div id="td-mobile-nav" style="visibility:hidden">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#" aria-label="Close"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-header-menu-container"><ul id="menu-header-menu" class="td-mobile-main-menu"><li id="menu-item-171466" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-171466"><a href="https://www.linuxtoday.com/news/">News</a></li>
<li id="menu-item-171465" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-171465"><a href="https://www.linuxtoday.com/it-management/">IT Management</a></li>
<li id="menu-item-171464" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-171464"><a href="https://www.linuxtoday.com/infrastructure/">Infrastructure</a></li>
<li id="menu-item-171462" class="menu-item menu-item-type-taxonomy menu-item-object-category current-user_post-ancestor current-menu-parent current-user_post-parent menu-item-171462"><a href="https://www.linuxtoday.com/developer/">Developer</a></li>
<li id="menu-item-171467" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-171467"><a href="https://www.linuxtoday.com/security/">Security</a></li>
<li id="menu-item-171463" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-171463"><a href="https://www.linuxtoday.com/high-performance/">High Performance</a></li>
<li id="menu-item-171468" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-171468"><a href="https://www.linuxtoday.com/storage/">Storage</a></li>
<li id="menu-item-171461" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-171461"><a href="https://www.linuxtoday.com/blog/">Blog</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background" style="visibility:hidden"></div>
<div class="td-search-wrap-mob" style="visibility:hidden">
	<div class="td-drop-down-search">
		<form method="get" class="td-search-form" action="https://www.linuxtoday.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
	</div>
</div>

    <div id="td-outer-wrap" class="td-theme-wrap">
    
                    <div class="td-header-template-wrap" style="position: relative">
                                    <div class="td-header-mobile-wrap ">
                        <div id="tdi_1" class="tdc-zone"><div class="tdc_zone tdi_2  wpb_row td-pb-row tdc-element-style"  >
<style scoped>

/* custom css */
.tdi_2{
                    min-height: 0;
                }.tdi_2 > .td-element-style:after{
                    content: '' !important;
                    width: 100% !important;
                    height: 100% !important;
                    position: absolute !important;
                    top: 0 !important;
                    left: 0 !important;
                    z-index: 0 !important;
                    display: block !important;
                    background-color: #ffffff !important;
                }.td-header-mobile-wrap{
                    position: relative;
                    width: 100%;
                }

/* phone */
@media (max-width: 767px){
.tdi_2:before{
                    content: '';
                    display: block;
                    width: 100vw;
                    height: 100%;
                    position: absolute;
                    left: 50%;
                    transform: translateX(-50%);
                    box-shadow:  0px 2px 6px 0px rgba(0, 0, 0, 0.08);
                    z-index: 20;
                    pointer-events: none;
                }@media (max-width: 767px) {
                    .tdi_2:before {
                        width: 100%;
                    }
                }
}
</style>
<div class="tdi_1_rand_style td-element-style" ></div><div id="tdi_3" class="tdc-row"><div class="vc_row tdi_4  wpb_row td-pb-row" >
<style scoped>

/* custom css */
.tdi_4,
                .tdi_4 .tdc-columns{
                    min-height: 0;
                }.tdi_4,
				.tdi_4 .tdc-columns{
				    display: block;
				}.tdi_4 .tdc-columns{
				    width: 100%;
				}

/* phone */
@media (max-width: 767px){
.tdi_4,
				.tdi_4 .tdc-columns{
				    display: flex;
				
				    flex-direction: row;
				
				    flex-wrap: nowrap;
				
				    justify-content: flex-start;
				
				    align-items: flex-start;
				}.tdi_4 .tdc-columns{
				    width: 100%;
				}
}
/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_4{
padding-top:3px !important;
padding-bottom:3px !important;
}
}

</style><div class="vc_column tdi_6  wpb_column vc_column_container tdc-column td-pb-span3">
<style scoped>

/* custom css */
.tdi_6{
                    vertical-align: baseline;
                }.tdi_6 > .wpb_wrapper,
				.tdi_6 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_6 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_6 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_6 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}

/* phone */
@media (max-width: 767px){
.tdi_6 > .wpb_wrapper,
				.tdi_6 > .wpb_wrapper > .tdc-elements{
				    display: flex;
				
				    flex-direction: row;
				
				    flex-wrap: nowrap;
				
				    justify-content: flex-start;
				
				    align-items: center;
				}.tdi_6 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_6 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_6 > .wpb_wrapper{
				    width: 100%;
				    height: 100%;
				}
}
</style><div class="wpb_wrapper"><div class="td_block_wrap tdb_mobile_menu tdi_7 td-pb-border-top td_block_template_2 tdb-header-align"  data-td-block-uid="tdi_7" >
<style>

/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_7{
margin-top:10px !important;
margin-right:20px !important;
}
}

</style>
<style>
/* custom css */
.tdb-header-align{
                  vertical-align: middle;
                }.tdb_mobile_menu{
                  margin-bottom: 0;
                  clear: none;
                }.tdb_mobile_menu a{
                  display: inline-block !important;
                  position: relative;
                  text-align: center;
                  color: #4db2ec;
                }.tdb_mobile_menu a > span{
                  display: flex;
                  align-items: center;
                  justify-content: center;
                }.tdb_mobile_menu svg{
                  height: auto;
                }.tdb_mobile_menu svg,
                .tdb_mobile_menu svg *{
                  fill: #4db2ec;
                }#tdc-live-iframe .tdb_mobile_menu a{
                  pointer-events: none;
                }.tdi_7{
                    display: inline-block;
                }.tdi_7 .tdb-mobile-menu-button i{
                    font-size: 27px;
                
                    width: 54px;
					height: 54px;
					line-height:  54px;
                }.tdi_7 .tdb-mobile-menu-button svg{
                    width: 27px;
                }.tdi_7 .tdb-mobile-menu-button .tdb-mobile-menu-icon-svg{
                    width: 54px;
					height: 54px;
                }.tdi_7 .tdb-mobile-menu-button{
                    color: #515151;
                }.tdi_7 .tdb-mobile-menu-button svg,
                .tdi_7 .tdb-mobile-menu-button svg *{
                    fill: #515151;
                }.tdi_7 .tdb-mobile-menu-button:hover{
                    color: #008de8;
                }.tdi_7 .tdb-mobile-menu-button:hover svg,
                .tdi_7 .tdb-mobile-menu-button:hover svg *{
                    fill: #008de8;
                }

/* phone */
@media (max-width: 767px){
.tdi_7 .tdb-mobile-menu-button i{
                    width: 27px;
					height: 27px;
					line-height:  27px;
                }.tdi_7 .tdb-mobile-menu-button .tdb-mobile-menu-icon-svg{
                    width: 27px;
					height: 27px;
                }
}
</style><div class="tdb-block-inner td-fix-index"><a class="tdb-mobile-menu-button" aria-label="menu-button" href="#"><span class="tdb-mobile-menu-icon tdb-mobile-menu-icon-svg"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 1024 1024"><path d="M881.152 489.133h-738.335c-17.654 0-31.98 14.305-31.98 32 0 17.705 14.326 32.020 31.98 32.020h738.335c17.695 0 32.010-14.305 32.010-32.020 0-17.695-14.326-32-32.010-32zM881.152 256.367h-738.335c-17.654 0-31.98 14.316-31.98 31.99 0 17.705 14.326 32.061 31.98 32.061h738.335c17.695 0 32.010-14.346 32.010-32.061 0-17.674-14.326-31.99-32.010-31.99zM513.444 721.888h-370.596c-17.674 0-32.010 14.326-32.010 32.061 0 17.572 14.346 31.969 32.010 31.969h370.586c17.705 0 32.020-14.397 32.020-31.969 0.010-17.725-14.305-32.061-32.010-32.061z"></path></svg></span></a></div></div> <!-- ./block --></div></div><div class="vc_column tdi_9  wpb_column vc_column_container tdc-column td-pb-span6">
<style scoped>

/* custom css */
.tdi_9{
                    vertical-align: baseline;
                }.tdi_9 > .wpb_wrapper,
				.tdi_9 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_9 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_9 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_9 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="td_block_wrap tdb_header_logo tdi_10 td-pb-border-top td_block_template_2 tdb-header-align"  data-td-block-uid="tdi_10" >
<style>

/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_10{
margin-top:10px !important;
}
}

</style>
<style>
/* custom css */
.tdb_header_logo{
                  margin-bottom: 0;
                  clear: none;
                }.tdb_header_logo .tdb-logo-a,
                .tdb_header_logo h1{
                  display: flex;
                  pointer-events: auto;
                  align-items: flex-start;
                }.tdb_header_logo h1{
                  margin: 0;
                  line-height: 0;
                }.tdb_header_logo .tdb-logo-img-wrap img{
                  display: block;
                }.tdb_header_logo .tdb-logo-svg-wrap + .tdb-logo-img-wrap{
                  display: none;
                }.tdb_header_logo .tdb-logo-svg-wrap svg{
                  width: 50px;
                  display: block;
                  transition: fill .3s ease;
                }.tdb_header_logo .tdb-logo-text-wrap{
                  display: flex;
                }.tdb_header_logo .tdb-logo-text-title,
                .tdb_header_logo .tdb-logo-text-tagline{
                  -webkit-transition: all 0.2s ease;
                  transition: all 0.2s ease;
                }.tdb_header_logo .tdb-logo-text-title{
                  background-size: cover;
                  background-position: center center;
                  font-size: 75px;
                  font-family: serif;
                  line-height: 1.1;
                  color: #222;
                  white-space: nowrap;
                }.tdb_header_logo .tdb-logo-text-tagline{
                  margin-top: 2px;
                  font-size: 12px;
                  font-family: serif;
                  letter-spacing: 1.8px;
                  line-height: 1;
                  color: #767676;
                }.tdb_header_logo .tdb-logo-icon{
                  position: relative;
                  font-size: 46px;
                  color: #000;
                }.tdb_header_logo .tdb-logo-icon-svg{
                  line-height: 0;
                }.tdb_header_logo .tdb-logo-icon-svg svg{
                  width: 46px;
                  height: auto;
                }.tdb_header_logo .tdb-logo-icon-svg svg,
                .tdb_header_logo .tdb-logo-icon-svg svg *{
                  fill: #000;
                }.tdi_10 .tdb-logo-a,
                .tdi_10 h1{
                    flex-direction: row;
                
                    align-items: center;
                
                    justify-content: center;
                }.tdi_10 .tdb-logo-svg-wrap{
                    display: block;
                }.tdi_10 .tdb-logo-svg-wrap + .tdb-logo-img-wrap{
                    display: none;
                }.tdi_10 .tdb-logo-img-wrap{
                    display: block;
                }.tdi_10 .tdb-logo-text-tagline{
                    margin-top: 2px;
                    margin-left: 0;
                
                    display: block;
                }.tdi_10 .tdb-logo-text-title{
                    display: block;
                }.tdi_10 .tdb-logo-text-wrap{
                    flex-direction: column;
                
                    align-items: flex-start;
                }.tdi_10 .tdb-logo-icon{
                    top: 0px;
                
                    display: block;
                }@media (max-width: 767px) {
                  .tdb_header_logo .tdb-logo-text-title {
                    font-size: 36px;
                  }
                }@media (max-width: 767px) {
                  .tdb_header_logo .tdb-logo-text-tagline {
                    font-size: 11px;
                  }
                }
</style><div class="tdb-block-inner td-fix-index"><a class="tdb-logo-a" href="https://www.linuxtoday.com/"><span class="tdb-logo-img-wrap"><img class="tdb-logo-img td-retina-data" data-retina="https://www.linuxtoday.com/wp-content/uploads/2021/06/Linux_logos_RetinaMobile-Logo.png" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20751%20200'%3E%3C/svg%3E" alt="LinuxToday"  title="LinuxToday"  width="751" height="200" data-lazy-src="https://www.linuxtoday.com/wp-content/uploads/2021/06/Linux_logos_MobileLogo.png" /><noscript><img class="tdb-logo-img td-retina-data" data-retina="https://www.linuxtoday.com/wp-content/uploads/2021/06/Linux_logos_RetinaMobile-Logo.png" src="https://www.linuxtoday.com/wp-content/uploads/2021/06/Linux_logos_MobileLogo.png" alt="LinuxToday"  title="LinuxToday"  width="751" height="200" /></noscript></span></a></div></div> <!-- ./block --></div></div><div class="vc_column tdi_12  wpb_column vc_column_container tdc-column td-pb-span3">
<style scoped>

/* custom css */
.tdi_12{
                    vertical-align: baseline;
                }.tdi_12 > .wpb_wrapper,
				.tdi_12 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_12 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_12 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_12 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="td_block_wrap tdb_mobile_search tdi_13 td-pb-border-top td_block_template_2 tdb-header-align"  data-td-block-uid="tdi_13" >
<style>
/* custom css */
.tdb_mobile_search{
                  margin-bottom: 0;
                  clear: none;
                }.tdb_mobile_search a{
                  display: inline-block !important;
                  position: relative;
                  text-align: center;
                  color: #4db2ec;
                }.tdb_mobile_search a > span{
                  display: flex;
                  align-items: center;
                  justify-content: center;
                }.tdb_mobile_search svg{
                  height: auto;
                }.tdb_mobile_search svg,
                .tdb_mobile_search svg *{
                  fill: #4db2ec;
                }#tdc-live-iframe .tdb_mobile_search a{
                  pointer-events: none;
                }.tdi_13{
                    display: inline-block;
                
                    float: right;
                    clear: none;
                }.tdi_13 .tdb-block-inner{
                    text-align: center;
                }.tdi_13 .tdb-header-search-button-mob i{
                    font-size: 22px;
                
                    width: 55px;
					height: 55px;
					line-height:  55px;
                }.tdi_13 .tdb-header-search-button-mob svg{
                    width: 22px;
                }.tdi_13 .tdb-header-search-button-mob .tdb-mobile-search-icon-svg{
                    width: 55px;
					height: 55px;
					display: flex;
                    justify-content: center;
                }.tdi_13 .tdb-header-search-button-mob{
                    color: #515151;
                }.tdi_13 .tdb-header-search-button-mob svg,
                .tdi_13 .tdb-header-search-button-mob svg *{
                    fill: #515151;
                }.tdi_13 .tdb-header-search-button-mob:hover{
                    color: #008de8;
                }
</style><div class="tdb-block-inner td-fix-index"><a class="tdb-header-search-button-mob dropdown-toggle" href="#" role="button" aria-label="Search" data-toggle="dropdown"><i class="tdb-mobile-search-icon td-icon-search"></i></a></div></div> <!-- ./block --></div></div></div></div></div></div>                    </div>
                                    <div class="td-header-mobile-sticky-wrap tdc-zone-sticky-invisible tdc-zone-sticky-inactive" style="display: none">
                        <div id="tdi_14" class="tdc-zone"><div class="tdc_zone tdi_15  wpb_row td-pb-row" data-sticky-offset="0" >
<style scoped>

/* custom css */
.tdi_15{
                    min-height: 0;
                }.td-header-mobile-sticky-wrap.td-header-active{
                    opacity: 1;
                }
</style><div id="tdi_16" class="tdc-row"><div class="vc_row tdi_17  wpb_row td-pb-row" >
<style scoped>

/* custom css */
.tdi_17,
                .tdi_17 .tdc-columns{
                    min-height: 0;
                }.tdi_17,
				.tdi_17 .tdc-columns{
				    display: block;
				}.tdi_17 .tdc-columns{
				    width: 100%;
				}
</style><div class="vc_column tdi_19  wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped>

/* custom css */
.tdi_19{
                    vertical-align: baseline;
                }.tdi_19 > .wpb_wrapper,
				.tdi_19 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_19 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_19 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_19 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"></div></div></div></div></div></div>                    </div>
                
                    <div class="td-header-desktop-wrap ">
                        <div id="tdi_20" class="tdc-zone"><div class="tdc_zone tdi_21  wpb_row td-pb-row"  >
<style scoped>

/* custom css */
.tdi_21{
                    min-height: 0;
                }.td-header-desktop-wrap{
                    position: relative;
                }
</style><div id="tdi_22" class="tdc-row stretch_row_1400 td-stretch-content"><div class="vc_row tdi_23  wpb_row td-pb-row tdc-element-style" >
<style scoped>

/* custom css */
.tdi_23,
                .tdi_23 .tdc-columns{
                    min-height: 0;
                }.tdi_23 > .td-element-style > .td-element-style-before{
                    transition: none;
                    -webkit-transition: none;
                    opacity: 1;
                }.tdi_23 > .td-element-style:after{
                    content: '' !important;
                    width: 100% !important;
                    height: 100% !important;
                    position: absolute !important;
                    top: 0 !important;
                    left: 0 !important;
                    z-index: 0 !important;
                    display: block !important;
                    background-color: #008de8;
                }.tdi_23,
				.tdi_23 .tdc-columns{
				    display: block;
				}.tdi_23 .tdc-columns{
				    width: 100%;
				}
/* inline tdc_css att */

.tdi_23{
margin-top:0px !important;
margin-bottom:0px !important;
}

.tdi_23 .td_block_wrap{ text-align:left }

</style>
<div class="tdi_22_rand_style td-element-style" ></div><div class="vc_column tdi_25  wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped>

/* custom css */
.tdi_25{
                    vertical-align: baseline;
                }.tdi_25 > .wpb_wrapper,
				.tdi_25 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_25 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_25 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_25 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="tdm_block td_block_wrap tdm_block_inline_text tdi_26 td-pb-border-top td_block_template_2"  data-td-block-uid="tdi_26" >
<style>

/* inline tdc_css att */

.tdi_26{
margin-top:0px !important;
margin-bottom:0px !important;
}

</style>
<style>
/* custom css */
.tdm_block.tdm_block_inline_text{
                  margin-bottom: 0;
                  vertical-align: top;
                }.tdm_block.tdm_block_inline_text .tdm-descr{
                  margin-bottom: 0;
                  -webkit-transform: translateZ(0);
                  transform: translateZ(0);
                }.tdc-row-content-vert-center .tdm-inline-text-yes{
                  vertical-align: middle;
                }.tdc-row-content-vert-bottom .tdm-inline-text-yes{
                  vertical-align: bottom;
                }.tdi_26{
                    text-align: center !important;
                    margin-right: auto; 
                    margin-left: auto;
                }.tdi_26 .tdm-descr{
                    color: #008de8;
                
					font-family:Raleway !important;font-size:5px !important;
				}

/* landscape */
@media (min-width: 1019px) and (max-width: 1140px){
.tdi_26 .tdm-descr{
					font-family:Raleway !important;font-size:11px !important;
				}
}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
.tdi_26 .tdm-descr{
					font-family:Raleway !important;font-size:11px !important;
				}
}
</style><p class="tdm-descr">---</p></div></div></div></div></div><div id="tdi_27" class="tdc-row tdc-row-is-sticky tdc-rist-top stretch_row_1400 td-stretch-content"><div class="vc_row tdi_28  wpb_row td-pb-row tdc-element-style" >
<style scoped>

/* custom css */
body .tdc-row.tdc-rist-top-active,
                body .tdc-row.tdc-rist-bottom-active{
                  position: fixed;
                  left: 50%;
                  transform: translateX(-50%);
                  z-index: 10000;
                }body .tdc-row.tdc-rist-top-active.td-stretch-content,
                body .tdc-row.tdc-rist-bottom-active.td-stretch-content{
                  width: 100% !important;
                }body .tdc-row.tdc-rist-top-active{
                  top: 0;
                }body .tdc-row.tdc-rist-absolute{
                  position: absolute;
                }body .tdc-row.tdc-rist-bottom-active{
                  bottom: 0;
                }.tdi_28,
                .tdi_28 .tdc-columns{
                    min-height: 0;
                }.tdi_28 > .td-element-style > .td-element-style-before{
                    transition: none;
                    -webkit-transition: none;
                    opacity: 1;
                }.tdi_28 > .td-element-style:after{
                    content: '' !important;
                    width: 100% !important;
                    height: 100% !important;
                    position: absolute !important;
                    top: 0 !important;
                    left: 0 !important;
                    z-index: 0 !important;
                    display: block !important;
                    background-color: #ffffff !important;
                }.tdi_28:before{
                    display: block;
                    width: 100vw; 
                    height: 100%;
                    position: absolute;
                    left: 50%;
                    transform: translateX(-50%);
                    box-shadow:  0px 6px 6px 0px #f2f2f2;
                    z-index: 20;
                    pointer-events: none;
                    top: 0;
                }.tdi_28,
				.tdi_28 .tdc-columns{
				    display: block;
				}.tdi_28 .tdc-columns{
				    width: 100%;
				}@media (min-width: 767px) {
                  body.admin-bar .tdc-row.tdc-rist-top-active {
                    top: 32px;
                  }
                }@media (min-width: 768px) {
	                .tdi_28 {
	                    margin-left: -0px;
	                    margin-right: -0px;
	                }
	                .tdi_28 .tdc-row-video-background-error,
	                .tdi_28 .vc_column {
	                    padding-left: 0px;
	                    padding-right: 0px;
	                }
                }
/* inline tdc_css att */

/* landscape */
@media (min-width: 1019px) and (max-width: 1140px)
{
.tdi_28{
padding-top:10px !important;
padding-bottom:10px !important;
}
}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px)
{
.tdi_28{
padding-top:10px !important;
padding-bottom:10px !important;
}
}

</style>
<div class="tdi_27_rand_style td-element-style" ></div><div class="vc_column tdi_30  wpb_column vc_column_container tdc-column td-pb-span3">
<style scoped>

/* custom css */
.tdi_30{
                    vertical-align: baseline;
                }.tdi_30 > .wpb_wrapper,
				.tdi_30 > .wpb_wrapper > .tdc-elements{
				    display: flex;
				
				    flex-direction: row;
				
				    flex-wrap: nowrap;
				
				    justify-content: flex-start;
				
				    align-items: center;
				}.tdi_30 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_30 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_30 > .wpb_wrapper{
				    width: 100%;
				    height: 100%;
				}
</style><div class="wpb_wrapper"><div class="td_block_wrap tdb_header_logo tdi_31 td-pb-border-top td_block_template_2 tdb-header-align"  data-td-block-uid="tdi_31" >
<style>
/* custom css */
.tdi_31 .tdb-logo-a,
                .tdi_31 h1{
                    flex-direction: row;
                
                    align-items: center;
                
                    justify-content: flex-start;
                }.tdi_31 .tdb-logo-svg-wrap{
                    display: block;
                }.tdi_31 .tdb-logo-svg-wrap + .tdb-logo-img-wrap{
                    display: none;
                }.tdi_31 .tdb-logo-img{
                    max-width: 60%;
                }.tdi_31 .tdb-logo-img-wrap{
                    display: block;
                }.tdi_31 .tdb-logo-text-tagline{
                    margin-top: 2px;
                    margin-left: 0;
                
                    display: block;
                }.tdi_31 .tdb-logo-text-title{
                    display: block;
                }.tdi_31 .tdb-logo-text-wrap{
                    flex-direction: column;
                
                    align-items: flex-start;
                }.tdi_31 .tdb-logo-icon{
                    top: 0px;
                
                    display: block;
                }
</style><div class="tdb-block-inner td-fix-index"><a class="tdb-logo-a" href="https://www.linuxtoday.com/"><span class="tdb-logo-img-wrap"><img class="tdb-logo-img td-retina-data" data-retina="https://www.linuxtoday.com/wp-content/uploads/2021/06/Linux_logos_RetinaLogo.png" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201134%20375'%3E%3C/svg%3E" alt="LinuxToday"  title="LinuxToday"  width="1134" height="375" data-lazy-src="https://www.linuxtoday.com/wp-content/uploads/2021/06/Linux_logos_MainLogo.png" /><noscript><img class="tdb-logo-img td-retina-data" data-retina="https://www.linuxtoday.com/wp-content/uploads/2021/06/Linux_logos_RetinaLogo.png" src="https://www.linuxtoday.com/wp-content/uploads/2021/06/Linux_logos_MainLogo.png" alt="LinuxToday"  title="LinuxToday"  width="1134" height="375" /></noscript></span></a></div></div> <!-- ./block --></div></div><div class="vc_column tdi_33  wpb_column vc_column_container tdc-column td-pb-span9">
<style scoped>

/* custom css */
.tdi_33{
                    vertical-align: baseline;
                }.tdi_33 > .wpb_wrapper,
				.tdi_33 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_33 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_33 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_33 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="td_block_wrap tdb_header_menu tdi_34 tds_menu_active1 tds_menu_sub_active1 tdb-head-menu-inline td-pb-border-top td_block_template_2 tdb-header-align"  data-td-block-uid="tdi_34"  style=" z-index: 999;">
<style>

/* inline tdc_css att */

.tdi_34{
margin-top:10px !important;
}

</style>
<style>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</style>
<style>
.tdi_34 .tdb-menu > li.current-menu-item > a,
				.tdi_34 .tdb-menu > li.current-menu-ancestor > a,
				.tdi_34 .tdb-menu > li.current-category-ancestor > a,
				.tdi_34 .tdb-menu > li:hover > a,
				.tdi_34 .tdb-menu > li.tdb-hover > a,
				.tdi_34 .tdb-menu-items-dropdown:hover .td-subcat-more{
					color: #757575;
				}.tdi_34 .tdb-menu > li.current-menu-item > a .tdb-sub-menu-icon-svg svg,
				.tdi_34 .tdb-menu > li.current-menu-item > a .tdb-sub-menu-icon-svg svg *,
				.tdi_34 .tdb-menu > li.current-menu-ancestor > a .tdb-sub-menu-icon-svg svg,
				.tdi_34 .tdb-menu > li.current-menu-ancestor > a .tdb-sub-menu-icon-svg svg *,
				.tdi_34 .tdb-menu > li.current-category-ancestor > a .tdb-sub-menu-icon-svg svg,
				.tdi_34 .tdb-menu > li.current-category-ancestor > a .tdb-sub-menu-icon-svg svg *,
				.tdi_34 .tdb-menu > li:hover > a .tdb-sub-menu-icon-svg svg,
				.tdi_34 .tdb-menu > li:hover > a .tdb-sub-menu-icon-svg svg *,
				.tdi_34 .tdb-menu > li.tdb-hover > a .tdb-sub-menu-icon-svg svg,
				.tdi_34 .tdb-menu > li.tdb-hover > a .tdb-sub-menu-icon-svg svg *,
				.tdi_34 .tdb-menu-items-dropdown:hover .td-subcat-more .tdb-menu-more-icon-svg svg,
				.tdi_34 .tdb-menu-items-dropdown:hover .td-subcat-more .tdb-menu-more-icon-svg svg *{
					fill: #757575;
				}.tdi_34 .tdb-menu > li > a:after,
				.tdi_34 .tdb-menu-items-dropdown .td-subcat-more:after{
					background-color: #008de8;
				
					height: 5px;
				
					bottom: 53px;
				}
</style>
<style>
.tdi_34 .tdb-menu ul .tdb-normal-menu.current-menu-item > a,
				.tdi_34 .tdb-menu ul .tdb-normal-menu.current-menu-ancestor > a,
				.tdi_34 .tdb-menu ul .tdb-normal-menu.current-category-ancestor > a,
				.tdi_34 .tdb-menu ul .tdb-normal-menu.tdb-hover > a,
				.tdi_34 .tdb-menu ul .tdb-normal-menu:hover > a,
				.tdi_34 .tdb-menu-items-dropdown .td-pulldown-filter-list li:hover > a{
					color: #dd3333;
				}.tdi_34 .tdb-menu ul .tdb-normal-menu.current-menu-item > a .tdb-sub-menu-icon-svg svg,
				.tdi_34 .tdb-menu ul .tdb-normal-menu.current-menu-item > a .tdb-sub-menu-icon-svg svg *,
				.tdi_34 .tdb-menu ul .tdb-normal-menu.current-menu-ancestor > a .tdb-sub-menu-icon-svg svg,
				.tdi_34 .tdb-menu ul .tdb-normal-menu.current-menu-ancestor > a .tdb-sub-menu-icon-svg svg *,
				.tdi_34 .tdb-menu ul .tdb-normal-menu.current-category-ancestor > a .tdb-sub-menu-icon-svg svg,
				.tdi_34 .tdb-menu ul .tdb-normal-menu.current-category-ancestor > a .tdb-sub-menu-icon-svg svg *,
				.tdi_34 .tdb-menu ul .tdb-normal-menu.tdb-hover > a .tdb-sub-menu-icon-svg svg,
				.tdi_34 .tdb-menu ul .tdb-normal-menu.tdb-hover > a .tdb-sub-menu-icon-svg svg *,
				.tdi_34 .tdb-menu ul .tdb-normal-menu:hover > a .tdb-sub-menu-icon-svg svg,
				.tdi_34 .tdb-menu ul .tdb-normal-menu:hover > a .tdb-sub-menu-icon-svg svg *,
				.tdi_34 .tdb-menu-items-dropdown .td-pulldown-filter-list li:hover > a .tdb-sub-menu-icon-svg svg,
				.tdi_34 .tdb-menu-items-dropdown .td-pulldown-filter-list li:hover > a .tdb-sub-menu-icon-svg svg *{
					fill: #dd3333;
				}
</style><div id=tdi_34 class="td_block_inner td-fix-index"><div class="tdb-main-sub-icon-fake"><i class="tdb-sub-menu-icon td-icon-down tdb-main-sub-menu-icon"></i></div><div class="tdb-sub-icon-fake"><i class="tdb-sub-menu-icon td-icon-right-arrow"></i></div><ul id="menu-header-menu-1" class="tdb-block-menu tdb-menu tdb-menu-items-visible"><li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-cur-menu-item menu-item-first tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-171466"><a href="https://www.linuxtoday.com/news/"><div class="tdb-menu-item-text">News</div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-171465"><a href="https://www.linuxtoday.com/it-management/"><div class="tdb-menu-item-text">IT Management</div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-171464"><a href="https://www.linuxtoday.com/infrastructure/"><div class="tdb-menu-item-text">Infrastructure</div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-user_post-ancestor current-menu-parent current-user_post-parent tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-171462"><a href="https://www.linuxtoday.com/developer/"><div class="tdb-menu-item-text">Developer</div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-171467"><a href="https://www.linuxtoday.com/security/"><div class="tdb-menu-item-text">Security</div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-171463"><a href="https://www.linuxtoday.com/high-performance/"><div class="tdb-menu-item-text">High Performance</div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-171468"><a href="https://www.linuxtoday.com/storage/"><div class="tdb-menu-item-text">Storage</div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-171461"><a href="https://www.linuxtoday.com/blog/"><div class="tdb-menu-item-text">Blog</div></a></li>
</ul></div></div><div class="td_block_wrap tdb_header_search tdi_37 tdb-header-search-trigger-enabled td-pb-border-top td_block_template_2 tdb-header-align"  data-td-block-uid="tdi_37" >
<style>

/* inline tdc_css att */

.tdi_37{
margin-top:12px !important;
}

</style>
<style>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</style><div class="tdb-block-inner td-fix-index"><div class="tdb-drop-down-search" aria-labelledby="td-header-search-button"><div class="tdb-drop-down-search-inner"><form method="get" class="tdb-search-form" action="https://www.linuxtoday.com/"><div class="tdb-search-form-inner"><input class="tdb-head-search-form-input" type="text" value="" name="s" autocomplete="off" /><button class="wpb_button wpb_btn-inverse btn tdb-head-search-form-btn" type="submit"><span>Search</span></button></div></form><div class="tdb-aj-search"></div></div></div><a href="#" role="button" aria-label="Search" class="tdb-head-search-btn dropdown-toggle" data-toggle="dropdown"><i class="tdb-search-icon td-icon-search"></i></a></div></div> <!-- ./block --></div></div></div></div></div></div>                    </div>
                                <div class="td-header-desktop-sticky-wrap tdc-zone-sticky-invisible tdc-zone-sticky-inactive" style="display: none">
                    <div id="tdi_38" class="tdc-zone"><div class="tdc_zone tdi_39  wpb_row td-pb-row" data-sticky-offset="0" >
<style scoped>

/* custom css */
.tdi_39{
                    min-height: 0;
                }.td-header-desktop-sticky-wrap.td-header-active{
                    opacity: 1;
                }
</style><div id="tdi_40" class="tdc-row"><div class="vc_row tdi_41  wpb_row td-pb-row" >
<style scoped>

/* custom css */
.tdi_41,
                .tdi_41 .tdc-columns{
                    min-height: 0;
                }.tdi_41,
				.tdi_41 .tdc-columns{
				    display: block;
				}.tdi_41 .tdc-columns{
				    width: 100%;
				}
</style><div class="vc_column tdi_43  wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped>

/* custom css */
.tdi_43{
                    vertical-align: baseline;
                }.tdi_43 > .wpb_wrapper,
				.tdi_43 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_43 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_43 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_43 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"></div></div></div></div></div></div>                </div>
            </div>
            





    <div class="td-main-content-wrap td-container-wrap">
        <div class="tdc-content-wrap">
                
<article class="post-138 tdb_templates type-tdb_templates status-publish post" itemscope="" itemtype="https://schema.org/Article">
    <div id="tdi_44" class="tdc-zone">
        <div class="tdc_zone tdi_45  wpb_row td-pb-row">
            <div id="tdi_46" class="tdc-row">
                <div class="vc_row tdi_47  wpb_row td-pb-row">
                    <div class="vc_column tdi_49  wpb_column vc_column_container tdc-column td-pb-span12">
                        <div class="wpb_wrapper">
                            <div class="td-block td-a-rec td-a-rec-id-custom-spot tdi_50 td_block_template_2">
                                <div class="wp-ads-inline-top wp-ads-target" id="wp-ads-1600237740" data-advadstrackid="119" data-advadstrackbid="1"><!-- Start: GAM Ad Slot Render | LinuxToday Inline Top -->
<div id="inline-top" style="min-width: 300px; width: auto; text-align:center; min-height: 50px; max-height: 250px; height: auto; background-color: transparent; border:0px solid #efefef;">
    <script>
        window.googletag = window.googletag ||
        {
            cmd: []
        };

        window.googletag.cmd.push(function()
        {
            googletag.display("inline-top");
        });
    </script>
</div>
<!-- End: GAM Ad Slot Render | LinuxToday Inline Top --></div>                            </div>
                        </div>
                    </div>
                </div>
            </div>        
            <div id="tdi_51" class="tdc-row stretch_row_1400 td-stretch-content">
                <div class="vc_row tdi_52  wpb_row td-pb-row">
                    <div class="vc_column tdi_54  wpb_column vc_column_container tdc-column td-pb-span9">
                        <div class="wpb_wrapper">
                            <div class="clearfix"></div>
                            <div class="td_block_wrap tdb_breadcrumbs tdi_55 td-pb-border-top td_block_template_2 tdb-breadcrumbs " data-td-block-uid="tdi_55">
                                <div class="tdb-block-inner td-fix-index">
                                    <span>
                                        <a title="" class="tdb-entry-crumb" href="https://www.linuxtoday.com/">Home</a>
                                    </span>
                                    <i class="tdb-bread-sep td-icon-right"></i>
                                    <span>
                                        <a title="View All Posts in Developer" class="tdb-entry-crumb" href="https://www.linuxtoday.com/developer/">Developer</a>
                                    </span>
                                </div>
                            </div>
                            <div class="td_block_wrap tdb_title tdi_56 tdb-single-title td-pb-border-top td_block_template_2" data-td-block-uid="tdi_56">
                                <div class="tdb-block-inner td-fix-index">
                                    <h1 class="tdb-title-text">Awesome Linux Game Tools: Heroic Games Launcher</h1>
                                    <div class="tdb-title-line"></div>
                                </div>
                            </div>
                            <div class="td_block_wrap td_single_author_from_postmeta tdi_57 td-pb-border-top td_block_template_2" data-td-block-uid="tdi_57">    
                                <div class="tdb-block-inner td-fix-index">
                                    <div class="tdb-author-name-wrap">
                                        <span class="tdb-author-by">By</span>
                                        LinuxLinks                                    </div>
                                </div>
                            </div>
                            <div class="td_block_wrap tdb_single_date tdi_58 td-pb-border-top td_block_template_2 tdb-post-meta" data-td-block-uid="tdi_58">
                                <div class="tdb-block-inner td-fix-index">
                                    <time class="entry-date updated td-module-date" datetime="2022-11-18T15:00:05+00:00">November 18, 2022</time>
                                </div>
                            </div> <!-- ./block -->
                            <div class="td_block_wrap tdb_single_content tdi_59 td-pb-border-top td_block_template_2 td-post-content tagdiv-type" data-td-block-uid="tdi_59">
                                <div class="tdb-block-inner td-fix-index">
                                    <div class="form-custom-fields-container above-content"></div>
                                    <p>Heroic Games Launcher (&#8220;Heroic&#8221;) is a free and open source games launcher for Epic Games and GOG. Learn more about it here.</p>
                                </div>
                              </div>
                            <div class="td_block_wrap td_single_publication_source_from_postmeta tdi_60 td-pb-border-top td_block_template_2" data-td-block-uid="tdi_60">
                                <a href="https://www.linuxlinks.com/awesome-linux-game-tools-heroic-games-launcher/" class="action-btn publication_source" target="_blank">Complete Story</a>
                            </div>
                            <div class="td_block_wrap tdb_single_post_share tdi_61 td-pb-border-top td_block_template_2" data-td-block-uid="tdi_61">
                                <div id="tdi_61" class="td-post-sharing tdb-block td-ps-bg td-ps-notext td-post-sharing-style1">
                                    <div class="td-post-sharing-visible">
                                        <a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https://www.linuxtoday.com/developer/awesome-linux-game-tools-heroic-games-launcher/" title="Facebook" style="transition: opacity 0.2s ease 0s; opacity: 1;">
                                            <div class="td-social-but-icon">
                                                <i class="td-icon-facebook"></i>
                                            </div>
                                            <div class="td-social-but-text">Facebook</div>
                                        </a>
                                        <a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Awesome Linux Game Tools: Heroic Games Launcher&amp;url=https://www.linuxtoday.com/developer/awesome-linux-game-tools-heroic-games-launcher/&amp;via=Linux Today" title="Twitter" style="transition: opacity 0.2s ease 0s; opacity: 1;">
                                            <div class="td-social-but-icon">
                                                <i class="td-icon-twitter"></i>
                                            </div>
                                            <div class="td-social-but-text">Twitter</div>
                                        </a>
                                        <a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.linuxtoday.com/developer/awesome-linux-game-tools-heroic-games-launcher//&amp;title=Awesome Linux Game Tools: Heroic Games Launcher" title="Linkedin" style="transition: opacity 0.2s ease 0s; opacity: 1;">
                                            <div class="td-social-but-icon">
                                                <i class="td-icon-linkedin"></i>
                                            </div>
                                            <div class="td-social-but-text">Linkedin</div>
                                        </a>
                                        <a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="mailto:?subject=Awesome Linux Game Tools: Heroic Games Launcher&amp;body=https://www.linuxtoday.com/developer/awesome-linux-game-tools-heroic-games-launcher/" title="Email" style="transition: opacity 0.2s ease 0s; opacity: 1;">
                                            <div class="td-social-but-icon">
                                                <i class="td-icon-mail"></i>
                                            </div>
                                            <div class="td-social-but-text">Email</div>
                                        </a>
                                        <a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#" title="Print" style="transition: opacity 0.2s ease 0s; opacity: 1;">
                                            <div class="td-social-but-icon">
                                                <i class="td-icon-print"></i>
                                            </div>
                                            <div class="td-social-but-text">Print</div>
                                        </a>
                                    </div>
                                    <div class="td-social-sharing-hidden" style="display: none;">
                                        <ul class="td-pulldown-filter-list"></ul>
                                        <a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="tdi_61" title="More">
                                            <div class="td-social-but-icon">
                                                <i class="td-icon-plus td-social-expand-tabs-icon"></i>
                                            </div>
                                        </a>
                                    </div>
                                </div>
                            </div>                        
                            <div class="td_block_wrap tdb_single_next_prev tdi_62 td-pb-border-top td_block_template_2" data-td-block-uid="tdi_62">
                                <div class="tdb-block-inner td-fix-index">
                                    <div class="tdb-next-post tdb-next-post-bg tdb-post-prev">
                                        <span>Previous article</span><a href="https://www.linuxtoday.com/developer/disable-ipv6-rhel-rocky-almalinux/" rel="prev">How to Disable IPv6 in RHEL, Rocky Linux, and AlmaLinux</a>                                    </div>
                                    <div class="tdb-next-post tdb-next-post-bg tdb-post-next">
                                        <span>Next article</span>                                    </div>
                                </div>
                            </div>
                          </div>
                        </div>
                        <div class="vc_column tdi_64  wpb_column vc_column_container tdc-column td-pb-span3 td-is-sticky">
                            <div class="wpb_wrapper" style="width: auto; position: static; top: auto; bottom: auto;">
                                <div class="wp-ads-sticky-rail wp-ads-target" id="wp-ads-1453304928" data-advadstrackid="121" data-advadstrackbid="1"><!-- Start: GAM Ad Slot Render | LinuxToday Sticky Rail -->
<div id="sticky-rail" style="max-width: 300px; min-width: 160px; width: auto; text-align:center; min-height: 250px; max-height: 600px; height: auto; background-color: #ffffff; border:0px solid #efefef;">
    <script>
        window.googletag = window.googletag ||
        {
            cmd: []
        };

        window.googletag.cmd.push(function()
        {
            googletag.display("sticky-rail");
        });
    </script>
</div>
<!-- End: GAM Ad Slot Render | LinuxToday Sticky Rail --></div>                                <div class="clearfix"></div>
                                <div class="td_block_wrap td_flex_block_1 tdi_66 td-pb-border-top _ntv_must_read_widget td_block_template_2 td_flex_block" data-td-block-uid="tdi_66">
                                   
                                            <div class="td-block-title-wrap">
                                                        <h4 class="td-block-title">
                                                            <span class="td-pulldown-size">Must Read</span>
                                                        </h4>
                                                    </div>
                                                <div id="tdi_66" class="td_block_inner td-mc1-wrap"><div class="td_module_flex td_module_flex_1 td_module_wrap td-animation-stack">
                                                                <div class="td-module-container td-category-pos-above">                                                          
                                                                    <div class="td-module-meta-info">
                                                                        <a href="https://www.linuxtoday.com/developer/" class="td-post-category">Developer</a>
                                                                        <h3 class="entry-title td-module-title">
                                                                            <a href="https://www.linuxtoday.com/developer/disable-ipv6-rhel-rocky-almalinux/" rel="bookmark" title="How to Disable IPv6 in RHEL, Rocky Linux, and AlmaLinux">How to Disable IPv6 in RHEL, Rocky Linux, and AlmaLinux</a>
                                                                        </h3>                                                          
                                                                    </div>
                                                                </div>
                                                            </div><br>
<div class="td_module_flex td_module_flex_1 td_module_wrap td-animation-stack">
                                                                <div class="td-module-container td-category-pos-above">                                                          
                                                                    <div class="td-module-meta-info">
                                                                        <a href="https://www.linuxtoday.com/developer/" class="td-post-category">Developer</a>
                                                                        <h3 class="entry-title td-module-title">
                                                                            <a href="https://www.linuxtoday.com/developer/install-makemkv-debian-11-10/" rel="bookmark" title="How to Install MakeMKV on Debian 11 and 10">How to Install MakeMKV on Debian 11 and 10</a>
                                                                        </h3>                                                          
                                                                    </div>
                                                                </div>
                                                            </div><br>
<div class="td_module_flex td_module_flex_1 td_module_wrap td-animation-stack">
                                                                <div class="td-module-container td-category-pos-above">                                                          
                                                                    <div class="td-module-meta-info">
                                                                        <a href="https://www.linuxtoday.com/developer/" class="td-post-category">Developer</a>
                                                                        <h3 class="entry-title td-module-title">
                                                                            <a href="https://www.linuxtoday.com/developer/apt-nala-like-apt-ubuntu/" rel="bookmark" title="Apt++? Nala is Like Apt in Ubuntu but Better">Apt++? Nala is Like Apt in Ubuntu but Better</a>
                                                                        </h3>                                                          
                                                                    </div>
                                                                </div>
                                                            </div><br>
<div class="td_module_flex td_module_flex_1 td_module_wrap td-animation-stack">
                                                                <div class="td-module-container td-category-pos-above">                                                          
                                                                    <div class="td-module-meta-info">
                                                                        <a href="https://www.linuxtoday.com/developer/" class="td-post-category">Developer</a>
                                                                        <h3 class="entry-title td-module-title">
                                                                            <a href="https://www.linuxtoday.com/developer/rocky-linux-8-7-released-updated-compiler-tool-set/" rel="bookmark" title="Rocky Linux 8.7 Released With Updated Compiler Tool Set">Rocky Linux 8.7 Released With Updated Compiler Tool Set</a>
                                                                        </h3>                                                          
                                                                    </div>
                                                                </div>
                                                            </div><br>
<div class="td_module_flex td_module_flex_1 td_module_wrap td-animation-stack">
                                                                <div class="td-module-container td-category-pos-above">                                                          
                                                                    <div class="td-module-meta-info">
                                                                        <a href="https://www.linuxtoday.com/security/" class="td-post-category">Security</a>
                                                                        <h3 class="entry-title td-module-title">
                                                                            <a href="https://www.linuxtoday.com/news/top-passwords-used-rdp-brute-force-attacks/" rel="bookmark" title="Top Passwords Used in RDP Brute-Force Attacks">Top Passwords Used in RDP Brute-Force Attacks</a>
                                                                        </h3>                                                          
                                                                    </div>
                                                                </div>
                                                            </div><br>
</div>                                </div>
                                <div class="clearfix"></div>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
        </div>
    </div>
</article>   

<style>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</style>    <div class="comments" id="comments">
            </div> <!-- /.content -->
            </div>
    </div>

<!-- Instagram -->
    <div class="td-footer-template-wrap" style="position: relative">
                <div class="td-footer-wrap ">
            <div id="tdi_44" class="tdc-zone"><div class="tdc_zone tdi_45  wpb_row td-pb-row tdc-element-style"  >
<style scoped>

/* custom css */
.tdi_45{
                    min-height: 0;
                }.tdi_45 > .td-element-style:after{
                    content: '' !important;
                    width: 100% !important;
                    height: 100% !important;
                    position: absolute !important;
                    top: 0 !important;
                    left: 0 !important;
                    z-index: 0 !important;
                    display: block !important;
                    background-color: #000000 !important;
                }
</style>
<div class="tdi_44_rand_style td-element-style" ></div><div id="tdi_46" class="tdc-row stretch_row_1400 td-stretch-content"><div class="vc_row tdi_47  wpb_row td-pb-row tdc-element-style" >
<style scoped>

/* custom css */
.tdi_47,
                .tdi_47 .tdc-columns{
                    min-height: 0;
                }.tdi_47,
				.tdi_47 .tdc-columns{
				    display: block;
				}.tdi_47 .tdc-columns{
				    width: 100%;
				}@media (min-width: 768px) {
	                .tdi_47 {
	                    margin-left: -60px;
	                    margin-right: -60px;
	                }
	                .tdi_47 .tdc-row-video-background-error,
	                .tdi_47 .vc_column {
	                    padding-left: 60px;
	                    padding-right: 60px;
	                }
                }

/* landscape */
@media (min-width: 1019px) and (max-width: 1140px){
@media (min-width: 768px) {
	                .tdi_47 {
	                    margin-left: -10px;
	                    margin-right: -10px;
	                }
	                .tdi_47 .tdc-row-video-background-error,
	                .tdi_47 .vc_column {
	                    padding-left: 10px;
	                    padding-right: 10px;
	                }
                }
}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
@media (min-width: 768px) {
	                .tdi_47 {
	                    margin-left: -10px;
	                    margin-right: -10px;
	                }
	                .tdi_47 .tdc-row-video-background-error,
	                .tdi_47 .vc_column {
	                    padding-left: 10px;
	                    padding-right: 10px;
	                }
                }
}
/* inline tdc_css att */

.tdi_47{
padding-top:60px !important;
padding-bottom:40px !important;
position:relative;
}

.tdi_47 .td_block_wrap{ text-align:left }

/* portrait */
@media (min-width: 768px) and (max-width: 1018px)
{
.tdi_47{
padding-top:30px !important;
padding-bottom:10px !important;
}
}

/* phone */
@media (max-width: 767px)
{
.tdi_47{
padding-top:40px !important;
}
}

</style>
<div class="tdi_46_rand_style td-element-style" ><div class="td-element-style-before"><style>
.tdi_46_rand_style > .td-element-style-before {
content:'' !important;
width:100% !important;
height:100% !important;
position:absolute !important;
top:0 !important;
left:0 !important;
display:block !important;
z-index:0 !important;
opacity:0.1 !important;
background-size:cover !important;
background-position:center top !important;
}
</style></div><style>
.tdi_46_rand_style{
background-color:#f2f2f2 !important;
}
 </style></div><div class="vc_column tdi_49  wpb_column vc_column_container tdc-column td-pb-span5">
<style scoped>

/* custom css */
.tdi_49{
                    vertical-align: baseline;
                }.tdi_49 > .wpb_wrapper,
				.tdi_49 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_49 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_49 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_49 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_49{
justify-content:center !important;
text-align:center !important;
}
}

</style><div class="wpb_wrapper"><div class="td_block_wrap tdb_header_logo tdi_50 td-pb-border-top td_block_template_2 tdb-header-align"  data-td-block-uid="tdi_50" >
<style>

/* inline tdc_css att */

.tdi_50{
margin-top:10px !important;
margin-bottom:10px !important;
}

/* phone */
@media (max-width: 767px)
{
.tdi_50{
padding-left:40px !important;
display:inline-block !important;
}
}

</style>
<style>
/* custom css */
.tdi_50 .tdb-logo-a,
                .tdi_50 h1{
                    flex-direction: row;
                
                    align-items: center;
                
                    justify-content: flex-start;
                }.tdi_50 .tdb-logo-svg-wrap{
                    display: block;
                }.tdi_50 .tdb-logo-svg-wrap + .tdb-logo-img-wrap{
                    display: none;
                }.tdi_50 .tdb-logo-img{
                    max-width: 50%;
                }.tdi_50 .tdb-logo-img-wrap{
                    display: block;
                }.tdi_50 .tdb-logo-text-tagline{
                    margin-top: 2px;
                    margin-left: 0;
                
                    display: block;
                }.tdi_50 .tdb-logo-text-title{
                    display: block;
                
                    color: #ffffff;
                
                    font-size:34px !important;font-weight:500 !important;text-transform:uppercase !important;;
                }.tdi_50 .tdb-logo-text-wrap{
                    flex-direction: column;
                
                    align-items: center;
                }.tdi_50 .tdb-logo-icon{
                    top: 0px;
                
                    display: block;
                }

/* landscape */
@media (min-width: 1019px) and (max-width: 1140px){
.tdi_50 .tdb-logo-text-title{
                    font-size:32px !important;font-weight:500 !important;text-transform:uppercase !important;;
                }
}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
.tdi_50 .tdb-logo-text-title{
                    font-size:22px !important;font-weight:500 !important;text-transform:uppercase !important;;
                }
}
</style><div class="tdb-block-inner td-fix-index"><a class="tdb-logo-a" href="https://www.linuxtoday.com/"><span class="tdb-logo-img-wrap"><img class="tdb-logo-img td-retina-data" data-retina="https://www.linuxtoday.com/wp-content/uploads/2021/06/Linux_logos_RetinaLogo.png" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201134%20375'%3E%3C/svg%3E" alt="LinuxToday"  title="LinuxToday"  width="1134" height="375" data-lazy-src="https://www.linuxtoday.com/wp-content/uploads/2021/06/Linux_logos_MainLogo.png" /><noscript><img class="tdb-logo-img td-retina-data" data-retina="https://www.linuxtoday.com/wp-content/uploads/2021/06/Linux_logos_RetinaLogo.png" src="https://www.linuxtoday.com/wp-content/uploads/2021/06/Linux_logos_MainLogo.png" alt="LinuxToday"  title="LinuxToday"  width="1134" height="375" /></noscript></span></a></div></div> <!-- ./block --><div class="tdm_block td_block_wrap tdm_block_inline_text tdi_51 td-pb-border-top td_block_template_2"  data-td-block-uid="tdi_51" >
<style>

/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_51{
justify-content:center !important;
text-align:center !important;
}
}

</style>
<style>
/* custom css */
.tdi_51{
                    text-align: left !important;
                }.tdi_51 .tdm-descr{
                    color: #515151;
                
					font-family:Fira Sans !important;font-size:14px !important;line-height:1.4 !important;
				}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
.tdi_51 .tdm-descr{
					font-family:Fira Sans !important;font-size:12px !important;line-height:1.4 !important;
				}
}
</style><p class="tdm-descr">LinuxToday is a trusted, contributor-driven news resource supporting all types of Linux users. Our thriving international community engages with us through social media and frequent content contributions aimed at solving problems ranging from personal computing to enterprise-level IT operations. LinuxToday serves as a home for a community that struggles to find comparable information elsewhere on the web.</p></div><div class="tdm_block td_block_wrap tdm_block_socials tdi_52 tdm-inline-block tdm-content-horiz-left td-pb-border-top td_block_template_2"  data-td-block-uid="tdi_52" >
<style>

/* inline tdc_css att */

.tdi_52{
margin-top:10px !important;
margin-bottom:20px !important;
}

</style>
<style>
/* custom css */
.tdm_block.tdm_block_socials{
                  margin-bottom: 0;
                }.tdm-social-wrapper{
                  *zoom: 1;
                }.tdm-social-wrapper:before,
                .tdm-social-wrapper:after{
                  display: table;
                  content: '';
                  line-height: 0;
                }.tdm-social-wrapper:after{
                  clear: both;
                }.tdm-social-item-wrap{
                  display: inline-block;
                }.tdm-social-item{
                  position: relative;
                  display: inline-block;
                  vertical-align: middle;
                  -webkit-transition: all 0.2s;
                  transition: all 0.2s;
                  text-align: center;
                  -webkit-transform: translateZ(0);
                  transform: translateZ(0);
                }.tdm-social-item i{
                  font-size: 14px;
                  color: #4db2ec;
                  -webkit-transition: all 0.2s;
                  transition: all 0.2s;
                }.tdm-social-text{
                  display: none;
                  margin-top: -1px;
                  vertical-align: middle;
                  font-size: 13px;
                  color: #4db2ec;
                  -webkit-transition: all 0.2s;
                  transition: all 0.2s;
                }.tdm-social-item-wrap:hover i,
                .tdm-social-item-wrap:hover .tdm-social-text{
                  color: #000;
                }.tdm-social-item-wrap:last-child .tdm-social-text{
                  margin-right: 0 !important;
                }
</style>
<style>
.tdi_53 .tdm-social-item i{
					font-size: 16px;
					vertical-align: middle;
				
					line-height: 28.8px;
				}.tdi_53 .tdm-social-item i.td-icon-twitter,
				.tdi_53 .tdm-social-item i.td-icon-linkedin,
				.tdi_53 .tdm-social-item i.td-icon-pinterest,
				.tdi_53 .tdm-social-item i.td-icon-blogger,
				.tdi_53 .tdm-social-item i.td-icon-vimeo{
					font-size: 12.8px;
				}.tdi_53 .tdm-social-item{
					width: 28.8px;
					height: 28.8px;
				
				    margin: 5px 10px 5px 0;
				}.tdi_53 .tdm-social-item-wrap:last-child .tdm-social-item{
				    margin-right: 0 !important;
				}.tdi_53 .tdm-social-item i,
				.tds-team-member2 .tdi_53.tds-social1 .tdm-social-item i{
					color: #515151;
				}.tdi_53 .tdm-social-item-wrap:hover i,
				.tds-team-member2 .tdi_53.tds-social1 .tdm-social-item:hover i{
					color: #008de8;
				}.tdi_53 .tdm-social-text{
					display: none;
				
					margin-left: 2px;
				
					margin-right: 18px;
				}

/* portrait */
@media (min-width: 768px) and (max-width: 1018px){
.tdi_53 .tdm-social-item i{
					font-size: 12px;
					vertical-align: middle;
				
					line-height: 21.6px;
				}.tdi_53 .tdm-social-item i.td-icon-twitter,
				.tdi_53 .tdm-social-item i.td-icon-linkedin,
				.tdi_53 .tdm-social-item i.td-icon-pinterest,
				.tdi_53 .tdm-social-item i.td-icon-blogger,
				.tdi_53 .tdm-social-item i.td-icon-vimeo{
					font-size: 9.6px;
				}.tdi_53 .tdm-social-item{
					width: 21.6px;
					height: 21.6px;
				}
}
</style><div class="tdm-social-wrapper tds-social1 tdi_53"><div class="tdm-social-item-wrap"><a href="https://www.facebook.com/LinuxToday-635265507098561/"  title="Facebook" class="tdm-social-item"><i class="td-icon-font td-icon-facebook"></i></a><a href="https://www.facebook.com/LinuxToday-635265507098561/" class="tdm-social-text" >Facebook</a></div><div class="tdm-social-item-wrap"><a href="https://www.linkedin.com/company/linuxtoday/"  title="Linkedin" class="tdm-social-item"><i class="td-icon-font td-icon-linkedin"></i></a><a href="https://www.linkedin.com/company/linuxtoday/" class="tdm-social-text" >Linkedin</a></div><div class="tdm-social-item-wrap"><a href="https://twitter.com/linuxtoday?ref_src=twsrc%5Egoogle%7Ctwcamp%5Eserp%7Ctwgr%5Eauthor"  title="Twitter" class="tdm-social-item"><i class="td-icon-font td-icon-twitter"></i></a><a href="https://twitter.com/linuxtoday?ref_src=twsrc%5Egoogle%7Ctwcamp%5Eserp%7Ctwgr%5Eauthor" class="tdm-social-text" >Twitter</a></div></div></div></div></div><div class="vc_column tdi_55  wpb_column vc_column_container tdc-column td-pb-span7">
<style scoped>

/* custom css */
.tdi_55{
                    vertical-align: baseline;
                }.tdi_55 > .wpb_wrapper,
				.tdi_55 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_55 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_55 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_55 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="wpb_wrapper td_block_empty_space td_block_wrap vc_empty_space tdi_57 "  style="height: 20px"></div><div class="vc_row_inner tdi_59  vc_row vc_inner wpb_row td-pb-row" >
<style scoped>

/* custom css */
.tdi_59{
                    position: relative !important;
                    top: 0;
                    transform: none;
                    -webkit-transform: none;
                }.tdi_59,
				.tdi_59 .tdc-inner-columns{
				    display: block;
				}.tdi_59 .tdc-inner-columns{
				    width: 100%;
				}
</style><div class="vc_column_inner tdi_61  wpb_column vc_column_container tdc-inner-column td-pb-span3">
<style scoped>

/* custom css */
.tdi_61{
                    vertical-align: baseline;
                }.tdi_61 .vc_column-inner > .wpb_wrapper,
				.tdi_61 .vc_column-inner > .wpb_wrapper .tdc-elements{
				    display: block;
				}.tdi_61 .vc_column-inner > .wpb_wrapper .tdc-elements{
				    width: 100%;
				}
</style><div class="vc_column-inner"><div class="wpb_wrapper"></div></div></div><div class="vc_column_inner tdi_63  wpb_column vc_column_container tdc-inner-column td-pb-span9">
<style scoped>

/* custom css */
.tdi_63{
                    vertical-align: baseline;
                }.tdi_63 .vc_column-inner > .wpb_wrapper,
				.tdi_63 .vc_column-inner > .wpb_wrapper .tdc-elements{
				    display: block;
				}.tdi_63 .vc_column-inner > .wpb_wrapper .tdc-elements{
				    width: 100%;
				}
</style><div class="vc_column-inner"><div class="wpb_wrapper"><div class="td_block_wrap tdb_header_menu tdi_64 tds_menu_active1 tds_menu_sub_active1 td-pb-border-top td_block_template_2 tdb-header-align"  data-td-block-uid="tdi_64"  style=" z-index: 999;">
<style>

/* inline tdc_css att */

.tdi_64{
z-index:2 !important;
}

</style>
<style>
/* custom css */
.tdi_64{
                    float: right;
                    clear: none;
                }.tdi_64 .td_block_inner{
                    text-align: right;
                }.tdi_64 .tdb-menu > li .tdb-menu-sep,
                .tdi_64 .tdb-menu-items-dropdown .tdb-menu-sep{
                    top: -1px;
                }.tdi_64 .tdb-menu > li > a .tdb-sub-menu-icon,
                .tdi_64 .td-subcat-more .tdb-menu-more-subicon{
                    top: -1px;
                
                    color: #f0a83b;
                }.tdi_64 .td-subcat-more .tdb-menu-more-icon{
                    top: 0px;
                }.tdi_64 .tdb-menu > li > a,
                .tdi_64 .td-subcat-more{
                    color: #515151;
                }.tdi_64 .tdb-menu > li > a .tdb-sub-menu-icon-svg svg,
                .tdi_64 .tdb-menu > li > a .tdb-sub-menu-icon-svg svg *,
                .tdi_64 .td-subcat-more .tdb-menu-more-subicon-svg svg,
                .tdi_64 .td-subcat-more .tdb-menu-more-subicon-svg svg *,
                .tdi_64 .td-subcat-more .tdb-menu-more-icon-svg,
                .tdi_64 .td-subcat-more .tdb-menu-more-icon-svg *{
                    fill: #515151;
                }.tdi_64 .tdb-menu > li > a .tdb-sub-menu-icon-svg svg,
                .tdi_64 .tdb-menu > li > a .tdb-sub-menu-icon-svg svg *,
                .tdi_64 .td-subcat-more .tdb-menu-more-subicon-svg svg,
                .tdi_64 .td-subcat-more .tdb-menu-more-subicon-svg svg *{
                    fill: #f0a83b;
                }.tdi_64 .tdb-menu > li > a,
                .tdi_64 .td-subcat-more,
                .tdi_64 .td-subcat-more > .tdb-menu-item-text{
                    font-family:Fira Sans !important;font-size:16px !important;font-weight:400 !important;text-transform:none !important;
                }.tdi_64 .tdb-normal-menu ul .tdb-menu-item > a .tdb-sub-menu-icon,
                .tdi_64 .td-pulldown-filter-list .tdb-menu-item > a .tdb-sub-menu-icon{
                    right: 0;
                
                    margin-top: 1px;
                }.tdi_64 .tdb-menu .tdb-normal-menu ul,
                .tdi_64 .td-pulldown-filter-list,
                .tdi_64 .td-pulldown-filter-list .sub-menu{
                    box-shadow:  1px 1px 4px 0px rgba(0, 0, 0, 0.15);
                }.tdi_64 .tdb-menu .tdb-normal-menu ul .tdb-menu-item > a,
                .tdi_64 .td-pulldown-filter-list li a{
                    font-family:Fira Sans !important;
                }.tdi_64 .tdb-menu .tdb-mega-menu .sub-menu > li{
					box-shadow:  0px 2px 6px 0px rgba(0, 0, 0, 0.1);
				}
</style>
<style>
.tdi_64 .tdb-menu > li.current-menu-item > a,
				.tdi_64 .tdb-menu > li.current-menu-ancestor > a,
				.tdi_64 .tdb-menu > li.current-category-ancestor > a,
				.tdi_64 .tdb-menu > li:hover > a,
				.tdi_64 .tdb-menu > li.tdb-hover > a,
				.tdi_64 .tdb-menu-items-dropdown:hover .td-subcat-more{
					color: #515151;
				}.tdi_64 .tdb-menu > li.current-menu-item > a .tdb-sub-menu-icon-svg svg,
				.tdi_64 .tdb-menu > li.current-menu-item > a .tdb-sub-menu-icon-svg svg *,
				.tdi_64 .tdb-menu > li.current-menu-ancestor > a .tdb-sub-menu-icon-svg svg,
				.tdi_64 .tdb-menu > li.current-menu-ancestor > a .tdb-sub-menu-icon-svg svg *,
				.tdi_64 .tdb-menu > li.current-category-ancestor > a .tdb-sub-menu-icon-svg svg,
				.tdi_64 .tdb-menu > li.current-category-ancestor > a .tdb-sub-menu-icon-svg svg *,
				.tdi_64 .tdb-menu > li:hover > a .tdb-sub-menu-icon-svg svg,
				.tdi_64 .tdb-menu > li:hover > a .tdb-sub-menu-icon-svg svg *,
				.tdi_64 .tdb-menu > li.tdb-hover > a .tdb-sub-menu-icon-svg svg,
				.tdi_64 .tdb-menu > li.tdb-hover > a .tdb-sub-menu-icon-svg svg *,
				.tdi_64 .tdb-menu-items-dropdown:hover .td-subcat-more .tdb-menu-more-icon-svg svg,
				.tdi_64 .tdb-menu-items-dropdown:hover .td-subcat-more .tdb-menu-more-icon-svg svg *{
					fill: #515151;
				}.tdi_64 .tdb-menu > li > a:after,
				.tdi_64 .tdb-menu-items-dropdown .td-subcat-more:after{
					background-color: #f0a83b;
				
					bottom: 0px;
				}
</style>
<style>

</style><div id=tdi_64 class="td_block_inner td-fix-index"><div class="tdb-main-sub-icon-fake"><i class="tdb-sub-menu-icon td-icon-down tdb-main-sub-menu-icon"></i></div><div class="tdb-sub-icon-fake"><i class="tdb-sub-menu-icon td-icon-right-arrow"></i></div><ul id="menu-header-menu-2" class="tdb-block-menu tdb-menu tdb-menu-items-visible"><li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-cur-menu-item menu-item-first tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-171466"><a href="https://www.linuxtoday.com/news/"><div class="tdb-menu-item-text">News</div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-171465"><a href="https://www.linuxtoday.com/it-management/"><div class="tdb-menu-item-text">IT Management</div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-171464"><a href="https://www.linuxtoday.com/infrastructure/"><div class="tdb-menu-item-text">Infrastructure</div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-user_post-ancestor current-menu-parent current-user_post-parent tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-171462"><a href="https://www.linuxtoday.com/developer/"><div class="tdb-menu-item-text">Developer</div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-171467"><a href="https://www.linuxtoday.com/security/"><div class="tdb-menu-item-text">Security</div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-171463"><a href="https://www.linuxtoday.com/high-performance/"><div class="tdb-menu-item-text">High Performance</div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-171468"><a href="https://www.linuxtoday.com/storage/"><div class="tdb-menu-item-text">Storage</div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-171461"><a href="https://www.linuxtoday.com/blog/"><div class="tdb-menu-item-text">Blog</div></a></li>
</ul></div></div></div></div></div></div></div></div></div></div><div id="tdi_67" class="tdc-row stretch_row_1400 td-stretch-content"><div class="vc_row tdi_68  wpb_row td-pb-row tdc-element-style" >
<style scoped>

/* custom css */
.tdi_68,
                .tdi_68 .tdc-columns{
                    min-height: 0;
                }.tdi_68,
				.tdi_68 .tdc-columns{
				    display: block;
				}.tdi_68 .tdc-columns{
				    width: 100%;
				}
/* inline tdc_css att */

.tdi_68{
padding-top:40px !important;
position:relative;
}

.tdi_68 .td_block_wrap{ text-align:left }

</style>
<div class="tdi_67_rand_style td-element-style" ><style>
.tdi_67_rand_style{
background-color:#2d2d2d !important;
}
 </style></div><div class="vc_column tdi_70  wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped>

/* custom css */
.tdi_70{
                    vertical-align: baseline;
                }.tdi_70 > .wpb_wrapper,
				.tdi_70 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_70 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_70 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_70 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="tdm_block td_block_wrap tdm_block_column_title tdi_71 tdm-content-horiz-left td-pb-border-top td_block_template_2"  data-td-block-uid="tdi_71" >
<style>
/* custom css */
.tdm_block_column_title{
                  margin-bottom: 0;
                  display: inline-block;
                  width: 100%;
                }
</style><div class="td-block-row"><div class="td-block-span12 tdm-col">
<style>
body .tdi_72 .tdm-title{
					color: #ffffff;
				}.tdi_72 .tdm-title{
					font-family:liquor-store, sans-serif; !important;font-style:italic !important;
				}
</style><div class="tds-title tds-title1 td-fix-index tdi_72"><h3 class="tdm-title tdm-title-md">Our Brands</h3></div></div></div></div></div></div></div></div><div id="tdi_73" class="tdc-row stretch_row_1400 td-stretch-content"><div class="vc_row tdi_74  wpb_row td-pb-row tdc-element-style" >
<style scoped>

/* custom css */
.tdi_74,
                .tdi_74 .tdc-columns{
                    min-height: 0;
                }.tdi_74,
				.tdi_74 .tdc-columns{
				    display: block;
				}.tdi_74 .tdc-columns{
				    width: 100%;
				}@media (min-width: 768px) {
	                .tdi_74 {
	                    margin-left: -0px;
	                    margin-right: -0px;
	                }
	                .tdi_74 .tdc-row-video-background-error,
	                .tdi_74 .vc_column {
	                    padding-left: 0px;
	                    padding-right: 0px;
	                }
                }
/* inline tdc_css att */

.tdi_74{
position:relative;
}

.tdi_74 .td_block_wrap{ text-align:left }

</style>
<div class="tdi_73_rand_style td-element-style" ><style>
.tdi_73_rand_style{
background-color:#2d2d2d !important;
}
 </style></div><div class="vc_column tdi_76  wpb_column vc_column_container tdc-column td-pb-span3">
<style scoped>

/* custom css */
.tdi_76{
                    vertical-align: baseline;
                }.tdi_76 > .wpb_wrapper,
				.tdi_76 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_76 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_76 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_76 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}

/* phone */
@media (max-width: 767px){
.tdi_76 > .wpb_wrapper,
				.tdi_76 > .wpb_wrapper > .tdc-elements{
				    display: flex;
				
				    flex-direction: row;
				
				    flex-wrap: nowrap;
				
				    justify-content: center;
				
				    align-items: flex-start;
				}.tdi_76 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_76 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_76 > .wpb_wrapper{
				    width: 100%;
				    height: 100%;
				}
}
</style><div class="wpb_wrapper"><div class="wpb_wrapper td_block_single_image td_block_wrap td_block_wrap vc_single_image tdi_77  td-single-image- td-pb-border-top td_block_template_2 "  data-td-block-uid="tdi_77"><a data-bg="https://www.linuxtoday.com/wp-content/uploads/2021/01/TAwhitefooter.png" 
			class="td_single_image_bg rocket-lazyload" 
			style="" 
			href="https://technologyadvice.com/"  target="_blank"  ></a>
<style>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</style></div><div class="wpb_wrapper td_block_single_image td_block_wrap td_block_wrap vc_single_image tdi_78  td-single-image- td-pb-border-top td_block_template_2 "  data-td-block-uid="tdi_78"><a data-bg="https://www.linuxtoday.com/wp-content/uploads/2021/01/eweekfooter.png" 
			class="td_single_image_bg rocket-lazyload" 
			style="" 
			href="https://www.eweek.com/"  target="_blank"  ></a>
<style>

/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_78{
margin-left:2px !important;
}
}

</style>
<style>
/* custom css */
.tdi_78 .td_single_image_bg{
					height: 40px;
					padding-bottom: 0;
				
				background-size: contain;
				
                background-repeat: no-repeat;
				
                background-position: center top;
				}.tdi_78{
					width: 100%;
				}.tdi_78:hover .td_single_image_bg:before{
                    opacity: 0;
                }

/* phone */
@media (max-width: 767px){
.tdi_78 .td_single_image_bg{
					height: 35px;
					padding-bottom: 0;
				}
}
</style></div></div></div><div class="vc_column tdi_80  wpb_column vc_column_container tdc-column td-pb-span3">
<style scoped>

/* custom css */
.tdi_80{
                    vertical-align: baseline;
                }.tdi_80 > .wpb_wrapper,
				.tdi_80 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_80 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_80 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_80 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}

/* phone */
@media (max-width: 767px){
.tdi_80 > .wpb_wrapper,
				.tdi_80 > .wpb_wrapper > .tdc-elements{
				    display: flex;
				
				    flex-direction: row;
				
				    flex-wrap: nowrap;
				
				    justify-content: center;
				
				    align-items: flex-start;
				}.tdi_80 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_80 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_80 > .wpb_wrapper{
				    width: 100%;
				    height: 100%;
				}
}
</style><div class="wpb_wrapper"><div class="wpb_wrapper td_block_single_image td_block_wrap td_block_wrap vc_single_image tdi_81  td-single-image- td-pb-border-top td_block_template_2 "  data-td-block-uid="tdi_81"><a data-bg="https://www.linuxtoday.com/wp-content/uploads/2021/01/datamationwhitefooter.png" 
			class="td_single_image_bg rocket-lazyload" 
			style="" 
			href="https://www.datamation.com/"  target="_blank"  ></a>
<style>
/* custom css */
.tdi_81 .td_single_image_bg{
					height: 40px;
					padding-bottom: 0;
				
				background-size: contain;
				
                background-repeat: no-repeat;
				
                background-position: center top;
				}.tdi_81{
					width: 100%;
				}.tdi_81:hover .td_single_image_bg:before{
                    opacity: 0;
                }
</style></div><div class="wpb_wrapper td_block_single_image td_block_wrap td_block_wrap vc_single_image tdi_82  td-single-image- td-pb-border-top td_block_template_2 "  data-td-block-uid="tdi_82"><a data-bg="https://www.linuxtoday.com/wp-content/uploads/2021/01/PMcomwhitefooter-09.png" 
			class="td_single_image_bg rocket-lazyload" 
			style="" 
			href="https://project-management.com/"  target="_blank"  ></a>
<style>

/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_82{
margin-left:6px !important;
}
}

</style>
<style>
/* custom css */
.tdi_82 .td_single_image_bg{
					height: 45px;
					padding-bottom: 0;
				
				background-size: contain;
				
                background-repeat: no-repeat;
				
                background-position: center top;
				}.tdi_82{
					width: 100%;
				}.tdi_82:hover .td_single_image_bg:before{
                    opacity: 0;
                }
</style></div></div></div><div class="vc_column tdi_84  wpb_column vc_column_container tdc-column td-pb-span3">
<style scoped>

/* custom css */
.tdi_84{
                    vertical-align: baseline;
                }.tdi_84 > .wpb_wrapper,
				.tdi_84 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_84 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_84 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_84 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}

/* phone */
@media (max-width: 767px){
.tdi_84 > .wpb_wrapper,
				.tdi_84 > .wpb_wrapper > .tdc-elements{
				    display: flex;
				
				    flex-direction: row;
				
				    flex-wrap: nowrap;
				
				    justify-content: center;
				
				    align-items: flex-start;
				}.tdi_84 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_84 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_84 > .wpb_wrapper{
				    width: 100%;
				    height: 100%;
				}
}
</style><div class="wpb_wrapper"><div class="wpb_wrapper td_block_single_image td_block_wrap td_block_wrap vc_single_image tdi_85  td-single-image- td-pb-border-top td_block_template_2 "  data-td-block-uid="tdi_85"><a data-bg="https://www.linuxtoday.com/wp-content/uploads/2021/01/webowhitefooter.png" 
			class="td_single_image_bg rocket-lazyload" 
			style="" 
			href="https://www.webopedia.com/"  target="_blank"  ></a>
<style>
/* custom css */
.tdi_85 .td_single_image_bg{
					height: 35px;
					padding-bottom: 0;
				
				background-size: contain;
				
                background-repeat: no-repeat;
				
                background-position: center top;
				}.tdi_85{
					width: 100%;
				
					display: inline-block;
				}.tdi_85:hover .td_single_image_bg:before{
                    opacity: 0;
                }
</style></div><div class="wpb_wrapper td_block_single_image td_block_wrap td_block_wrap vc_single_image tdi_86  td-single-image- td-pb-border-top td_block_template_2 "  data-td-block-uid="tdi_86"><a data-bg="https://www.linuxtoday.com/wp-content/uploads/2021/01/esecuritywhitefooter.png" 
			class="td_single_image_bg rocket-lazyload" 
			style="" 
			href="https://www.esecurityplanet.com/"  target="_blank"  ></a>
<style>

/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_86{
margin-left:1px !important;
}
}

</style>
<style>
/* custom css */
.tdi_86 .td_single_image_bg{
					height: 45px;
					padding-bottom: 0;
				
				background-size: contain;
				
                background-repeat: no-repeat;
				
                background-position: center top;
				}.tdi_86{
					width: 100%;
				}.tdi_86:hover .td_single_image_bg:before{
                    opacity: 0;
                }

/* phone */
@media (max-width: 767px){
.tdi_86 .td_single_image_bg{
					height: 40px;
					padding-bottom: 0;
				}
}
</style></div></div></div><div class="vc_column tdi_88  wpb_column vc_column_container tdc-column td-pb-span3">
<style scoped>

/* custom css */
.tdi_88{
                    vertical-align: baseline;
                }.tdi_88 > .wpb_wrapper,
				.tdi_88 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_88 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_88 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_88 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}

/* phone */
@media (max-width: 767px){
.tdi_88 > .wpb_wrapper,
				.tdi_88 > .wpb_wrapper > .tdc-elements{
				    display: flex;
				
				    flex-direction: row;
				
				    flex-wrap: nowrap;
				
				    justify-content: center;
				
				    align-items: flex-start;
				}.tdi_88 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_88 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_88 > .wpb_wrapper{
				    width: 100%;
				    height: 100%;
				}
}
</style><div class="wpb_wrapper"><div class="wpb_wrapper td_block_single_image td_block_wrap td_block_wrap vc_single_image tdi_89  td-single-image- td-pb-border-top td_block_template_2 "  data-td-block-uid="tdi_89"><a data-bg="https://www.linuxtoday.com/wp-content/uploads/2021/01/serverwatchwhitefooter-10.png" 
			class="td_single_image_bg rocket-lazyload" 
			style="" 
			href="https://www.serverwatch.com/"  target="_blank"  ></a>
<style>
/* custom css */
.tdi_89 .td_single_image_bg{
					height: 50px;
					padding-bottom: 0;
				
				background-size: contain;
				
                background-repeat: no-repeat;
				
                background-position: center top;
				}.tdi_89{
					width: 100%;
				}.tdi_89:hover .td_single_image_bg:before{
                    opacity: 0;
                }

/* phone */
@media (max-width: 767px){
.tdi_89 .td_single_image_bg{
					height: 45px;
					padding-bottom: 0;
				}
}
</style></div><div class="wpb_wrapper td_block_single_image td_block_wrap td_block_wrap vc_single_image tdi_90  td-single-image- td-pb-border-top td_block_template_2 "  data-td-block-uid="tdi_90"><a data-bg="https://www.linuxtoday.com/wp-content/uploads/2021/01/ITBEwhitefooter-copy.png" 
			class="td_single_image_bg rocket-lazyload" 
			style="" 
			href="https://www.itbusinessedge.com/"  target="_blank"  ></a>
<style>

/* inline tdc_css att */

/* phone */
@media (max-width: 767px)
{
.tdi_90{
margin-left:3px !important;
}
}

</style>
<style>
/* custom css */
.tdi_90 .td_single_image_bg{
					height: 45px;
					padding-bottom: 0;
				
				background-size: contain;
				
                background-repeat: no-repeat;
				
                background-position: center top;
				}.tdi_90{
					width: 100%;
				
					display: inline-block;
				}.tdi_90:hover .td_single_image_bg:before{
                    opacity: 0;
                }

/* phone */
@media (max-width: 767px){
.tdi_90 .td_single_image_bg{
					height: 40px;
					padding-bottom: 0;
				}
}
</style></div></div></div></div></div><div id="tdi_91" class="tdc-row stretch_row_1400 td-stretch-content"><div class="vc_row tdi_92  wpb_row td-pb-row tdc-element-style" >
<style scoped>

/* custom css */
.tdi_92,
                .tdi_92 .tdc-columns{
                    min-height: 0;
                }.tdi_92,
				.tdi_92 .tdc-columns{
				    display: block;
				}.tdi_92 .tdc-columns{
				    width: 100%;
				}
/* inline tdc_css att */

.tdi_92{
position:relative;
}

.tdi_92 .td_block_wrap{ text-align:left }

</style>
<div class="tdi_91_rand_style td-element-style" ><style>
.tdi_91_rand_style{
background-color:#2d2d2d !important;
}
 </style></div><div class="vc_column tdi_94  wpb_column vc_column_container tdc-column td-pb-span12">
<style scoped>

/* custom css */
.tdi_94{
                    vertical-align: baseline;
                }.tdi_94 > .wpb_wrapper,
				.tdi_94 > .wpb_wrapper > .tdc-elements{
				    display: block;
				}.tdi_94 > .wpb_wrapper > .tdc-elements{
				    width: 100%;
				}.tdi_94 > .wpb_wrapper > .vc_row_inner{
				    width: auto;
				}.tdi_94 > .wpb_wrapper{
				    width: auto;
				    height: auto;
				}
</style><div class="wpb_wrapper"><div class="td_block_wrap tdb_header_menu tdi_95 tds_menu_active1 tds_menu_sub_active1 td-pb-border-top td_block_template_2 tdb-header-align"  data-td-block-uid="tdi_95"  style=" z-index: 999;">
<style>

/* inline tdc_css att */

.tdi_95{
margin-top:20px !important;
}

</style>
<style>
/* custom css */
.tdi_95 .td_block_inner{
                    text-align: center;
                }.tdi_95 .tdb-menu > li .tdb-menu-sep,
                .tdi_95 .tdb-menu-items-dropdown .tdb-menu-sep{
                    top: -1px;
                }.tdi_95 .tdb-menu > li > a .tdb-sub-menu-icon,
                .tdi_95 .td-subcat-more .tdb-menu-more-subicon{
                    top: -1px;
                }.tdi_95 .td-subcat-more .tdb-menu-more-icon{
                    top: 0px;
                }.tdi_95 .tdb-menu > li > a,
                .tdi_95 .td-subcat-more{
                    color: #ffffff;
                }.tdi_95 .tdb-menu > li > a .tdb-sub-menu-icon-svg svg,
                .tdi_95 .tdb-menu > li > a .tdb-sub-menu-icon-svg svg *,
                .tdi_95 .td-subcat-more .tdb-menu-more-subicon-svg svg,
                .tdi_95 .td-subcat-more .tdb-menu-more-subicon-svg svg *,
                .tdi_95 .td-subcat-more .tdb-menu-more-icon-svg,
                .tdi_95 .td-subcat-more .tdb-menu-more-icon-svg *{
                    fill: #ffffff;
                }.tdi_95 .tdb-menu > li > a,
                .tdi_95 .td-subcat-more,
                .tdi_95 .td-subcat-more > .tdb-menu-item-text{
                    font-family:Fira Sans !important;font-size:12px !important;letter-spacing:1px !important;
                }.tdi_95 .tdb-normal-menu ul .tdb-menu-item > a .tdb-sub-menu-icon,
                .tdi_95 .td-pulldown-filter-list .tdb-menu-item > a .tdb-sub-menu-icon{
                    right: 0;
                
                    margin-top: 1px;
                }.tdi_95 .tdb-menu .tdb-normal-menu ul,
                .tdi_95 .td-pulldown-filter-list,
                .tdi_95 .td-pulldown-filter-list .sub-menu{
                    box-shadow:  1px 1px 4px 0px rgba(0, 0, 0, 0.15);
                }.tdi_95 .tdb-menu .tdb-mega-menu .sub-menu > li{
					box-shadow:  0px 2px 6px 0px rgba(0, 0, 0, 0.1);
				}
</style>
<style>
.tdi_95 .tdb-menu > li > a:after,
				.tdi_95 .tdb-menu-items-dropdown .td-subcat-more:after{
					background-color: #008de8;
				
					bottom: 0px;
				}
</style>
<style>

</style><div id=tdi_95 class="td_block_inner td-fix-index"><div class="tdb-main-sub-icon-fake"><i class="tdb-sub-menu-icon td-icon-down tdb-main-sub-menu-icon"></i></div><div class="tdb-sub-icon-fake"><i class="tdb-sub-menu-icon td-icon-right-arrow"></i></div><ul id="menu-footer-menu" class="tdb-block-menu tdb-menu tdb-menu-items-visible"><li id="menu-item-107" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy tdb-cur-menu-item menu-item-first tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-107"><a href="https://www.linuxtoday.com/privacy-policy/"><div class="tdb-menu-item-text">Privacy Policy</div></a></li>
<li id="menu-item-108" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-108"><a href="https://technologyadvice.com/terms-conditions/"><div class="tdb-menu-item-text">Terms</div></a></li>
<li id="menu-item-109" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-109"><a href="https://technologyadvice.com/about-us/"><div class="tdb-menu-item-text">About</div></a></li>
<li id="menu-item-110" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-110"><a href="https://technologyadvice.com/contact-us/"><div class="tdb-menu-item-text">Contact</div></a></li>
<li id="menu-item-111" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-111"><a href="https://solutions.technologyadvice.com/digital-advertising-solutions/"><div class="tdb-menu-item-text">Advertise</div></a></li>
<li id="menu-item-112" class="menu-item menu-item-type-custom menu-item-object-custom tdb-menu-item-button tdb-menu-item tdb-normal-menu menu-item-112"><a href="https://technologyadvice.com/privacy-policy/ccpa-opt-out-form/"><div class="tdb-menu-item-text">California &#8211; Do Not Sell My Information</div></a></li>
</ul></div></div><div class="tdm_block td_block_wrap tdm_block_column_content tdi_98 tdm-content-horiz-center td-pb-border-top td_block_template_2"  data-td-block-uid="tdi_98" >
<style>

/* inline tdc_css att */

.tdi_98{
margin-top:30px !important;
padding-bottom:40px !important;
}

</style>
<style>
/* custom css */
.tdm_block_column_content .tdm-image-holder{
                  position: relative;
                  display: block;
                  height: 0;
                  margin-bottom: 24px;
                  padding-bottom: 70%;
                }.tdm_block_column_content .tdm-image-holder:hover .tdm-hover-img{
                  opacity: 1;
                }.tdm_block_column_content .tdm-image-holder > div{
                  position: absolute;
                  top: 0;
                  left: 0;
                  width: 100%;
                  height: 100%;
                  background-repeat: no-repeat;
                  background-position: center center;
                  background-size: cover;
                }.tdm_block_column_content .tdm-hover-img{
                  opacity: 0;
                  -webkit-transition: all 0.4s ease-in-out;
                  transition: all 0.4s ease-in-out;
                }.tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title{
                  color: #4db2ec;
                }.tdm_block_column_content .tdm-title-xxsm,
                .tdm_block_column_content .tdm-title-xsm{
                  margin-bottom: 20px;
                }.tdm_block_column_content .tdm-title-md{
                  margin-bottom: 14px;
                }.tdm_block_column_content .tdm-title-bg{
                  margin-bottom: 16px;
                }.tdm_block_column_content .tdm-descr{
                  margin-bottom: 0;
                }.tdm_block_column_content .tds-button{
                  margin-top: 25px;
                }.tdi_98 .tdm-descr{
                    color: #ffffff;
                
					font-family:dita-wd, sans-serif; !important;font-size:9px !important;text-transform:uppercase !important;
				}@media (max-width: 767px) {
                  .tdm_block_column_content .tdm-image-holder {
                    margin-bottom: 14px;
                  }
                }
</style><div class="tdm-col-content-info"><a href="#" class="tdm-col-content-title-url"></a><p class="tdm-descr td-fix-index">Advertiser Disclosure: Some of the products that appear on this site are from companies from which TechnologyAdvice receives compensation. This compensation may impact how and where products appear on this site including, for example, the order in which they appear. TechnologyAdvice does not include all companies or all types of products available in the marketplace.</p></div></div><div class="wpb_wrapper td_block_wrap vc_raw_html tdi_100 choice-footer-msg">
<style scoped>

/* inline tdc_css att */

.tdi_100{
margin-top:0px !important;
margin-bottom:10px !important;
padding-top:0px !important;
border-style:solid !important;
border-color:#888888 !important;
border-width: 0px 0px 0px 0px !important;
}

</style><div class="td-fix-index"><div id="choice-footer-msg" style="color:#ffffff;">
</div></div></div></div></div></div></div></div></div>        </div>

    </div>
    
</div><!--close td-outer-wrap-->


<script>(function(){var advanced_ads_ga_UID="UA-48217604-1",advanced_ads_ga_anonymIP=!!1;function AdvAdsAdBlockCounterGA(t){this.UID=t,this.analyticsObject="function"==typeof gtag;var n=this;return this.count=function(){gtag("event","AdBlock",{event_category:"Advanced Ads",event_label:"Yes",non_interaction:!0,send_to:n.UID})},function(){if(!n.analyticsObject){var e=document.createElement("script");e.src="https://www.googletagmanager.com/gtag/js?id="+t,e.async=!0,document.body.appendChild(e),window.dataLayer=window.dataLayer||[],window.gtag=function(){dataLayer.push(arguments)},n.analyticsObject=!0,gtag("js",new Date)}var a={send_page_view:!1,transport_type:"beacon"};window.advanced_ads_ga_anonymIP&&(a.anonymize_ip=!0),gtag("config",t,a)}(),this}window.advanced_ads_check_adblocker=function(t){var n=[],e=null;function a(t){(window.requestAnimationFrame||window.mozRequestAnimationFrame||window.webkitRequestAnimationFrame||function(t){return setTimeout(t,16)}).call(window,t)}return a((function(){var t=document.createElement("div");t.innerHTML="&nbsp;",t.setAttribute("class","ad_unit ad-unit text-ad text_ad pub_300x250"),t.setAttribute("style","width: 1px !important; height: 1px !important; position: absolute !important; left: 0px !important; top: 0px !important; overflow: hidden !important;"),document.body.appendChild(t),a((function(){var a=window.getComputedStyle&&window.getComputedStyle(t),o=a&&a.getPropertyValue("-moz-binding");e=a&&"none"===a.getPropertyValue("display")||"string"==typeof o&&-1!==o.indexOf("about:");for(var i=0,d=n.length;i<d;i++)n[i](e);n=[]}))})),function(t){null!==e?t(e):n.push(t)}}(),advanced_ads_check_adblocker((function(t){t&&new AdvAdsAdBlockCounterGA(advanced_ads_ga_UID).count()}));})();</script><div class="wp-ads-native-ads wp-ads-sticky wp-ads-target" id="wp-ads-376733845" style="position: fixed; bottom: 0; z-index: 10000; " data-advadstrackid="178287" data-advadstrackbid="1"><!-- Linux Today Native -->
<!-- Start: GAM Ad Slot Render | Linux Today Native Ads -->
<style>

#native-main-well {
	border-bottom: 1px solid rgba(0,0,0,0.19);
	padding: 20px 0;
	margin-bottom: -15px;
}	
	
#native-boap {
	position: relative;
}

#native-rr-article > div {
  width: 100%;
	height: 100% !important;
}	
	
#native-rr-article {
	border-bottom: 1px solid rgba(0,0,0,0.19);
	margin-bottom: -20px;
}	

#native-rr-article iframe {
	height: 100%;
}

#native-boap iframe {
	width: 100%;
  height: 36rem;
}

#native-rr-article {
	position: relative;
}	

@media screen and (min-width: 500px) {
    #native-boap iframe {
        height: 25rem;
    }
}

@media screen and (min-width: 1100px) {
    #native-boap iframe {
        height: 24.5rem;
    }
}

</style>



<div id="native-boap" style="display:none; margin-bottom: 50px;">
    <script>
        window.googletag = window.googletag ||
        {
            cmd: []
        };

        window.googletag.cmd.push(function()
        {
            googletag.display("native-boap");
        });		
    </script>
</div>

<script>
	(function() {		
		var boapSpot = document.querySelector('article.post');
		var boapAfterContent = document.querySelector("article.post .tdb_single_next_prev");		
		var boapContent = document.getElementById('native-boap');
		boapAfterContent.parentNode.insertBefore(boapContent, boapAfterContent.nextSibling);
		boapContent.style.height = 'auto';
		boapContent.style.width = '100%';	
			})();
</script>
<!-- End: GAM Ad Slot Render | Linux Today Native Ads --></div><script>( window.advanced_ads_ready || jQuery( document ).ready ).call( null, function() {var wrapper_id = "#wp-ads-376733845"; var $wrapper = jQuery( wrapper_id );advads.move( wrapper_id, "", {  });window.advanced_ads_sticky_items = window.advanced_ads_sticky_items || {};advanced_ads_sticky_items[ "wp-ads-376733845" ] = { "can_convert_to_abs": "1", "initial_css": $wrapper.attr( "style" ), "modifying_func": function() { $wrapper.css({ "-webkit-transform": "translateX(-50%)", "-moz-transform": "translateX(-50%)", "transform": "translateX(-50%)", "left": "50%", "margin-right": "-50%" });}};
if ( advads.wait_for_images ) { 
    var sticky_wait_for_images_time = new Date().getTime();
    $wrapper.data( "sticky_wait_for_images_time", sticky_wait_for_images_time );
    advads.wait_for_images( $wrapper, function() {
        // At the moment when this function is called, it is possible that 
        // the placement has been updated using "Reload ads on resize" feature of Responsive add-on 
        if ( $wrapper.data( "sticky_wait_for_images_time" ) === sticky_wait_for_images_time ) {
            advanced_ads_sticky_items[ "wp-ads-376733845" ]["modifying_func"]();
        } 
    } );
} else { 
    advanced_ads_sticky_items[ "wp-ads-376733845" ]["modifying_func"]();
};
});</script><div class="wp-ads-sticky-footer wp-ads-sticky wp-ads-target" id="wp-ads-290682099" style="position: fixed; bottom: 0; z-index: 10000; " data-advadstrackid="120" data-advadstrackbid="1"><span class="wp-ads-close-button" onclick="void(0)" title="close" style="width: 15px; height: 15px; background: #fff; position: relative; line-height: 15px; text-align: center; cursor: pointer; z-index: 10000;right:-15px;float: right; margin-left: -15px;">×</span><!-- Start: GAM Ad Slot Render | LinuxToday Sticky Bottom -->
<div id="sticky-bottom" style="max-width: 1020px; min-width: 300px; width: auto; text-align:center; min-height: 50px; max-height: 90px; height: auto; background-color: #ffffff; border:1px solid #efefef;">
    <script>
        window.googletag = window.googletag ||
        {
            cmd: []
        };

        window.googletag.cmd.push(function()
        {
            googletag.display("sticky-bottom");
        });
    </script>
</div>
<!-- End: GAM Ad Slot Render | LinuxToday Sticky Bottom --></div><script>( window.advanced_ads_ready || jQuery( document ).ready ).call( null, function() {var wrapper_id = "#wp-ads-290682099"; var $wrapper = jQuery( wrapper_id );advads.move( wrapper_id, "", {  });window.advanced_ads_sticky_items = window.advanced_ads_sticky_items || {};advanced_ads_sticky_items[ "wp-ads-290682099" ] = { "can_convert_to_abs": "1", "initial_css": $wrapper.attr( "style" ), "modifying_func": function() { $wrapper.css({ "-webkit-transform": "translateX(-50%)", "-moz-transform": "translateX(-50%)", "transform": "translateX(-50%)", "left": "50%", "margin-right": "-50%" });jQuery( "#wp-ads-290682099" ).on( "click", "span", function() { advads.close( "#wp-ads-290682099" ); });}};
if ( advads.wait_for_images ) { 
    var sticky_wait_for_images_time = new Date().getTime();
    $wrapper.data( "sticky_wait_for_images_time", sticky_wait_for_images_time );
    advads.wait_for_images( $wrapper, function() {
        // At the moment when this function is called, it is possible that 
        // the placement has been updated using "Reload ads on resize" feature of Responsive add-on 
        if ( $wrapper.data( "sticky_wait_for_images_time" ) === sticky_wait_for_images_time ) {
            advanced_ads_sticky_items[ "wp-ads-290682099" ]["modifying_func"]();
        } 
    } );
} else { 
    advanced_ads_sticky_items[ "wp-ads-290682099" ]["modifying_func"]();
};
});</script>

    <!--

        Theme: Newspaper by tagDiv.com 2022
        Version: 11.4.3 (rara)
        Deploy mode: deploy
        
        uid: 6377f25af111d
    -->

    
<!-- Custom css from theme panel -->
<style type="text/css" media="screen">
/* custom css theme panel */
/* GG: Fixes for mobile search thumbs */
.td-aj-search-results > .td_module_wrap > .td-module-container > .td-image-container
{
    display: none !important;
}
</style>

		<!-- Google Tag Manager (noscript) snippet added by Site Kit -->
		<noscript>
			<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-T4P43PZ" height="0" width="0" style="display:none;visibility:hidden"></iframe>
		</noscript>
		<!-- End Google Tag Manager (noscript) snippet added by Site Kit -->
		
<script type='text/javascript' id='icp_js-js-extra'>
/* <![CDATA[ */
var intentclicks_ajax = {"url":"https:\/\/www.linuxtoday.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script data-minify="1" type='text/javascript' src='https://www.linuxtoday.com/wp-content/cache/min/1/wp-content/plugins/ta-intentclicks-master/includes/js/scripts.js?ver=1664217620' id='icp_js-js'></script>
<script type='text/javascript' id='advanced-ads-layer-footer-js-js-extra'>
/* <![CDATA[ */
var advanced_ads_layer_settings = {"layer_class":"wp-ads-layer","placements":[]};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.linuxtoday.com/wp-content/uploads/226/185/public/assets/js/279.js?ver=1.7.5' id='advanced-ads-layer-footer-js-js'></script>
<script type='text/javascript' id='advanced-ads-responsive-js-extra'>
/* <![CDATA[ */
var advanced_ads_responsive = {"reload_on_resize":"0"};
/* ]]> */
</script>
<script data-minify="1" type='text/javascript' src='https://www.linuxtoday.com/wp-content/cache/min/1/wp-content/uploads/226/324/public/assets/js/958.js?ver=1656610518' id='advanced-ads-responsive-js'></script>
<script type='text/javascript' id='advanced-ads-sticky-footer-js-js-extra'>
/* <![CDATA[ */
var advanced_ads_sticky_settings = {"check_position_fixed":"","sticky_class":"wp-ads-sticky","placements":["native-ads","sticky-footer"]};
/* ]]> */
</script>
<script data-minify="1" type='text/javascript' src='https://www.linuxtoday.com/wp-content/cache/min/1/wp-content/uploads/226/474/public/assets/js/880.js?ver=1656610518' id='advanced-ads-sticky-footer-js-js'></script>
<script type='text/javascript' id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script>
<script type='text/javascript' id='rocket-preload-links-js-extra'>
/* <![CDATA[ */
var RocketPreloadLinksConfig = {"excludeUris":"\/(?:.+\/)?feed(?:\/(?:.+\/?)?)?$|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/wp-admin\/|\/logout\/|\/wp-login.php|\/refer\/|\/go\/|\/recommend\/|\/recommends\/","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|pdf|doc|docx|xls|xlsx|php","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|pdf|doc|docx|xls|xlsx|php|html|htm","siteUrl":"https:\/\/www.linuxtoday.com","onHoverDelay":"100","rateThrottle":"3"};
/* ]]> */
</script>
<script type='text/javascript' id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script>
<script data-minify="1" type='text/javascript' src='https://www.linuxtoday.com/wp-content/cache/min/1/wp-content/uploads/226/735/assets/js/738.js?ver=1656610518' id='advanced-ads-pro/front-js'></script>
<script type='text/javascript' src='https://www.linuxtoday.com/wp-includes/js/underscore.min.js?ver=1.13.3' id='underscore-js'></script>
<script type='text/javascript' src='https://www.linuxtoday.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=b2e02a383c117d2c27b181e37c1c9e0e' id='tdb_js_posts_autoload-js'></script>
<script type='text/javascript' src='https://www.linuxtoday.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=11.4.3' id='td-site-min-js'></script>
<script type='text/javascript' src='https://www.linuxtoday.com/wp-includes/js/comment-reply.min.js?ver=6.0.3' id='comment-reply-js'></script>
<script type='text/javascript' id='advadsTrackingScript-js-extra'>
/* <![CDATA[ */
var advadsTracking = {"impressionActionName":"aatrack-records","clickActionName":"aatrack-click","targetClass":"wp-ads-target","blogId":"1"};
/* ]]> */
</script>
<script data-minify="1" type='text/javascript' src='https://www.linuxtoday.com/wp-content/cache/min/1/wp-content/uploads/226/56/public/assets/js/839/511.js?ver=1656610518' id='advadsTrackingScript-js'></script>
<script data-minify="1" type='text/javascript' src='https://www.linuxtoday.com/wp-content/cache/min/1/wp-content/uploads/226/56/public/assets/js/839/154.js?ver=1656610518' id='advadsTrackingDelayed-js'></script>
<script type='text/javascript' src='https://www.linuxtoday.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=b2e02a383c117d2c27b181e37c1c9e0e' id='tdb_js_files_for_front-js'></script>
<!--noptimize--><script>window.advads_admin_bar_items = [{"title":"LinuxToday | Datalayer &amp; GAM Core","type":"ad"},{"title":"Before Closing Head Tag","type":"placement"},{"title":"LinuxToday | Master Ad Slot Definitions","type":"ad"},{"title":"Master Ad Slot Definitions Placements","type":"placement"},{"title":"LinuxToday | Inline Top Render","type":"ad"},{"title":"Inline Top","type":"placement"},{"title":"LinuxToday | Sticky Rail Render","type":"ad"},{"title":"Sticky Rail","type":"placement"},{"title":"LinuxToday | Native Ads - Render","type":"ad"},{"title":"Native Ads ","type":"placement"},{"title":"LinuxToday | Sticky Bottom Render","type":"ad"},{"title":"Sticky Footer","type":"placement"}];</script><!--/noptimize--><!--noptimize--><script>!function(){window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[],advanced_ads_ready_queue.push=window.advanced_ads_ready;for(var d=0,a=advanced_ads_ready_queue.length;d<a;d++)advanced_ads_ready(advanced_ads_ready_queue[d])}();</script><!--/noptimize--><!-- typekit fonts -->
<!-- JS generated by theme -->

<script>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</script>

<script id="wp-ads-tracking">var advads_tracking_ads = {"1":[117,178286,119,121,178287,120]};var advads_tracking_urls = {"1":"https:\/\/www.linuxtoday.com\/wp-content\/ajax-handler.php"};var advads_tracking_methods = {"1":"frontend"};var advads_tracking_parallel = {"1":false};var advads_tracking_linkbases = {"1":"https:\/\/www.linuxtoday.com\/linkout\/"};</script><script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(var i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://www.linuxtoday.com/wp-content/plugins/wp-rocket/assets/js/lazyload/17.5/lazyload.min.js"></script><script>function lazyLoadThumb(e){var t='<img data-lazy-src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"><noscript><img src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"></noscript>',a='<button class="play" aria-label="play Youtube video"></button>';return t.replace("ID",e)+a}function lazyLoadYoutubeIframe(){var e=document.createElement("iframe"),t="ID?autoplay=1";t+=0===this.parentNode.dataset.query.length?'':'&'+this.parentNode.dataset.query;e.setAttribute("src",t.replace("ID",this.parentNode.dataset.src)),e.setAttribute("frameborder","0"),e.setAttribute("allowfullscreen","1"),e.setAttribute("allow", "accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture"),this.parentNode.parentNode.replaceChild(e,this.parentNode)}document.addEventListener("DOMContentLoaded",function(){var e,t,p,a=document.getElementsByClassName("rll-youtube-player");for(t=0;t<a.length;t++)e=document.createElement("div"),e.setAttribute("data-id",a[t].dataset.id),e.setAttribute("data-query", a[t].dataset.query),e.setAttribute("data-src", a[t].dataset.src),e.innerHTML=lazyLoadThumb(a[t].dataset.id),a[t].appendChild(e),p=e.querySelector('.play'),p.onclick=lazyLoadYoutubeIframe});</script>
<script>"use strict";function wprRemoveCPCSS(){var preload_stylesheets=document.querySelectorAll('link[data-rocket-async="style"][rel="preload"]');if(preload_stylesheets&&0<preload_stylesheets.length)for(var stylesheet_index=0;stylesheet_index<preload_stylesheets.length;stylesheet_index++){var media=preload_stylesheets[stylesheet_index].getAttribute("media")||"all";if(window.matchMedia(media).matches)return void setTimeout(wprRemoveCPCSS,200)}var elem=document.getElementById("rocket-critical-css");elem&&"remove"in elem&&elem.remove()}window.addEventListener?window.addEventListener("load",wprRemoveCPCSS):window.attachEvent&&window.attachEvent("onload",wprRemoveCPCSS);</script><noscript><link rel="stylesheet" href="https://www.linuxtoday.com/wp-content/cache/min/1/054cd28ea276727f224bab9f42f87051.css" media="all" data-minify="1" /></noscript></body>
</html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me -->