---

Tails Linux Users Warned Against Using the Tor Browser: Here’s Why!

A crucial fix for a dangerous vulnerability that bypasses security in Tor browser is due to arrive in Tails 5.1. Here’s what it is all about.