---

Mozilla Firefox 78 Enters Beta with Updated Minimal Linux System Requirements

Slated for release at the end of this month, the Firefox 78 web browser will boast updated minimal system requirements for GNU/Linux systems. Therefore, to be able to deploy or install Mozilla Firefox 78 on a GNU/Linux distribution, this will have to ship with GNU libc 2.17, GTK 3.14, and libstdc++ 4.8.1 or newer versions. Distros that don’t meet these minimal system requirements won’t be able to offer the latest Firefox release to their users.