---

Install Mind Blowing Xfce 4.12 Desktop Environment on Linux

Xfce 4.12 is still based on GTK+2 for but there is partial support for GTK+3 with Xf* programs being optionally allowed to support GTK3 in parallel.