---

Qualcomm patches widespread vulnerability, but most phones will remain at risk

Qualcomm has patched a vulnerability in netd (network_manager), which for the last five years has left devices vulnerable to having their text message or contact databases compromised. Qualcomm sent OEMs a fix for this problem back in March, but the gap in Android versions on the market means that most users are going to be out of luck.