---

CrossOver Now Offers Better Support for Running Diablo III on Ubuntu and Debian

CrossOver 14.1.3 is a very small release that fixes no more than two issues, one for the Mac OS X operating system and another of Ubuntu and Debian GNU/Linux distributions. With this new maintenance release of CrossOver, Linux users will be able to play the Diablo III game on recent versions of the popular Ubuntu and Debian GNU/Linux operating systems. It appears that CodeWeavers updated the GnuTLS library in CrossOver 14.1.3, which fixes various connection problems in certain applications, as well as other possible issues.