---

Gentoo Linux Advisories: kernel, phpMyAdmin


Gentoo Linux Security Advisory GLSA 200402-06
http://security.gentoo.org
Severity: Normal
Title: Linux kernel AMD64 ptrace vulnerability
Date: February 17, 2004
ID: 200402-06


Synopsis

A vulnerability has been discovered by in the ptrace emulation
code for AMD64 platforms when eflags are processed, allowing a
local user to obtain elevated priveleges.

Affected packages


Kernel Unaffected Version
ck-sources 2.6.2-r1
development-sources 2.6.2
gentoo-dev-sources 2.6.2
gentoo-sources 2.4.20-r12
gs-sources 2.4.25_pre7-r1
vanilla-prepatch-sources 2.4.25_rc3
vanilla-sources 2.4.24-r1

Description

A vulnerability has been discovered by Andi Kleen in the ptrace
emulation code for AMD64 platforms when eflags are processed,
allowing a local user to obtain elevated priveleges. The Common
Vulnerabilities and Exposures project has assigned CAN-2004-0001 to
this issue.

Impact

( Only users of the AMD64 platform are affected )

In this scenario, a user may be able to obtain elevated
priveleges, including root access. However, no public exploit is
known for the vulnerability at this time.

Workaround

There is no temporary workaround – a kernel upgrade is required.
A list of unaffected kernels is provided along with this
announcement.

Resolution

Users are encouraged to upgrade to the latest available sources
for their system:

# emerge sync
# emerge -pv your-favorite-sources
# emerge your-favorite-sources

~ # # Follow usual procedures for compiling and installing a
kernel.
~ # # If you use genkernel, run genkernel as you would do
normally.
~ # # See http://www.gentoo.org/doc/en/handbook/handbook.xml
for help.

Concerns?

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or
alternatively, you may file a bug at http://bugs.gentoo.org.


Gentoo Linux Security Advisory GLSA 200402-05
http://security.gentoo.org
Severity: Normal
Title: phpMyAdmin < 2.5.6-rc1 directory traversal attack
Date: February 17, 2004
Bugs: #40268
ID: 200402-05


Synopsis

A vulnerability in phpMyAdmin which was not properly verifying
user generated input could lead to a directory traversal
attack.

Description

A component of the phpMyAdmin software package (export.php) does
not properly verify input that is passed to it from a remote user.
Since the input is used to include other files, it is possible to
launch a directory traversal attack.

Impact

Sensitive information could be gleaned from the server if an
attacker uses a malformed URL such as
http://phpmyadmin.example.com/export.php?what=../../../[existing_file]

In this scenario, the script does not sanitize the “what”
argument passed to it, allowing directory traversal attacks to take
place, and disclosing the contents of files if the file is readable
as the web-server user.

Workaround

The workaround is to either patch the export.php file using the
referenced CVS patch [ 1 ] or upgrade the software via Portage.

Resolution

Users are encouraged to upgrade to phpMyAdmin-2.5.6_rc1:

# emerge sync
# emerge -pv ">=dev-db/phpmyadmin-2.5.6_rc1" # emerge ">=dev-db/phpmyadmin-2.5.6_rc1" # emerge clean

References

[ 1 ] CVS Patch export.php of phpMyAdmin:


http://cvs.sourceforge.net/viewcvs.py/phpmyadmin/phpMyAdmin/export.php?r1=2.3&r2=2.3.2.1

Concerns?

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or
alternatively, you may file a bug at http://bugs.gentoo.org.

Get the Free Newsletter!

Subscribe to Developer Insider for top news, trends, & analysis