Gentoo Linux Security Advisory GLSA 200410-29
Title: PuTTY: Pre-authentication buffer overflow
Date: October 27, 2004
PuTTY contains a vulnerability allowing an SSH server to execute
arbitrary code on the connecting client.
PuTTY is a free implementation of Telnet and SSH for Win32 and
Unix platforms, along with an xterm terminal emulator.
|1 net-misc/putty||<= 0.55||>= 0.56|
PuTTY fails to do proper bounds checking on SSH2_MSG_DEBUG
packets. The “stringlen” parameter value is incorrectly checked due
to signedness issues. Note that this vulnerability is similar to
the one described in GLSA 200408-04 but not the same.
When PuTTY connects to a server using the SSH2 protocol, an
attacker may be able to send specially crafted packets to the
client, resulting in the execution of arbitrary code with the
permissions of the user running PuTTY. Note that this is possible
during the authentication process but before host key
There is no known workaround at this time.
All PuTTY users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=net-misc/putty-0.56"
[ 1 ] iDEFENSE Security Advisory 10.27.04
[ 2 ] PuTTY ChangeLog
This GLSA and any updates to it are available for viewing at the
Gentoo Security Website:
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or
alternatively, you may file a bug at http://bugs.gentoo.org.
Copyright 2004 Gentoo Foundation, Inc; referenced text belongs
to its owner(s).
The contents of this document are licensed under the Creative
Commons – Attribution / Share Alike license.